Previous 1 10 11 12 13 14 Next 196 Replies Latest reply: Jun 1, 2015 1:11 AM by sarcastor Go to original post
  • jefftung Level 1 (0 points)

    I didn't do anything and now everything is working fine this morning.... And I upgraded 4 apps.

  • rks05 Level 1 (10 points)

    Hi- I used Bokmun's solution below and it worked for me:  Go into your "Purchased Apps" page and scroll down and manually update each app by pressing update.  Then, once done re-boot the iPad/phone & it may work normally from that point on (mine did).  Thanks again to these posts, solutions & in my case Bokmun's solution worked but the language one didn't ...but who knows why.  Thanks for posting the question. always helps to know others are encountering the same thing and then find out how it might be fixed.

  • rks05 Level 1 (10 points)

    Hi - thanks for your posting your solution.  It worked for me too.  I just went into "Purchased" and updated manually like you said, re-booted and now it works.  Thanks again for taking the time to post.

  • jd2020 Level 1 (15 points)

    For anyone still having problems, I located a solution that worked for me at SenseiPhone:

    http://senseiphone.com/app-store-loading-returned-white-blank-screen-10145364/

     

    The page lists a number of solutions, but the first one worked for me (after trying many in the Apple discussions).

    1. Turn off automatice time setting
    2. Set the clock forward one year
    3. Check for app updates (get error)
    4. Correct the clock time/date
    5. Check for update and get them!
  • Mehmet Cosmus Level 1 (0 points)

    Hi jd2020,

    Thanks for posting a solution but as we would all agree this kind of solution is not acceptable.

    Apple shall boldly stand and say that there is a problem and it will be fixed soon. I really do not understand these guys.

    There is certainly a problem and there is no explanation at all..

  • Vitu Level 2 (235 points)

    Tried almost all of the suggestions to no avail (the only missing is a complete restore). Even took the iPhone to a nearby shaman and not even that worked (go figure).

     

    The AppStore works on my daughter's iPodTouch (4g) but not on my iPhone 5 (neither via the same Wi-Fi network nor via 3G).

     

    Too many different 'solutions' and no uniform/logical way to solve the problem.

  • Taurus0426 Level 1 (0 points)

    Same problem here. I'm using an iPhone 5. The situation is: when I was playing a game, an add poped up and I clicked the add by mistake. Then I was automatically transferred to a downloading page in App Store. I switched back without waiting for the downloading page to complete loading. After that, the updates page in App Store became blank. The only difference is that the page is a bit darker. I guess there should be a "cover webpage" which blocks the view of the update page.

    I have had this problem for 2 days.

  • Mahmod manirawi Level 1 (0 points)

    I have problem with App Store. When I just try open it, white page come and there's buffering. That's mean App Store never open, but yesterday I was using it normally !!! How I can fix this problem plz?  Thx

  • Babinda Butterfly Level 1 (0 points)

    This also helped me thank you so much

    I had my teenage son have a look at it for me because I thought it was something I had done

    He came up with this solution and told me check into it further

    Once again THANK YOU

  • forsynthia Level 1 (0 points)

    Select the "Purchase" tab instead of the "Update" tab on the iPad and it will show all your apps that need to be updated. Select Update and it goes away.  This does not solve the original problem of why it isn't showing in the first place, but it is a quick temporary solution.

  • forsynthia Level 1 (0 points)

    Maybe if you have the same app on two devices it wants you to update on one device, not the other.  I believe I had the app on my iPhone first, so I bet it would show the update button on my iPhone.  If I had downloaded the app on my iPad first, it would show on my iPad.  I noticed all apps downloaded under your apple ID go to cloud.

  • Robert Mendicino Level 1 (0 points)

    I am having the same problem anyone know how it's fixed.  I do have a upper level support person helping me. I did send him this site. My case no is 472300022. Thanks

  • Cep907 Level 1 (0 points)

    I am having the same problem - went through all purchased apps and updated manually which was a pain.  Any explanation from Apple?

  • DCooke Level 1 (0 points)

    Same issue here on a wifi-only iPad running 6.1.3. Signing out of the App Store and powering down with wifi off did not resolve the issue. Scrolling through the purchased apps seems to be the only solution.

     

    Frustrating!

  • 💋Yara💫 Level 1 (0 points)

    Same here on iPad mini @ iOS 6.1.3. Had to update via workaround.  Very annoying. These issues and Apple's silence has me questioning myself on why do I bother with Apple devices. Everything was much more simpler back in the day with HP's iPAQ. Grrrr...