Previous 1 2 3 4 Next 46 Replies Latest reply: Jul 29, 2013 9:03 AM by gurruu Go to original post
  • nilesh73 Level 1 Level 1 (0 points)

    did every method reseting, restoring , changing language,  moving clock year ahead, logout login in app store, updating to ios 6.1 but nothing works on my iphone 4s

  • dtsuperstar Level 1 Level 1 (0 points)

    Im still having trouble with this, i have an iphone 4 & only just updated to ios 6.1, everything is working on the app store apart from a blank updates page. Tried everything i have seen online but nothing has fixed the problem. Any more ideas?

  • German123 Level 1 Level 1 (145 points)

    Reapetly tap top button and button button

  • akival Level 1 Level 1 (0 points)

    Me too! issue started right after the update to iOS 6.1. I've tried all your suggestions just now but still the same... :(( I had a chat conversation with the one of the apple support rep, I told her that i'm also a tech support and usually this kind of issue will be resolved by UPDATING the OS or uninstall/reinstall the APP STORE.. I explained to her that I did all the troubleshooting and she told me that the only way to reinstall the APP STORE is by RESTORING the phone. Haven't tried it yet because i'm still looking for any other way to resolve this without doing the RESTORE..if I couldn't find any other way I guess restoring would be my last resort. Anyone want to try it? And then tell me if it works on yours. Btw, i'm using 4s. Thanks

  • iheartzidane Level 1 Level 1 (0 points)

    I also updated to iOS 6.1 and the update screen is blank... I tried everything save restore like akival but I would really like to not do that if at all possible. I have just the 4. If anyone else tries something besides restore, I'd be willing to try that too!

  • German123 Level 1 Level 1 (145 points)

    Double tap the top and bottom  button

  • SPB333 Level 1 Level 1 (0 points)

    In response to Mustafa's instructions - I followed these steps, and it first looked as if it wasn't going to work.  But then I went into synced my phone and had to go back into the App store several times on my phone itself, but eventually they showed up.  After they came up I seleted Update All.  Still gave me some issues - an error over and over, but again eventually it updated each one. Very frustrating but at least it eventually worked.  Thanks!

  • raviprashanth Level 1 Level 1 (0 points)

    This worked for me Mustafa. Thanks a lot. I think after restarting, we need to go to Settings--- Login to Appl store with apple Id & then open the App Store ( Make sure before openning App Store) its not running at the background.

  • PVP84 Level 1 Level 1 (0 points)

    i was having the same issue but not resloved.. for iphone4

     

    i follwed the below steps..

     

    Signout from the Apple Store from Setting.

    Turn off all the running application.

    restart Iphone.

    Relogin in App store from Setting menu

    then open the APP store and check the update menu.

     

    Try may this help..

     

    Thanks to all for suggestions..

  • Etyam Level 1 Level 1 (0 points)

    Everything, I tried everything...nothing happens. Update page is blank. The other site like categories, features, genius works fine but update still blank with the 6 bubbles updates to do....

    :-((

  • German123 Level 1 Level 1 (145 points)

    Just update them on itunes or Icloud

  • gurruu Level 1 Level 1 (0 points)

    Guys try to restore phone software using iTunes and u won't have that problem

  • Richard Morris Level 1 Level 1 (145 points)

    Broken here on all my iPhones intermittently for weeks now. Very frustrating. Sometimes it's only broken on one of them and the other two are fine.

  • sandeepgv Level 1 Level 1 (0 points)

    I faced the Same Issue. It is resolved by changing the language at Settings-->General-->International-Language. Change the Current Language ( I have changed it from British English to English). Then after a succesful change, Go to Appstore- Updates. The Issue is resolved. Now go back to your original Setting (if required)

  • jd2020 Level 1 Level 1 (15 points)

    For anyone still having problems, SenseiPhone.com has a good troubleshooting checklist.  The time change worked for me, while language, etc didn't.  The page here gives you a step-by-step approach to problem solving the blank app update screen:

    http://senseiphone.com/app-store-loading-returned-white-blank-screen-10145364/

     

    Maybe it will help...