8 Replies Latest reply: Jan 24, 2013 1:53 PM by davidsignal
tal1971 Level 2 (245 points)

I have just received my first Mac and I'm having some issues with iMessage.

 

 

Basically I'm wanting to know if its possible to have iMessages coming through on both my iPhone and iMac at the same time, so that I can pick the iMessage up on whichever device I'm nearest too and if so, how is this done?


iMac (27-inch, Late 2012), OS X Mountain Lion (10.8.2), iPad (3rd Gen) 32GB iPhone 5 32GB
  • leroydouglas Level 6 (17,827 points)

    Yes, designed to just that.

     

    Mac >Sys Pref>Messages

     

    iphone>Settings>Messages

  • davidsignal Level 3 (540 points)

    Yes, works that way for me.  You just need to put your telephone number in iMessage (and have iMessage running).

  • tal1971 Level 2 (245 points)

    leroydouglas wrote:

     

    Yes, designed to just that.

     

    Mac >Sys Pref>Messages

     

    iphone>Settings>Messages

    I don't see Messages in System Preferences on my iMac leroy.

  • tal1971 Level 2 (245 points)

    djcastaldo wrote:

     

    Yes, works that way for me.  You just need to put your telephone number in iMessage (and have iMessage running).

     

     

    I have my telephone number shown in Settings/Messages/Send & Receive, on my iPhone.

     

    On my iMac I have the following:
    Screen Shot 2013-01-24 at 21.05.29.png
  • leroydouglas Level 6 (17,827 points)

    tal1971 wrote:

     

    leroydouglas wrote:

     

    Yes, designed to just that.

     

    Mac >Sys Pref>Messages> Preferences

     

    iphone>Settings>Messages

    I don't see Messages in System Preferences on my iMac leroy.

    Right, correct that to read:

     

    Messages>Preferences

  • davidsignal Level 3 (540 points)

    It appears as though you have it set up right.  It works for me for both text messages and facetime calls.  I can't see what your phone number looks like with the black bar you put there, but does it look like this:

     

    +44 1234 123456 ?

     

    I ask because this is how my UK number was formated automatically, so possibly yours was not actually input as a phone number.

     

    EDIT (heres a picture):

    screen.jpg

  • tal1971 Level 2 (245 points)

    djcastaldo wrote:

     

    It appears as though you have it set up right.  It works for me for both text messages and facetime calls.  I can't see what your phone number looks like with the black bar you put there, but does it look like this:

     

    +44 1234 123456 ?

     

    I ask because this is how my UK number was formated automatically, so possibly yours was not actually input as a phone number.

     

     

    Thanks djcastaldo.

     

    My telephone number appears the way youve mentioned.

  • davidsignal Level 3 (540 points)

    well try deleting it and adding it again then, you should get a confirmation on your iPhone when you add its number to your mac's imessage.