3 Replies Latest reply: Jul 9, 2013 7:00 AM by nevoba
j1111 Level 1 (0 points)

I recently set up iCal to import my calandars from an Exchange server at work.  On my work calendar, I added an event that repeats daily, but has no invitees.  iCal is now telling me that I have "entered an invitee that wasn't recognized by the server."  There are no invitees on this calendar.  I tried adding an invitee to see if that would clear the error.  iCal initiated a meeting request via the Exchange server, but the error remained in place.  Any ideas how I can fix this would be greatly appreciated.  I am using iCal 6.0 on a 2.53 GHz Intel MacBook Pro.  All software is up to date.

MacBook Pro (15-inch 2.53 GHz), iOS 6.0.2
  • tvz052 Level 1 (0 points)

    I have had this problem for a long time, well over a year. I have searched many forums for a solution. I find many similar complaints (along with various other errors that also plague me). Various solutions are provided (delete the account and re-enable, all the way to a fresh install of Mac OS X) but none are more than temporary. Apple has not addressed this. What is more, when this error comes up, iCal can stop synching with the server, which has several times left me with missed appointments. I wish I didn't hate Outlook even more. Does anyone know of a good calendar program that works the Mac and works properly with an Exchange server?

  • sri111 Level 1 (0 points)

    I, too, have searched several forums and tried many solutions.  But nothing works.  This is terribly annoying. Apple, please fix already!

  • nevoba Level 1 (0 points)

    I just had this issue and finally resolved it. Just find all of your apple devices that connect to the exchange calendar and make sure that all of the alerts are set to "none" this includes mobile devices, desktops and laptops. For some reason whenever you have "All Day Events:" alerts set to "1 day before (9AM)" the device will put a reminder in the exchange server calendar, which then causes other apple devices to convert the event into a meeting without any invitees. Don't ask my why this happens, i've already submitted a bug report to apple and no response yet. This is totally reproduceable.