6 Replies Latest reply: Jan 24, 2013 9:06 PM by randers4
Gaye M Level 1 Level 1 (0 points)

I add appointments to Calendar on my iPhone, but it doesn't synch with iCloud.  The appointments don't appear on my Mac calendar, and are not on iCloud calendar.  I've tried switching to another app, then back to calendar.  I've restarted Mac.  I've checked that all the preferences are on both on my iPhone and on Mac to use Calendar, and that the appropriate calendar has a check-mark in its box so the items will appear.  For notifications, it has "Push"  Not sure whether that's the issue, instead of my devices going up and checking every so many minutes. 

 

Can someone help?  It's the new iPhone 5, Calendar 6.0, and using Mountain Lion on my Mac


iPhone 5, iOS 6.0.2
  • randers4 Level 9 Level 9 (62,585 points)

    On your phone go to Settings>Mail,Contacts,Calendars>Default Calendar (in the Calendars section).  Here confirm that you have selected a calendar listed under your iCloud account name as your default, and not something else such as a calendar under On My iPhone.  If you haven't, make this change, then add a new event on your iPhone calendar and see if it syncs to icloud.com and your Mac now.

  • Gaye M Level 1 Level 1 (0 points)

    Did this along with the other things I listed.

    I tried Reset on the phone, logged out and restarted the Mac and did a hard reboot (hold down Sleep Button and Home button on iPhone until apple appeared) and the calendar synched from iPhone to iCloud calender.  It updated on my Mac calendar (iCloud) as well.  However, now everything in my calendar and contacts is duplicated.  iCloud has its head in the clouds when I need its feet on the ground.

  • randers4 Level 9 Level 9 (62,585 points)

    If calendar events added to your phone are not appearing on icloud.com or on your Mac the problem is with your phone, not your computer.  If the calendar on your Mac and on icloud.com are up to date, containing all your events, try going to Settings>iCloud, turn Calendars to Off, when prompted about what to do with the iCloud calendar choose Delete from My iPhone, wait a minute or two, then turn Calendars back to On to transfer the iCloud calendar back to your phone.  Then try entering a new event on your phone again and see if it syncs this time.

  • Gaye M Level 1 Level 1 (0 points)

    Have resolved the synching issue (see above.)

     

    Now, however, all calendar entries and contacts appear twice - does anyone have a fix for that?

     

    I see a lot of questions on the same issues for iCloud.  Is anyone else worried about having all your personal info up there on the web, rather than on your hardware - personal Mac or PC?

     

    And what to do about the duplications from iCloud?

  • Gaye M Level 1 Level 1 (0 points)

    Did that too, and then performed a Reset.  That helped.  Thank you!

     

    However, now have duplicates of every calendar event and contact....

  • randers4 Level 9 Level 9 (62,585 points)

    Sorry your having so many problems.  Mine works all the time...once you get it working it tends to work very well. 

    I don't know of an easy solution for fixing duplicate calendar entries other than going to iclould.com and manually deleting them.  Apple's troubleshooting steps for this are:

    Confirm you are experiencing this specific issue by logging in to iCloud Calendar at icloud.com/calendar to see if your calendars are duplicated there.

    • If your calendars are not duplicated on the iCloud website (but they are in Calendar, iCal, or Microsoft Outlook) see this article for instructions on resolving the issue.
    • If your calendars are duplicated on iCloud.com, contact iCloud Support.

     

    For contacts, you can open Contacts on your Mac and go to Card>Look For Duplicates, then Merge any duplicates found.