1 Reply Latest reply: Jan 25, 2013 12:43 AM by sig
Angela Zou Level 1 Level 1 (0 points)

  I have a weird DNS problem on my macbook, which is in my home network connecting using ADSL router over a PPPoE. There is another computer in the same network that has no trouble connecting. And the Ubuntu VM that runs on this Mac (using a bridged connection) also has no problem connecting at all.

 

  On the mac itself, I can ping different IP addresses without any problem. In my /etc/resolv.conf, there are 3 DNS servers, first one is the ADSL wireless router itself, and the other two are the primary and secondary DNS servers that I have copied from the ADSL config (obtained after PPPoE connection). Interestingly, digs and nslookups return fine results as well (status:noerror).

 

  At first, I thought this may be from reminiscing DNS cache. So I flushed the local DNS cache (using something like dnsutil -flushcache), I resetted the ADSL wireless router and reconfigured, and I also asked the network admin to reset the PPPoE connection as well.

 

  I have also tried using 8.8.8.8 as my DNS server as well as connecting while VM is shut down (so no, this is not a VM problem as I thought it was). However, nothing solved this problem. Any inputs are appreciated.

 

Regards,

Angela


2009, Mac OS X (10.5.8), Aluminum Unibody, 2.4 GHz, 250 GB hard disk drive, 4GB RAM