5 Replies Latest reply: Jan 25, 2013 12:32 PM by Krischan
Krischan Level 1 Level 1 (0 points)

Hello,

 

I run the latest version of Aperture on my MacBook under 10.7 Lion with a shared iPhoto library. I've purchased a Nikon V1 in late 2012 shooting in RAW (.NEF).

 

During the import, Aperture recognized and converted all images correctly. However, a few days later, a strange thing happened: Some of the images display a black  "unknown image format" frame (in German "unbekanntes Bildformat"). This is weird because other pictures from the same series and with the same camera settings are displayed correctly. What I did was to export the broken files and reimported them – everything was okay then.

 

Now, the same thing happened again in a different image series. This is what it looks like (first five images are shown correctly, I pixellated them manually before uploading):

 

Bildschirmfoto 2013-01-25 um 08-1.15.21.pngBildschirmfoto 2013-01-25 um 08.15.03.png

I could surely export and reimport the images like I did before but I'm afraid that this problem might reappear again and again. By the way, I never had this problem with NEFs from my old Nikon D50.

 

Thanks for your help

Christian

  • 1. Re: Nikon V1 RAW images: strange "unknown image format" message
    Owen A Level 2 Level 2 (215 points)

    What version of RAW Camera do you have? You should be on 4.03. You can find the version by going to 'Aperture' in the menu bar and selecting 'About Aperture'.

     

    Also, have you tried to reprocess the originals from the 'Photos' menu bar option?

  • 2. Re: Nikon V1 RAW images: strange "unknown image format" message
    léonie Level 9 Level 9 (51,775 points)

    Krischan,

    I run the latest version of Aperture on my MacBook under 10.7 Lion with a shared iPhoto library.

     

    In addition to Owen's suggestions.

    Are you switching between iPhoto and Aperture? Do you see the "unbekanntes Bildformat" after opening the library in iPhoto?

     

    You may have a problem with the shared library. I'd try to repair the permissions and to repair the library, just to be sure it is in working condition.

     

    Are your raw images referenced or managed? And is the library on an external drive or on an internal drive?

     

    Regards

    Léonie

  • 3. Re: Nikon V1 RAW images: strange "unknown image format" message
    Krischan Level 1 Level 1 (0 points)

    My Camera RAW version is 4.0.3.

     

    Yes, I am switching between iPhoto and Aperture. The shared library is locally under /Users/Shared where my wife (with iPhoto) and me (mainly with Aperture) access it from our own user accounts. All images are managed on the internal HD, not referenced.

     

    When I just checked it from my wife's iPhoto account, the images were okay. Only Aperture showed the black frames and interestingly considered the images to be 900x600px.

     

    I then had to idea to select "Vorschaubild aktualisieren" (presumably "update preview image") from the context menu in Aperture and, to my surprise, it worked Didn't expect that it was a problem with the preview image because the error message suggested something different.

     

    I will additionally repair the library as LeonieDF suggested. Thanks to you and I hope that this won't happen too often.

  • 4. Re: Nikon V1 RAW images: strange "unknown image format" message
    léonie Level 9 Level 9 (51,775 points)

    If you share the library in a shared folder, you probably are having a permissions problem.

    Then it should suffice to repair the permission, and not the datbase.

     

    The problem with sharing a library:

    Whenever your wife is writing to the iPhoto/Aperture library, the ownership of files inside the library bundle will change. She is the owner, that is why she still can see them, but you are not.

    A "Shared" folder is not sufficient to ensure, that you can both use the library safely. It would be better to move the library to a separate partion, disk, or writable disk image, with the "Ignore Ownership on this Volume" flag set. This support article explains, how set up a library to share between two users, see:

     

    http://support.apple.com/kb/HT1198

     

    Regards

    Léonie

  • 5. Re: Nikon V1 RAW images: strange "unknown image format" message
    Krischan Level 1 Level 1 (0 points)

    Ah, ok. So I will either try the disk image or the partition solution.

     

    Thanks again,

    Christian