Previous 1 2 Next 10 Replies Latest reply: Jan 25, 2013 2:40 PM by zombi3g
TeknikEnzo Level 1 (0 points)

I'm getting horribly frustrated. I have spent the last day (probably 16 hours or more) trying to install bootcamp on my mac. It worked fine in the past but apparently now my superdrive is dead. So I have been trying countless methods of installing without a disc. Finally I found a way to have bootcamp just make me a bootable USB and install that way.

 

Lo and behold, it partitions and restarts, then boots to a "No bootable drive detected.. Insert disk and press any key" but it just sits there.

Holding option at startup does nothing, holding Command + Option + P + R at start up does nothing, holding shift at startup does nothing..

 

I have rEFIt installed if that has any bearing on it.

I'm trying really hard to keep myself from typing hundreds of curse words right now... I just want my computer back.


iMac, OS X Mountain Lion (10.8.2)
  • Csound1 Level 8 (46,987 points)

    You can't install from a USB stick if your Mac has a superdrive. Repair the drive and install from Disk.

  • TeknikEnzo Level 1 (0 points)

    That wouldn't help anyways.

    I don't care about boot camp anymore. I just want my computer to boot to OS X but it won't.

    Just loads up that horrid "No bootable drive" screen and refuses to allow me to do anything else.

  • Csound1 Level 8 (46,987 points)

    Reboot, hold the option key down at the sound of the chime, when the boot manager appears select OSX. Once booted go to System Preferences>Startup Disk, and make your choice permanent.

  • TeknikEnzo Level 1 (0 points)

    From my original post:

    "Holding option at startup does nothing, holding Command + Option + P + R at start up does nothing, holding shift at startup does nothing."

  • zombi3g Level 1 (40 points)

    It sounds like you might have selected the OS X partition to format as NTFS during Windows installation instead of the Boot Camp partition. During your Boot Camp installation did you get as far as selecting a drive in the Windows installer? If not, then perhaps the drive has gone bad?

     

    Try starting the computer from the Recovery System by holding down command-R at startup. If the built-in drive is not bootable, you should be presented with a network-bootable version instead.

     

    http://support.apple.com/kb/HT4718

     

    If you can get as far as Recovery System, then use Disk Utility from Recovery to check your drive and partitions.

     

    http://support.apple.com/kb/HT1782

  • Csound1 Level 8 (46,987 points)

    TeknikEnzo wrote:

     

    From my original post:

    "Holding option at startup does nothing, holding Command + Option + P + R at start up does nothing, holding shift at startup does nothing."

    Take it to an Apple Store, if you can't access the Boot Manager there is little else to do.

  • TeknikEnzo Level 1 (0 points)

    No, I never even got to the windows installation screen.

    Only thing i can imagine is going on is it's trying to boot into the Windows installation but that isn't working for some reason, and my keyboard isn't being enabled during startup so the key presses aren't being registered.

     

    Cmd + R doesn't work either.. I sincerely hope I don't have to take it to an Apple Store. I didn't have money for Apple Care and I dont' have money to pay for service.

     

    I'm going back to PC after this...

  • zombi3g Level 1 (40 points)

    If you are using a wireless keyboard, try a wired keyboard if you have access to one. Any USB keyboard should work (even one from a PC). The only difference is that you may have to use Alt-R or Windows-R on a PC keyboard to get to the Recovery System because the Option/Alt key may be mapped differently on a Windows keyboard.

     

    If none of the "snag" keys at boot are working, it may just be that your wireless keyboard isn't working right or your timing is wrong when pressing the keys.

     

    http://support.apple.com/kb/TS3273

     

    Hope this helps!

  • TeknikEnzo Level 1 (0 points)

    I'm using an Apple Wired keyboard and I have tried it on a windows wired keyboard.

     

    I've tried all the commands I can find before, during and after the chime, several times each. This thing is about to go out the window. I don't know what else to do.

  • Csound1 Level 8 (46,987 points)

    It is 'at the sound of the chime' i.e the beginning, not before and not after, and it is once.

     

    Turn the machine off, wait a few seconds and turn it on, press the option key and hold it down until the boot manager appears, do it At The Sound of the chime. Post back.

  • TeknikEnzo Level 1 (0 points)

    Did exactly what I expected.

    Sat on the gray screen for 30 seconds then went to "No bootable drive" screen.

  • Csound1 Level 8 (46,987 points)

    Try a verbose (or single user) boot, if it works poast back, don't enter anything, I just want to know if you can boot this way.

     

    Look at this:

     

    Starting up in single-user or verbose mode

      1. Shut down your Mac if it is on.
      2. Press the power button to start the computer.
      3. Immediately press and hold the Command (Apple) key and one of the following:
      • the "s" key for single-user mode.  (Command-S)
      • the "v" key for verbose mode.  (Command-V)

    You have successfully entered single-user or verbose mode when you see white text appear on the screen.To exit single-user mode type reboot  then press Return. Verbose mode exits automatically when the computer's startup process progresses sufficiently and the blue screen appears.If the computer does not progress beyond verbose mode, and does not show progression messages, press the power button until the computer shuts down. See this article for information about troubleshooting startup issues.

    Additional Information

    Notes

    • If you do not develop software, verbose and single-user modes are only needed when troubleshooting a startup issue.
    • You cannot enter single-user or verbose mode if the computer owner or administrator has enabled Open Firmware Password Protection.
    • When in single-user mode, the keyboard layout is US English.
  • zombi3g Level 1 (40 points)

    Thanks for following up with results. If you are seeing a blank gray screen and don't even get the Apple logo, single-user or verbose mode likely won't work either. I don't think it's getting far enough in the process for those to work.

     

    Next thing I'd try is to unplug the iMac from AC power for a couple of minutes (just unplug the AC power cord from the outlet). This should reset the computer's SMC. Then plug AC power back in, start up the computer and try holding down Command-Option-R at startup instead. This should force the network boot of the Recovery System.

     

    http://www.cultofmac.com/106669/force-lion-to-start-internet-recovery-on-your-20 11-or-later-mac-os-x-tips/

     

    Best of luck!

  • TeknikEnzo Level 1 (0 points)

    It doesn't work either.. Just goes to the same screen as always.

    Boot camp did this to itself. Nothing else I did ever did this.

     

    Edit: This response was to the Verbose/Single user mode thing.

    I've unplugged my mac and will try this other solution soon.

Previous 1 2 Next