Previous 1 2 3 Next 42 Replies Latest reply: Nov 25, 2015 6:15 AM by legacypgmr
copydeskcat Level 1 (0 points)

Hi folks,

 

I've had a Mac Mini since January 2012.

 

It's a 2.5ghz with 8gb 1333 DDR.

 

I have a VirginMedia internet connection using a Belkin Superhub.

 

Initially, I was running Lion and the Mac worked a treat without any problems. Then I upgraded to Mountain Lion.

 

Shortly afterwards, I started getting internet drop-off on wifi roughly every hour or so. All access to the internet would cease for around 3-4 minutes - nothing would bring it back. I thought it was a wifi problem, so I purchased two D-Link 500 Powerline adaptors and moved to Ethernet (shutting down wifi). The problem persisted.

 

The problem does not occur on any other device in the house (I have two iPhone 5, two iPod Touches, a laptop, xBox, iPad and AppleTV). When it happens on the Mac, I can access the internet freely on all the other devices while the Mac sits frozen. I can perform any other activities on the Mac at the time, just not the internet.

 

The kind of message I was getting in Console referred to mdworker and "heartbeat detected".

 

I got Virgin out to test my connection, but the line is fine and my setup on the router is fine.

 

I set a dedicated IP address for the Mac on the router, and set the Mac to use DHCP with a specific IP address.

 

I set the router to filter the Mac via its Mac address. The problem persisted.

 

So, with five days of my warranty remaining, I took it to Apple and they tested it - but could not replicated the problem, so they assumed it was an environmental issue and sent me home with my Mac Mini.

 

As soon as I got home, the problem returned - losing the internet connection roughly once an hour for 3-4 minutes.

 

So, I reinstalled Mountain Lion. The problem persisted.

 

So, I wiped the drive and installed a fresh version of Mountain Lion. The problem persisted.

 

I took it back to Apple and they agreed to look at it again, even though I was now out of warranty. They couldn't replicate the problem.

 

They put me back to Lion and I took the Mac home. So far so good - the Mac seemed to be working fine.

 

Then, the problem returned - albeit in a slightly different fashion. I still get the internet freezing roughly every hour or so, but it's now for only about 20 seconds at a time.

 

When it happens now, I get this kind of message:

 

26/01/2013 12:30:44.923 com.apple.usbmuxd: _handle_timer heartbeat detected detach for device 0x54-192.168.0.14:0!

 

I thought it was perhaps Spotlight trying to index an external drive - but I've exluded the drive from being indexed, and it's still happening.

 

I'm convinced the Mac is faulty, but can't prove it - and Apple keep saying it's environmental.

 

Does anyone have any idea what might be causing this? I would really appreciate some help.

 

Best,

 

 

 

CDC

  • BDAqua Level 10 (122,276 points)

    com.apple.usbmuxd

    What iDevices do you have around?

     

    System Preferences>Network, click on the little gear at the bottom next to the + & - icons, (unlock lock first if locked), choose Set Service Order.

     

    The interface that connects to the Internet should be dragged to the top of the list.

  • copydeskcat Level 1 (0 points)

    I have:

     

    two iphone 5s, two iPod Touches, AppleTV, an iPad.

     

    I've already done the network Service Ordering - it doesn't make any difference. I've tried deleting the connection and creating a new one, that doesn't change it either. It still cuts off.

  • BDAqua Level 10 (122,276 points)

    Well, is that error with iDevices disconnecting at the same time as the Wifi problem? I assume the others are using Bluetooth?

  • copydeskcat Level 1 (0 points)

    Bluetooth isn't enabled.

     

    When it was happening on ML, I wasn't getting the idevice messages.

     

    It's happening on Ethernet (with wifi disabled), but it also happens on wifi if I enable wifi and disable Ethernet regardless.

  • copydeskcat Level 1 (0 points)

    Apologies, Bluetooth is enabled for my keyboard.

  • BDAqua Level 10 (122,276 points)

    To find out if it's system wide or user specific, try this...

     

    Open System Preferences>Users & Groups, unlock the lock, click on the little plus icon, make a new admin account, log out & into the new account.

     

    Does it happen in the new account?

  • copydeskcat Level 1 (0 points)

    Yeah - it happens on other accounts.

     

    Here's a message I got today when it cut out for the better part of four minutes:

     

    28/01/2013 12:16:52.491 com.apple.SecurityServer: Killing auth hosts

    28/01/2013 12:16:52.491 com.apple.SecurityServer: Session 100045 destroyed

  • BDAqua Level 10 (122,276 points)

    I forget, do we have any anti Virus SW running? Any 3rd party stuff that you know of? Is the App Store running?

  • copydeskcat Level 1 (0 points)

    There's no anti-virus sofrware running.

     

    The only third-party stuff I have running is:

     

    KeyRemapper (remaps my @ key to the " key)

    AirVideo (the problem happens if I shut AirVideo down)

    App Store is not running

  • BDAqua Level 10 (122,276 points)

    Make a New Location, Using network locations in Mac OS X ...

     

    http://support.apple.com/kb/HT2712

     

    10.7 & 10.8…

     

    System Preferences>Network, top of window>Locations>Edit Locations, little plus icon, give it a name.

     

     

    10.5.x/10.6.x/10.7.x instructions...

     

    System Preferences>Network, click on the little gear at the bottom next to the + & - icons, (unlock lock first if locked), choose Set Service Order.

     

    The interface that connects to the Internet should be dragged to the top of the list.

     

    10.4 instructions...

     

    Is that Interface dragged to the top of Network>Show:>Network Port Configurations.

    If using Wifi/Airport...

     

    Instead of joining your Network from the list, click the WiFi icon at the top, and click join other network. Fill in everything as needed.

     

    For 10.5/10.6/10.7/10.8, System Preferences>Network, unlock the lock if need be, highlight the Interface you use to connect to Internet, click on the advanced button, click on the DNS tab, click on the little plus icon, then add these numbers...

     

    208.67.222.222

    208.67.220.220

     

    Click OK.

  • copydeskcat Level 1 (0 points)

    BDAqua - I've re-ordered the networks on numerous occassions, but it makes no difference.

     

    I'm away from the house at the moment, but I'll try the OpenDNS change and let you know if it makes any difference - although, I don't think it will, as I have no issues with the other numerous devices in the house that connect to the web using my ISPs default DNS.

  • BDAqua Level 10 (122,276 points)

    Just wondering though, have you reordered the interfaces using a new location yet?

  • copydeskcat Level 1 (0 points)

    Yes. I've done that. It didn't make any difference.

  • BDAqua Level 10 (122,276 points)

    About the only thing left is Microwave interference or flaky Hardware.

     

    http://store.bearextender.com/products/bearextender-mini

     

    http://eshop.macsales.com/item/NewerTech/MXP3802NU2C/

Previous 1 2 3 Next