3 Replies Latest reply: Nov 18, 2013 11:55 PM by cheonweb
Mcj1992 Level 1 Level 1 (0 points)

It somehow unchecked itself in the iMessage send and receive messages from section and now I can only send messages through my email. How can I fix that


iPhone 4, iOS 6.0.1
  • cheonweb Level 4 Level 4 (3,445 points)

    By turning iMessage OFF for a few seconds and then back ON?

  • drantoniadis Level 1 Level 1 (0 points)

    DrantoniadisAthens

     

    1. Go to settings, Icloud and delete account. Put your Apple id  to delete but keep content in your Iphone.

    2. Go to settings, itunes and appstore and click on your apple id and select sign out

    3. Then go to imessage, send and receive, click on your apple id and select sign out

    4.  Do the same with facetime. At this point imessage and facetime is  turned off and e-mail info and apple id are not set for  appstore,icloud,imessage and facetime.

    5. Power off your phone and wait for 10 minutes

    6.  Turn on your phone. Go to imessage and turn it on and wait for a couple  of minutes to activate. DO NOT use your apple id for imessage because  that's the reason the # does not register. After your # is ok then you  can add another e-mail and sign in your icloud and appstore account.

     

    Greetings from Greece

  • cheonweb Level 4 Level 4 (3,445 points)

    iCloud, ITunes and App Store and FaceTime has nothing to do with iMessage. All you need is to turn off iMessage for a while and then turn it back on and tap ok to send the activation SMS.