Previous 1 2 Next 15 Replies Latest reply: Jan 30, 2013 5:22 PM by MacMyDrive
MacMyDrive Level 1 (0 points)

I've watched an episode of Parenthood before on Hulu with no problem. Recently, however, with the scare about Java's weakness, I disabled it on Safari's security but left JavaScript alone. Just now, though, I tried watching the latest Parenthood episode on Hulu but all I got was a white screen with this notice:

It appears that software on your computer is blocking JavaScript. To enjoy, you'll need to enable JavaScript in your web browser. Please configure your security software or browser plugins to allow to load JavaScript.


But I never disabled JavaScript! I even went back and enabled Java again but that didn't help.  Sorry I don't know how to configure my browser plugins and any advice would be appreciated.

Mac Mini, Mac OS X (10.6.7)
  • a brody Level 9 (65,706 points)

    Upgrade to 10.6.8 and run the latest  Then you should be able to disable Java without issue.

  • MacMyDrive Level 1 (0 points)

    But I already have 10.6.8 and I didn't have a problem disabling Java, you just click on the enable Java box so it's unchecked and it's disabled, according to what I've read elswhere, here. Hulu is saying my JavaScript is diabled and it's not, I never clicked on the JavaScript box to disable it!

  • a brody Level 9 (65,706 points)

    Then contact Hulu support and ask them if they know whether or not their software still works with 10.6.8.

  • MacMyDrive Level 1 (0 points)

    Thanks, I did email Hulu and am waiting for a reply. I also clicked on the link you gave me and tried downloading the latest Java in case that was the problem. But I was unable to download because I kept getting the message that the disk was not recognized, whatever that means. Anyway, hoping to hear from Hulu before too long.

  • a brody Level 9 (65,706 points)

    Go to Hard drive -> Library -> Internet Plugins and check you have Flash Player.plugin with a verison of or later.    And Quicktime 7.6.6 or later.

  • MacMyDrive Level 1 (0 points)

    I have both plugins with Flash player modified in Jan. and Quicktime modified in Dec. Found Quicktime's version # in Applications and it's 10.0. Pretty sure my Flash player is the latest version too, although I can never find it in Applications. I'll have to go to its website for the latest download and see if I already have it.

  • Lanny Level 5 (6,917 points)

    Pretty sure my Flash player is the latest version too, although I can never find it in Applications.

    That's because it's not in the Applications folder. It's in the Internet Plug-Ins folder.


    Screen Shot 2013-01-28 at 1.19.49 AM.jpg

  • MacMyDrive Level 1 (0 points)

    Yes, as I said, I did find Flash Player in the Internet Plug-Ins folder and when they were modified. I was just looking around to see if I could find what version I have. I went to Flash Player's website and I have the latest version, plus I also went to YouTube and was able to play a video so looks like there's nothing wrong with it. Still waiting for an answer from Hulu.

  • Lanny Level 5 (6,917 points)

    Duh, the info is given right in the Finder:


    Screen Shot 2013-01-28 at 9.52.44 AM.jpg


    You could also use Command I


    Screen Shot 2013-01-28 at 9.54.56 AM.jpg


    Or, the System Preferences:


    Screen Shot 2013-01-28 at 9.56.26 AM.jpg

  • MacMyDrive Level 1 (0 points)

    Duh, I did look in Finder, but when I clicked on Flash plug-in, it went into Preview with a gray box showing up that said: oom-large.bmp. However I did find it in Systems Preference as you suggested and it shows I have the latest version, so thanks.

  • Lanny Level 5 (6,917 points)
    when I clicked on Flash plug-in, it went into Preview with a gray box showing up that said: oom-large.bmp.


    You must have double clicked it. Just click on it once to highlight it. Once highlighted, press Command I, that command gives you the Get Info pane.


    This works for any file or icon in OSX. Command-I, where the I is for Information.

  • MacMyDrive Level 1 (0 points)

    Got it! Thanks again.

  • MacMyDrive Level 1 (0 points)

    Well, I never heard from Hulu so I don't know if they read my email, but tonight I decided to try again, and this  time it worked! Just finshed watching the Parenthood finale. Good night all and thanks again for the help.

  • itlogo Level 1 (0 points)

    I was getting the exact same error, and I have JS enabled with the latest Flash.  For me, it was because I was connected to my company's VPN gateway that caused to think that I had disabled JS.  I'm not sure what Hulu is [incorrectly] detecting about my setup, but once I disconnected from the VPN, I could watch movies again.


    For reference, the CheckPoint VPN client adds static routes to the client to only route company traffic through the gateways.  All traffic not destined for the company network addresses goes through the client's default route as before.  That's the VPN policy for my company, anyways, so not sure why Hulu traffic would've cared whether I was connected to the VPN or not.  All traffic from my computer to Hulu went through the default route outside of the VPN.

Previous 1 2 Next