3 Replies Latest reply: Feb 1, 2013 12:00 AM by Black_Cat55
Black_Cat55 Level 1 (0 points)

Hello, 4 days ago I used time machine to move my files to a new iMac, and now I'm having problems ejecting time machine and ejecting CDs from my USB Superdrive. I'm getting the "Drive is in use by one or more programs" error. I've done some digging and found that Spotlight is the problem, but nothing I've tried fixes it. My iMac is a 27" 13,2 and my OS is 10.8.2. My Time Machine drive is a Seagate GoFlex 500MB



My symptoms

-MDS is the only process using the time machine drive and the optical drive. I found this out using a terminal command "sudo lsof /Volumes/"TM-drive-name""

When trying to eject time machine, the log shows "code validation failed in the process of getting signing information."

-I constantly get new "[[DMManager alloc] init] failed!" errors without doing any sort of activity.

-When failing to eject the optical drive, I only saw the DMManager error.

-When I first migrated everything to my iMac, Time Machine did NOT make a full backup as I was told it would.


Common issues that are not symptoms in my case

-Spotlight does not actively show that it is indexing the drive with the magnifying glass, and I can't find anything in the log about it indexing time machine.

-No other log errors besides the two I mentioned are present while I'm backing up, or while I'm trying to eject the drive.

-Time Machine runs normally. It is not slow and the backups are successful.


What I've tried to fix the problem:

  -I set the time machine drive to private in spotlight and later rebooted. I still couldn't eject Time Machine. Of course, I can't actually add the time machine files to private.

  -The optical drive issue was resolved after setting the disc to private in spotlight and rebooting. I only had this problem with the optical drive once and have not used the drive since. I think I'm going to have to manually set every disk I use to private unless there's a way of excluding the hardware itself and not just the disk name. Is there?

  -I ran "Verify Disk" in disk utility on the TM drive and my internal HD. Both drives are clean.

  -I reindexed spotlight using "sudo rm -rf /.spotlight-V100". It did not work, nor did it take as long to execute as the website I read this advice from said it would.

  -I unloaded Spotlight Daemon with "sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist" and reloaded. This did not fix either the optical drive or Time Machine.

-I did this, which did not work. I don't know what it was supposed to do.

    1. Go to Time Machine System Preferences.
    2. Turn Time Machine off.
    3. Go to Options and set the backup disk to "None".
    4. Start Terminal.app
    5. execute: sudo mdutil -i off -V /Volumes/Backups
    6. execute: sudo mdutil -E -V /Volumes/Backups

  -Tried changing my screen resolution, unindexing and reindexing a couple of folders.

  -Turning off the computer and disconnecting time machine DOES work but my drive makes the "Disconnnected improperly" noise. I think theoretically it should be safe, but I don't want to do it too often.



Any help please

iMac, OS X Mountain Lion (10.8.2)