Previous 1 2 Next 21 Replies Latest reply: Oct 10, 2006 11:57 PM by Bundy
Julia Kelly1 Level 1 Level 1 (5 points)
I have installed the office:mac 2004 version but when I try to open any of office applications while trying to optimize font menu performance, I get a message saying xyz font is corrupt and needs to be deleted. Seems like many fonts needs to be deleted.

So I called Microsoft help desk. She asked me to disable all fonts and restart my computer. After the restart now my office applications are working but my entire 235 fonts are disabled.

My computer is a G4 with 10.4.4 operating system. I also have system nine running.

Could anyone help me solve this issue?

Thank you in advance.

Mac OS X (10.4.4)
  • Kappy Level 10 Level 10 (257,805 points)
    Simply start adding back fonts a couple at a time. When the problem arises you will have identified the likely problem font(s) and can then remove or replace them.
  • Julia Kelly1 Level 1 Level 1 (5 points)
    Thank you for your respond.

    I went ahead and re activated all the fonts I disabled. Should I disable all of them, re start the computer, and start activating the fonts two at a time? Every time I add two, do I need to restart the Office:mac to see if there is a conflict? Do I need to re start the computer each time I add fonts to the list? There sure will be a lot of restart since there is more than 200 fonts.

    Thanks again.
  • Kappy Level 10 Level 10 (257,805 points)
    You should not have to restart the computer each time you add back a couple of fonts. If you are using a font manager, then simply activate a font or two then check with Office to see if there's a problem.

    You should also check for any duplicate fonts and be sure to remove the duplicates so you have only one copy of each font. Also check to see if you have Times RO and HelveticaFractions. If so, remove them.
  • macjack Level 9 Level 9 (50,625 points)
    Kappy has given you terrific advice, you should award him a star.

    Also, if you're a craps shooter, you might try replacing half your fonts on the first go and see if you get lucky. You never know


    -mj
    macjack@gmail.com
  • Julia Kelly1 Level 1 Level 1 (5 points)
    Kappy, thank you very much for your advise. I will try it and post my result hopefully stating it is fixed.

    I may try the crap shooting also

    thanks,
    Chipfly
  • Julia Kelly1 Level 1 Level 1 (5 points)
    Well, in my font book I do have duplicate fonts (some fonts are more than two), but amongst the 2-3 fonts that I have which are the same there are some that have dot next to the font name. What does the dot represent? and should I keep or delete the font with a dot?

    Thanks so much.
  • Jpfresno Level 4 Level 4 (3,020 points)
    Hi Chipfly, Welcome to Apple's Users Help Users Forums

    Hilight the font in question and then click on resolve duplicates.
  • Julia Kelly1 Level 1 Level 1 (5 points)
    I have disolved all my duplicate fonts, and disabled 95% of my fonts.

    I launched one of Microsoft applications and every time it showed a corrupted font I went back to Font Book and disabled that font, but I have disabled almost all of my fonts.

    what puzzles me is that I also have a titanium laptop with same operating system 10.4.4, system 9, and I installed Office:mac 2004 program in that computer but I have NO problems there.

    Any suggestions?? Thanks.
  • Kappy Level 10 Level 10 (257,805 points)
    Yes, that is a puzzle. Perhaps your problem lies elsewhere. Try the following:

    Boot from your Tiger DVD. After the installer loads select Disk Utility from the Utilities menu. After DU loads select your OS X volume from the list on the left, click on the First Aid tab, then click on the Repair Disk button. If DU reports any errors that have been fixed, then re-run Repair Disk until no errors are reported. If no errors are reported click on the Repair Permissions button. Wait until the operation completes, then quit DU and return to the installer. Now shutdown the computer for a couple of minutes and then restart normally.

    If DU reports errors it cannot fix, then you will need Disk Warrior (3.0.3 for Tiger) and/or TechTool Pro (4.1.1 for Tiger) to repair the drive. If you don't have either of them or if neither of them can fix the drive, then you will need to reformat the drive and reinstall OS X.

    If that does not help, then you may have a corrupted font cache and/or preference files. The following may prove helpful:

    http://discussions.apple.com/thread.jspa?messageID=607542&#607542.

    You can also download one of the several utilities used to perform maintenance and use it to clear the font caches. I recommend Tinkertool System, but there are others from which to choose. You will find them all at www.versiontracker.com.
  • Stamper Level 1 Level 1 (60 points)
    Chipfly, I too have had the same problem you are talking about. It is very frustrating. I verified all of my fonts and they were fine but Word kept telling me that many of them were corrupt including the System fonts. There is something about Tiger and Microsoft Word. Apparantly the font cache has become corrupt. Someone gave me this advice. It worked. Restart your computer in Safe mode (holding the shift key). When it starts up, open Word. Then quit and restart your computer. This has worked for me lately.
  • Kurt Lang Level 8 Level 8 (35,475 points)
    Hi chipfly,

    Corrupt font caches are likely the problem. Stamper's suggestion forces Tiger to remove the font caches for Font Book, which is a good start. To remove almost all of the remaining font cache files, use Font Finagler.

    Then remove the caches specific to Office. Remove the following two files. The tilde (~) indicates your home account.

    ~/Library/Caches/.com.microsoft.browserfont.cache

    ~/Library/Preferences/Microsoft/Office Font Cache (11)
  • Bundy Level 1 Level 1 (0 points)
    I too have this problem and have tried most of the above mentioned remedies.

    Every time make a change in font book I have to empty the font cache for any of the Microsoft Office programs work.

    I am not absolutely sure as it is now quite some time that I have put with this problem but I think it started after deleting duplicate fonts in font book.
  • Kurt Lang Level 8 Level 8 (35,475 points)
    Hi Bundy,

    That the problem keeps recurring suggests that you have a corrupt font. This will corrupt Font Book's font cache and/or database. You'll need to root out the bad fonts to eliminate the problem.

    Pull all fonts out of the /Library/Fonts/ folder and your user account at ~/Library/Fonts/. Just put them in a dummy folder on the desktop.

    Replace all system fonts by installing fresh copies from the OS X Install CD/DVD. The instructions to do this are in Font management in Mac OS X Tiger and Panther. It's the last section. This will put all new copies of the fonts that come with OS X on your hard drive.

    Follow the steps in Undoing Font Book to reset the application and clear its font caches once again. Run Font Finagler and clear the MS Office font caches.

    With all new fonts, new font caches and a clean Font Book, everything should work normally. Delete any duplicate fonts from the dummy folder you created that reinstalling the fonts placed on your hard drive. That should leave only those you added yourself. Place them into the /Library/Fonts/ folder five at a time. If the problems return, you know at least one of the fonts you added is bad.
  • Bundy Level 1 Level 1 (0 points)
    Hi Kurt,
    thanks for your reply,

    I am not so sure it is a corrupt font as the problem only occurs when I have changed font book and in most cases that is just adding a new font.

    If I clear the font cache with OnyX things work okay for days after with restarts and using many programs up until the change is made in Font Book then I must run OnyX again.
    If was a corrupt font would the problem not occur more often?

    Thank again for your help.
Previous 1 2 Next