6 Replies Latest reply: Feb 8, 2013 10:53 AM by Lassi.
Lassi. Level 1 (0 points)

I can´t buy apps anymore from the store. When I try to log in, AppStore just keeps asking the password. I changed the password but it didn´t help. All free widgets and games download without problem.

iPod touch
  • HACKINT0SH Level 5 (5,760 points)

    You need to change the login account.


    iOS: Changing the signed-in iTunes Store account


  • Lassi. Level 1 (0 points)

    This advice seemed to be very promising. Thanks.


    The new problem is I can´t anymore even sign in on my profile for changing the login account. I tried that but I cancelled the operation, cause I wanted to use the same e-mail-address for a new login account also.

    Naturally I couldn´t create a new account to previous email-address.


    And after this I can´t log in from my itouch at all anymore.


    So, I need to close first my account? Am I right? Not just overwrite it.

  • HACKINT0SH Level 5 (5,760 points)

    At this point you're not making too much sense, and I believe because you are confused. There is no need to close any account, or over-write. At least there shouldn't be.


    Let's start over again:


    Are you saying the Apple ID you see prompted is the same email address that is yours and you are trying to enter the password for it, but it won't accept the password?

  • Lassi. Level 1 (0 points)

    Yes. I am  . Language is one problem and I´m not very experienced Mac user. But answer to your question is yes, it won't accept the password.

  • HACKINT0SH Level 5 (5,760 points)

    Ok, we will try to get over this language barrier. I'm sure this problem is very simple to solve.


    On your touch, I want you to first sign out. Tap this:


    Settings > iTunes & App Stores > Apple ID > Sign Out


    Now, sign back in with your Apple ID again, and enter your password. Once that works, you should be able to continue with the downloads.

  • Lassi. Level 1 (0 points)

    Hi! I tried that several times once again... and it just didn´t work. Now I just booted the whole system and voilá... no problems anymore. I think the operation system was corrupted and rebooting iOS fixed the error. But thanks a lot for your help, Hackintosh!!!