1 Reply Latest reply: Jan 27, 2013 11:24 PM by steve626
KKlinda Level 1 (0 points)

I'm using iphoto 9.4.2 on a brand new MacBook retina running OS 10.8.2. I've spent the past couple weekends digitizing, editing, and organizing a couple thousand old photos. As I've been working, I noticed that whole events randomly disappear and reappear, and when I create and name events, they often end up with the wrong pictures in them.


Now, I'm pretty smart and an experienced computer user, so I do know what I'm doing, and I've never had this problem before. I absolutely, positively DID NOT accidentally delete the photos. However, the last time I did any serious work in iphoto was in September, and I don't remember when I updated the software--I think the update could be the problem. Everything else on my computer is working perfectly; and it's definitely not a RAM or HD issue.


Today I spent the whole morning uploading and editing photos. As I was working entire groups of pictures would disappear from view but if I tried to reimport them it said they were duplicates and showed the other version. But when I selected "view event" they would show up but then I couldn't navigate to the event because it wasn't visible. Additionally, as I was trying to import photos from photostream (I'm copying the old pictures using my iphone and photostream, which was working wonderfully until now), a lot of the functions would not work consistently. For example, if I selected photos in photostream and created an event or albumn, the menu choices would randomly become unavailable, and often if I could create an event I would name it, edit the photos, and when I'd go back later it would be gone or the wrong pictures would be in it. Very weird. Also, some old events suddenly showed up that weren't previously visible. Several times while I was working the program crashed. Nevertheless, I continued working and sorting. Then, after the last crash the thubmnails for several of the events I had edited went gray and the pictures were missing from some of them. I found some in their unedited form in another event, others were gone altogether, and all of the events I edited this morning had reverted to their original state. In short, about 5 hours of work just disappeared--possibly more.


After reading the support pages I repaired and rebuilt the library. All this did was wipe out most of the photos in photostream; some of the other pictures came back; some didn't, but essentially most of what I did today was gone. I still have some of the photos on my phone and I do have backups on TimeMachine. Also before I tried the repair I think I successfully copied the photo library into another file (I also tried copying from iphoto to the desktop, but everything disappeared from iphoto and didn't copy as it usually does.)


I'm afraid to continue working on iphoto for fear I'll lose everything, and I'm afraid to open a backup to see what's in it in case iphoto corrupts it. I've seen many similar posts, so I know I'm not alone in this. Is there any new information on the problem?

iPhoto '11, OS X Mountain Lion (10.8.2)
  • steve626 Level 4 (1,480 points)

    First thing to do is figure out if your iPhoto program is working properly. Do you have another user on your computer you can log in as? If so, do that and see if that user can work with photos within iPhoto (with a different iPhoto Library than the one you've been using). If it seems to work without the problems you've been seeing, then go to Step 2 below. If you don't have a second user you can log in as, you can create one, or if you prefer not to do that, simply start iPhoto holding down the option key and create a new iPhoto Library. You can then test that new Library by importing a few photos and working a little while with them. Assuming the program works properly in either case, go to Step 2. (FYI, you can switch back to your old Library again by restarting iPhoto with the option key held down.)


    Step 2. Once you ascertain that the iPhoto program is working ok, it would then seem likely that a faulty iPhoto Library is cauing the trouble. Since you already rebuilt the Library from Apple's instructions, you should try a stronger type of rebuild of the Library, using iPhoto Library Manager. You can download this program for free, but not all its features are available until you pay a small fee. However I think that the Library rebuild feature is available in the free version (not 100% sure about that). When iPhoto Library Manager rebuilds your Library, it does so by leaving the original file untouched and it creates a new Library that it creates from your photo files plus the data about them. So you can always revert back to the original file if need be. (That is not the case with the Apple-provided rebuild feature.)


    Hopefully Step 2 will fix your problems.


    If Step 2 does not work for you, then you may have to import your original photos into a brand new Library, or maybe reinstall iPhoto. These are more complex steps and might be best to wait to see whether Step 2 works for you.