Previous 1 2 Next 18 Replies Latest reply: Jan 28, 2013 6:34 AM by italk2rocks
italk2rocks Level 1 Level 1 (0 points)

I've been searching for and trying different solutions for over 5 hours now. I'm hoping someone can help me. This canon device should work similarly to the newer printer/scanners in this line. This device worked fine for me when connected directly to my iMac via USB. I recently upgraded to OS X 10.8 and connected the printer to an Airport Extreme so both PCs on our wireless network could access it. This worked fine, could print from both the Macbook Air and the iMac with no problems. Then I tried to scan something and went down the rabbit hole. Found that the printer was not properly connected to the wireless network, and I have been unable to re-run the wireless setup using the Canon IJ Network Tool. After numerous efforts of installing the original startup disk, restarting, restarting the printer, installing all new drivers and software from the Canon site, I'm now in a worse situation than when I started. Now the iMac doesn't see the printer at all.


I had cleared all devices in my efforts to reset and start over, but now I am unable to add the printer back to my printer queue. At this point it's connected directly from my printer to the PC, so there shouldn't be anything complicated here, but the PC doesn't see it. I'm completely stuck.


This thread had great information for my original problem, but by the time I found that thread, my efforts to fix it had made it worse and now I can't access the printer at all.


Please help! Best case scenario, I'd be able to use the printer/scanner on our wireless network. But at this point I'd be happy to just be able to use it with a direct USB connection to the PC. Right now it's an expensive door stop.

OS X Mountain Lion (10.8.2)
Previous 1 2 Next