Previous 1 2 Next 21 Replies Latest reply: Apr 29, 2014 3:42 AM by lozza50
taramx Level 1 Level 1 (0 points)

My early 2011 macbook pro goes to sleep on its own in the middle of whatever I'm doing. It's done it maybe four times in the last few days. I can get it to wake by pressing the power button. It's running Lion. I'm not very computer-literate... Can anyone suggest a cause or a solution?


MacBook Pro
  • a brody Level 9 Level 9 (64,370 points)

    Did you buy AppleCare?

  • leroydouglas Level 6 Level 6 (14,965 points)
  • a brody Level 9 Level 9 (64,370 points)

    As for what's happening, double check that the only thing hooked up to the computer is power.   Then see what your Apple menu -> System Preferences -> Energy Saver and Security Settings have to say about when it goes to sleep.

  • taramx Level 1 Level 1 (0 points)

    Yes, I have Apple Care. Should I just call them? It's just plugged into power. I have the macbook to go to sleep after 3 hours (I generally just close the lid or shut it down if it's not in use).

  • a brody Level 9 Level 9 (64,370 points)

    Try the SMC suggestion, and if it fails, also try to run the hardware test:

     

    http://support.apple.com/kb/HT1509

    If neither reveals anything logical, then yes, call them.

  • taramx Level 1 Level 1 (0 points)

    thank you! will try these things and see how i go

  • leroydouglas Level 6 Level 6 (14,965 points)

    taramx wrote:

    I have the macbook to go to sleep after 3 hours (I generally just close the lid or shut it down if it's not in use).

     

    I would also turn that off, this could be a problem.

     

    For now set it to never and see the results.

  • taramx Level 1 Level 1 (0 points)

    I tried the SMC reset but it has just happened again. This time I waited to see what would happen if I didn't press anything - it went to the black sleep screen, and then seemed to restart itself and came back up on the user login screen without me having to press the power button. Should I try the hardware test?

  • Linc Davis Level 10 Level 10 (159,315 points)

    If you have more than one user account, you must be logged in as an administrator to carry out these instructions.

     

    Triple-click anywhere in the line below to select it:

     

    sudo pmset -g log | tail -50

     

    Copy the selected text to the Clipboard (command-C).

     

     

    Launch the Terminal application in any of the following ways:

     

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.

     

    Paste (command-V) into the Terminal window. You'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning not to screw up. You don't need to post the warning. If you don’t have a login password, you’ll need to set one before you can run the command. If you see a message that your username "is not in the sudoers file," then you're not logged in as an administrator.

    The command may take a noticeable amount of time to run. Wait for a new line ending in a dollar sign (“$”) to appear.

     

    Post any lines of output that appear below what you entered — the text, please, not a screenshot.

  • taramx Level 1 Level 1 (0 points)

    Thank you for your response. I have gotten as far as it asking me to put in my password, but when I type it in after the dollar sign it says "Command not found"

  • Linc Davis Level 10 Level 10 (159,315 points)

    Please post a screenshot of the Terminal window showing what you did.

  • taramx Level 1 Level 1 (0 points)

    Okay, I don't know what I was doing before lol, but it's worked now. Here is the rest:

     

    Password:

    1/28/13 11:26:51 AM GMT+ slowresponse                  PMConnection: Response from mDNSResponder is slow (powercaps:0x0)                                        231 ms    

    1/28/13 11:26:51 AM GMT+ slowresponse                  PMConnection: Response from IOPowerWatcher is slow (powercaps:0x0)                                       231 ms    

    1/28/13 11:26:52 AM GMT+ slowresponse                  PMConnection: Response from IPConfiguration is slow (powercaps:0x0)                                      833 ms    

    1/28/13 11:26:52 AM GMT+ slowresponse                  PMConnection: Response from AirPort configd plug-in is slow (powercaps:0x0)                              833 ms    

    1/28/13 11:26:54 AM GMT+ slowresponse                  PMConnection: Response from SystemUIServer is slow (powercaps:0x0)                                       3445 ms  

    1/28/13 11:27:06 AM GMT+ wake                          Wake due to EC.LidOpen EHC2: Using AC (Charge:97%)                                            

    1/28/13 11:27:06 AM GMT+ hibernatestats                hibmode=3 standbydelay=4200                                                                              wr=9316 ms

    1/28/13 11:27:08 AM GMT+ slowresponse                  PMConnection: Response from AirPort configd plug-in is slow (powercaps:0x1f)                              1220 ms  

    1/28/13 11:27:08 AM GMT+ slowresponse                  PMConnection: Response from IPConfiguration is slow (powercaps:0x1f)                                     1222 ms  

    Sleep/Wakes since boot:50   Dark Wake Count in this sleep cycle:0

     

     

    Time stamp                Domain                        Message                                                                               Duration            Delay    

    ==========                ======                        =======                                                                               ========            =====    

    UUID: 94552C5E-3931-443B-A084-D72E6D4B6EB9

    1/28/13 1:00:24 PM GMT+1 sleep                         Clamshell Sleep: Using AC (Charge:100%)                                              6865 secs

    Sleep/Wakes since boot:1   Dark Wake Count in this sleep cycle:0

     

     

    Time stamp                Domain                        Message                                                                               Duration            Delay    

    ==========                ======                        =======                                                                               ========            =====    

    UUID: FF5A3734-464C-452C-8861-CBBEB16F1B54

    1/28/13 1:00:33 PM GMT+1 slowresponse                  PMConnection: Response from SystemUIServer is slow (powercaps:0x0)                                       9476 ms  

    1/28/13 2:54:49 PM GMT+1 wake                          Wake due to EC.LidOpen: Using BATT (Charge:98%)                                      2579 secs

    Sleep/Wakes since boot:0   Dark Wake Count in this sleep cycle:0

     

     

    Time stamp                Domain                        Message                                                                               Duration            Delay    

    ==========                ======                        =======                                                                               ========            =====    

    UUID: 4970457D-7955-42A9-A04C-3035F0C0022E

    1/28/13 3:37:48 PM GMT+1 sleep                         Clamshell Sleep: Using BATT (Charge:78%)                                             10 secs  

    1/28/13 3:37:48 PM GMT+1 slowresponse                  Kernel: Response from powerd is slow                                                                     9485 ms  

    1/28/13 3:37:48 PM GMT+1 slowresponse                  PMConnection: Response from IPConfiguration is slow (powercaps:0x0)                                      117 ms    

    1/28/13 3:37:48 PM GMT+1 slowresponse                  PMConnection: Response from AirPort configd plug-in is slow (powercaps:0x0)                              118 ms    

    1/28/13 3:37:58 PM GMT+1 wake                          Wake due to EC.LidOpen: Using BATT (Charge:78%)                                               

    1/28/13 3:37:58 PM GMT+1 hibernatestats                hibmode=3 standbydelay=4200                                                                              wr=7526 ms

    Sleep/Wakes since boot:2   Dark Wake Count in this sleep cycle:0

     

     

    Time stamp                Domain                        Message                                                                               Duration            Delay    

    ==========                ======                        =======                                                                               ========            =====    

    UUID: 59B6ED3E-A54D-4764-BC0D-64BE71286103

    1/28/13 4:00:59 PM GMT+1 sleep                         Clamshell Sleep: Using BATT (Charge:68%)                                             47 secs  

    1/28/13 4:01:46 PM GMT+1 wake                          Wake due to EC.PowerButton PWRB: Using BATT (Charge:67%)                                      

    1/28/13 4:01:47 PM GMT+1 slowresponse                  PMConnection: Response from SystemUIServer is slow (powercaps:0x1f)                                      955 ms    

    Sleep/Wakes since boot:1   Dark Wake Count in this sleep cycle:0

     

     

    Time stamp                Domain                        Message                                                                               Duration            Delay    

    ==========                ======                        =======                                                                               ========            =====    

    UUID: 6A97E4A0-FC6E-4334-9400-E3805BCC04C4

    1/28/13 4:14:27 PM GMT+1 sleep                         Clamshell Sleep: Using AC (Charge:69%)                                               2794 secs

    1/28/13 5:01:01 PM GMT+1 wake                          Wake due to EC.LidOpen: Using AC (Charge:73%)                                                 

     

     

    Total Sleep/Wakes since boot:1

    Taras-MacBook-Pro:~ tarahanrahan$

  • taramx Level 1 Level 1 (0 points)

    I should say that after I tried the SMC reset, I spoke to a guy from AppleCare who got me to do the parameter RAM thing... I've had my macbook on with no problems since then but then it was not a regular occurring problem, it just happened intermittently.

  • Linc Davis Level 10 Level 10 (159,315 points)

    Update this thread if it happens again.

Previous 1 2 Next