13 Replies Latest reply: Feb 8, 2015 3:16 PM by dinhr
kristina_louise Level 1 (0 points)

When i try and access "all my files" on the sidebar it does not load my files it just flashes. Then when i try and type anywhere ; chrome, office, finder etc nothing works it just flashes at me. I have to force quit and relaunch finder. I have tried restarting my computer tried unselecting and re selecting "all my files" to show in side bar. I have tried deleting "all my files from side bar" When i click GO to "all my files" on the finder menu it says that the folder cannot be found

HOW DO I GET ALL MY FILES BACK?    


MacBook Pro, Mac OS X (10.7.5), Only 3 months old!
  • leroydouglas Level 6 (17,777 points)

    Could be corrupt plist

     

    delete the com.apple.finder.plist

     

    Found here Finder>Go>Go to Folder

     

    copy and paste:

     

     ~/Library/Preferences/com.apple.finder.plist
    

     

    Relaunch your Finder

  • kristina_louise Level 1 (0 points)

    Thank you for your reply. I dont have that file though :\

  • leroydouglas Level 6 (17,777 points)

    Yes you do. Use the Go>Go to Folder

  • kristina_louise Level 1 (0 points)

    Okay i found it and deleted it. I relaunched my finder and tried to click on "all my files' still didnt work

  • leroydouglas Level 6 (17,777 points)

    I would open a guest account and see if the problem persist. If no it is not global.

     

    Reboot in SafeBoot Mode.  Hold the shift key on boot up. Log-in and see if the problem is gone.

     

    http://support.apple.com/kb/HT1564

     

    This will turn off all third party apps.

  • Linc Davis Level 10 (192,529 points)

    Please read this whole message before doing anything.

     

    This procedure is a test, not a solution. Don’t be disappointed when you find that nothing has changed after you complete it.

     

    Step 1

     

    The purpose of this step is to determine whether the problem is localized to your user account.

     

    Enable guest logins* and log in as Guest. For instructions, launch the System Preferences application, select Help from the menu bar, and enter “Set up guest users” (without the quotes) in the search box. Don't use the Safari-only “Guest User” login created by “Find My Mac.”

     

    While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.

     

    Test while logged in as Guest. Same problem?

     

    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.

     

    *Note: If you’ve activated “Find My Mac” or FileVault, then you can’t enable the Guest account. The “Guest User” login created by “Find My Mac” is not the same. Create a new account in which to test, and delete it, including its home folder, after testing.

     

    Step 2

     

    The purpose of this step is to determine whether the problem is caused by third-party system modifications that load automatically at startup or login.

     

    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode* and log in to the account with the problem. The instructions provided by Apple are as follows:

     

    • Shut down your computer, wait 30 seconds, and then hold down the shift key while pressing the power button.
    • When you see the gray Apple logo, release the shift key.
    • If you are prompted to log in, type your password, and then hold down the shift key again as you click Log in.

     

    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including wireless networking on certain Macs.  The next normal boot may also be somewhat slow.

     

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

     

    *Note: If FileVault is enabled, or if a firmware password is set, or if the boot volume is a software RAID, you can’t boot in safe mode.

     

    Test while in safe mode. Same problem?

     

    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of steps 1 and 2.

  • kristina_louise Level 1 (0 points)

    Both of those methods didn't work

  • Linc Davis Level 10 (192,529 points)

    Both of those methods didn't work

     

    I'm not sure what that means. I didn't suggest any "methods." I suggested a test. What were the results?

  • kristina_louise Level 1 (0 points)

    Sorry both of those tests didnt work.

  • Linc Davis Level 10 (192,529 points)

    From the menu bar, select

      

    System Preferences Spotlight Privacy

      

    The list of items excluded from Spotlight indexing is shown (it may be empty.) Click the plus (“+”) icon to add an item to the list. Select your boot volume (under DEVICES) and add it to the list. Then remove it from the list by selecting it and clicking the minus (“-“) icon.

     

    Spotlight will rebuild the index. If you try to do a Spotlight search now from the magnifying-glass icon in the top right corner of the display, a pulsing dot will appear in the icon. When the dot disappears, the indexing is complete.

  • kristina_louise Level 1 (0 points)

    Hi I did that and still doesnt work.

  • Linc Davis Level 10 (192,529 points)

    Are you absolutely sure the information you provided earlier was correct? I mean the results of steps 1 and 2. Because if it wasn't correct, a lot of time and effort is going to be wasted, and the problem won't be solved.

  • dinhr Level 1 (0 points)

    Hi Mr Davis,

     

    I'm having this same problem. I see that your response to this issue is about two years old. I hope you are still able to help me. I followed your suggestion to use the two steps, (logged in as "guest" and logged in in safe mode). The problem is still happening. Rebuilding the Spotlight index, as you suggested, did not help. I am running Yosemite now but this problem has been nagging me since Mavericks, I hoped that when I upgraded to Yosemite, the problem would resolve itself, no such luck. I have even tried someone else suggestion to delete the "com.apple.finder.plist", that did not help either.

     

    I vaguely remember deleting something, somehow, from the 'all my files' folder but I don't know what it was, and the folder has not worked since.

     

    Any help would be appreciated.

     

    Regards, dinhr