2 Replies Latest reply: Jan 27, 2013 9:00 PM by roaminggnome
Jps1973 Level 1 Level 1 (0 points)

I need to update my phone so that i can use the square that i bought for my phone


iPhone 3G, iOS 4.3.3