Skip navigation

Error 306: Canon MP250 through D-Link NAS

198 Views 0 Replies Latest reply: Jan 27, 2013 10:06 PM by DoubleOhKevin RSS
DoubleOhKevin Calculating status...
Currently Being Moderated
Jan 27, 2013 10:06 PM

I've been using a D-Link DNS-325 NAS for storage and Time Machine backup. A couple of days ago I plugged my printer into it to be able to use it over the network, but when I try to print I get error 306 (a communication error has occurred). There's also a Windows 7 PC in the house, and everything works perfectly through that. The printer does work through my Mac when connected via USB. The USB print server on the NAS is a Windows/Samba setup.

 

 

I've scoured the internet and tried all the suggestions I could find. I've deleted and re-added the printer; tried all the login credentials that I could think of (all registered accounts, "guest" with no password, and "guest"/"guest"); put the login credentials into the print server address (just to try it); set up the printer through the CUPS page, rather than through System Prefs; set up the printer through both Samba and IP; set CUPS to allow internet printing; edited the CUPS configuration file to "allow from all;" manually added the printer; and tried every iteration of the print server address that I could think of.

 

Can anyone think of anything that I'm missing?

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.