4 Replies Latest reply: Feb 5, 2013 4:19 AM by electronicMe
electronicMe Level 1 (0 points)

I have a really big problem with my mac osx 10.8.2 server. I used the file sharing feature for a long time.

This morning no user could access the shared folders anymore. Only system administrators can access them.


The users can connect to the server, but when they want to mount a folder, the following error message appears:

"The operation can’t be completed because the original item for “...” can’t be found."


I tried to mount the folder with multiple users. All permissions are set correctly! I checked them a hundret times.

A normal user can't mount the folder. But when I check the option "allow user to administrate this server" in the usermanagement, the user is able mount the folder.


I use afp and already tried to restart the server and add testusers. Nothing helped.


Please help me out of this!


Thank you an best regards

Mac OSX 10.8.2 Server, OS X Server
  • UptimeJeff Level 4 (3,420 points)

    Are you shares on an internal or external drive?

    If external, check the perms on the drive:

         ls -ald /Volumes/DriveName

    make sure it has everyone read, typically 755

  • gracoat Level 3 (660 points)

    Check your SACLs.

    I bet you don't have your users allowed access.


    In Server.app, Click the Users tab.


    Right click on the user that CAN'T access the disired share.

    Select, "Edit access to services"

    Ensure that there's check in all the boxes that you want your user to access.





  • electronicMe Level 1 (0 points)

    Thank you for your answers!


    The share is on my Server HD in the folder "/Shared Items/Share Points/TheFolderIWantToShare" (could this be a problem?).


    The user has access to the service (Edit Access To Services; File Sharing is checked) and he has read and write permissions to the folder.


    When I enter "ls -ald /Volumes/Server HD" to the terminal I get this output: "lrwxr-xr-x  1 root  admin  1 Jan 28 16:58 /Volumes/Server HD -> /"


    The File Sharing service has already worked for the user. But one day, when I tried to connect to the server, I always get the following error message:


    Title: "There was a problem connecting to the server “myserver”."

    Message: "The share does not exist on the server. Please check the share name, and then try again."


    The client is in the same network as the server. When I give the user admin privileges, he's able to mount the folder :S

  • electronicMe Level 1 (0 points)

    I solved the problem myself.


    I have moved the Shared Folder to my second HDD in my Mac Mini.

    I think there were some permission difficulties on my System HDD.


    The Apple Care Technical Support also helped me with the Problem.


    Thank you again for the help.


    Special thanks to the Apple Enterprise Technical Support. You helped me a lot with the problem !!