6 Replies Latest reply: Apr 26, 2013 9:42 AM by Old Toad
Reuben Feffer Level 2 (205 points)

I'm using File > Export... in iPhoto 9.4.2 to export a portrait photo to 1024 pixels in height. Problem is, it doesn't work. iPhoto keeps exporting the photo at its original resolution (2448 x 3264 pixels).


If I change the Max height value to 800 px, it works just fine. If I change the Max height value to 1280 px, I get a file at the original resolution again.


What's going on? This is weird.

iMac, OS X Mountain Lion (10.8.2), iMac (21.5-inch, Mid 2010) 12GB RAM
  • Ed Voncken Level 1 (0 points)

    iPhoto 9.4.3 still has this issue.


    Landscape photos are resized correctly, Portrait photos are not (exported in original size)


    Tried export size Large, as well as Custom with a Maximum Dimension of 1280. Same problem.


    When using other size (1920) for Maximum Dimension, results became completely unpredictable - lots of photos, even landscape, now exported at full resolution.


    Clearly a bug in iPhoto, still present in latest version...

  • Terence Devlin Level 10 (137,883 points)

    iPhoto menu -> Provide iPhoto Feedback and report it

  • Old Toad Level 10 (135,314 points)

    It's not  an issue as I can export to a new size correctly with iPhoto 9.4.3.

    Tried export size Large, as well as Custom with a Maximum Dimension of 1280. Same problem.


    That does not affect pixel dimensions. It only changes the amount of jpeg compression that is applied to the file which affects file size, not image size. 


    I suggest you update your system to 10.8.3 with the OS X Mountain Lion Update v10.8.3 (Combo) updater and update your iPhoto to the latest, 9.4.3.  Then give it a try again.


    Also you can give this a try first: Try the following:


    1 - delete the iPhoto preference file, com.apple.iPhoto.plist, that resides in your

         User/Home/Library/ Preferences folder.


    2 - delete iPhoto's cache file, Cache.db, that is located in your

    User/Home/Library/Caches/com.apple.iPhoto folder (Snow Leopard and Earlier).




    or with Lion and Mt. Lion from the User/Library/Containers/com.apple.iPhoto/




    3 - launch iPhoto and try again.


    NOTE 1: If you're moved your library from its default location in your Home/Pictures folder you will have to point iPhoto to its new location when you next open iPhoto by holding down the Option key when launching iPhoto.  You'll also have to reset the iPhoto's various preferences.


    NOTE 2:  In Lion and Mountain Lion the Library folder is now invisible. To make it permanently visible enter the following in the Terminal application window: chflags nohidden ~/Library and hit the Enter button - 10.7: Un-hide the User Library folder.



  • Ed Voncken Level 1 (0 points)

    Already reported

  • Ed Voncken Level 1 (0 points)

    Hi Old Toad,


    Thanks for the reply; I'm already on latest iPhoto 9.4.3 and Mac OSX 10.8.3.


    I don't see how seting the export photo size limit (to 1280 pixels) would NOT affect the photo size in pixels, but would change the Quality setting instead (that's set at High, by the way)...

  • Old Toad Level 10 (135,314 points)

    Reducing the nunber of pixels in a phioto will reduce the file size.  The Quality level further reduces the file size depending on the setting.  The Maximum setting often increases the file size over the original's size if there's no cropping or pixel reduction involved. 


    I was trying to say that the Quality level will have no effect on the pixel dimension of the exported photo.


    Did you try deleting the preference and cache files?  If that doesn't help log into another user account on your Mac and try exporting from iPhoto there.