1 Reply Latest reply: Jan 28, 2013 4:33 PM by Niel
what_the_hey Level 1 Level 1 (0 points)

My itouch is IOS 4.21, and a recent update of a purchased app demands IOS 4.3.  Am I out of luck?


iPod touch, iOS 4.2