6 Replies Latest reply: Jan 31, 2013 3:18 PM by Agolem2
Agolem2 Level 1 Level 1 (0 points)

I recently added a refrubished 25GB ATA harddrive to my G4 as the orig. was grinding so bad i was afraid to loose it.

 

The diskutil recoginized the drive however only displays 12MB of disk space available to play with. Anyone know how to remedy this?

 

~M~


PowerMac, Mac OS X (10.4.1)
  • edex67 Level 4 Level 4 (3,250 points)

    Have you tried reformatting the drive and doing 'Get Info' on the newly formatted HDD?

  • Agolem2 Level 1 Level 1 (0 points)

    I tried however the disk utiltiy only shows 12MB can be formatted. Is there a way to do it from command in terminal?

  • eoinfromcork Level 1 Level 1 (0 points)

    Did you try erase the disk instead of the volume? or try to repartition the disk in case issue is with volume?

     

    In terminal you can use the diskutil command:

    diskutil erasedisk

    Usage:  diskutil eraseDisk format name [[APM]Format|[MBR]Format|[GPT]Format]

            MountPoint|DiskIdentifier|DeviceNode

    Completely erase an existing whole disk.  All volumes on this disk will be

    destroyed.  Ownership of the affected disk is required.

    Format is the specific file system name you want to erase it as (HFS+, etc.).

    Name is the (new) volume name (subject to file system naming restrictions),

    or can be specified as %noformat% to skip initialization (newfs).

    You cannot erase the boot disk.

    Example: diskutil eraseDisk JHFS+ UntitledUFS disk3

  • Agolem2 Level 1 Level 1 (0 points)

    This did not work. It's higher up i think.

     

     

    unknown003065150c20:~ Milo$ diskutil eraseDisk "Journaled HFS+" MacintoshHD bootable /dev/disk0

    Started erase on disk disk0

     

     

    Creating Partition Map

    5% ..

    Formatting Disk                                                          100% ..

    Finished erase on disk disk0

     

     

    Finished partitioning on disk disk0

    unknown003065150c20:~ Milo$ diskutil list/dev/disk0

       #:                   type name               size      identifier

       0: Apple_partition_scheme                    *9.8 MB   disk0

       1:    Apple_partition_map                    31.5 KB   disk0s1

       2:              Apple_HFS MacintoshHD        9.7 MB    disk0s2

    /dev/disk1

       #:                   type name               size      identifier

       0: Apple_partition_scheme                    *25.5 GB  disk1

       1:    Apple_partition_map                    31.5 KB   disk1s1

       2:         Apple_Driver43                    28.0 KB   disk1s2

       3:         Apple_Driver43                    28.0 KB   disk1s3

       4:       Apple_Driver_ATA                    28.0 KB   disk1s4

       5:       Apple_Driver_ATA                    28.0 KB   disk1s5

       6:         Apple_FWDriver                    256.0 KB  disk1s6

       7:     Apple_Driver_IOKit                    256.0 KB  disk1s7

       8:          Apple_Patches                    256.0 KB  disk1s8

       9:              Apple_HFS MacHD              25.4 GB   disk1s10

  • edex67 Level 4 Level 4 (3,250 points)

    Can you actually add more than 12MB of files to the HDD? If you format using Gparted does it exhibit this problem?

  • Agolem2 Level 1 Level 1 (0 points)

    Yep, If Iformat using Gparted it exhibits this problem.