10 Replies Latest reply: Jan 31, 2013 12:21 PM by motc
motc Level 1 (5 points)

I have a MacBook Pro, OS 10.5.8, which I've been using since 2009, and this is the first time I've encountered the problem described below.


I'm suddenly having what seems to be a system wide permissions problem. Tonight I found I couldn't add a new folder (the option was grayed out), and I noticed a pencil icon with a line through it at the bottom of the window. When I chose Get Info for that window, my name was missing from Sharing & Permissions. There was also a new name, "wheel", which I've never seen before. (3 names in all: system, wheel, eveyone.) This affects a lot of folders stemming off the HD (Applications, Library, etc.), but my user folder folder is unaffected.


I've rebuilt the permissions several times in Disk Utility, and also repaired the disk after getting an error message when verifying. But the permissions problem is still there.


So I'm wondering what in the heck could have caused this, and how can I fix it?


I found I could add my name back to the permissions list in one of the affected folders, using Get Info, and this solved the issue for that folder, but there are a LOT of folders with the same issue. Perhaps if I did this with the HD folder, and selected the "Apply to enclosed items" option at the bottom?


FWIW, we just bought & set up a new iMac, OS 10.8.2, last week. I looked at a number of folders on it using Get Info, and it seems to be configured pretty much the same way with regard to permissions, which is a little spooky. Don't know if it makes any difference, but I used the same user name, login password, apple ID & password when I set up the new computer as I have on my Macbook. Could that have caused this somehow?


Thanks for any help or thoughts.

MacBook Pro, Mac OS X (10.5.8)