Previous 1 2 Next 17 Replies Latest reply: Dec 3, 2013 11:53 AM by giaynee
hc10 Level 1 Level 1 (0 points)

Recently noticed that new entries on my iCal on iPhone are not syncing on iCloud with the iCal details on my MacBook. No problem the other way (initial entry on MacBook syncing with iPhone) or indeed any other apps / Mail / Contacts etc. Have checked all items are 'on' in systems preferences and have re-booted the iPhone - to no avail.  

 

Any suggestions?


MacBook Pro (15-inch Late 2008), OS X Mountain Lion
  • Winston Churchill Level 10 Level 10 (84,590 points)
    1. First check that all your settings are correct, that calendar syncing is checked on all devices (system preferences > iCloud on a mac and settings > iCloud on a iPhone, iPad or iPod).
    2. Make sure the calendars you are using are in your 'iCloud' account and not an 'On My Mac', 'On My Phone' or other non iCloud account (you can do this by clicking/tapping the calendar button in the top left corner of the application ), non iCloud calendars will not sync.
    3. If you are sure that everything is set up correctly and your calendars are in the iCloud account, you might try unchecking calendar syncing in the iCloud settings, restarting your device and then re-enabling calendar syncing settings.
  • hc10 Level 1 Level 1 (0 points)

    Hi - thanks for your prompt response and advice. 

     

    I had previously tried all of the above suggestions but did go through each one again - strangely enough I did have some success. 

     

    Following all the above, tried a 'test entry on iCal on iPhone about an hour ago and that did sync over through iCloud but noticed that the entries made earlier this week on the iPhone did not transfer over at the sametime. Even when I tried to edit a historic item this morning (original entry earlier this week on my iPhone), the changes have not coming through on the iCal entry on the MacBook. 

     

    Any other suggestions greatfully accepted as this is causing chaos and overbooking etc.

     

    Many thanks

  • Ticklesneezer Level 1 Level 1 (0 points)

    I recently updated to OS 10.8, and I am having this exact issues (following the advice above). I've been troubleshooting for the last few hours - no luck. Any help would be appriciated. Thanks in advance.

  • Ticklesneezer Level 1 Level 1 (0 points)

    I finally found a fix that works for me:

     

    My soultion:

    1) On each device got to iCloud settings and disable 'Calendars'

    2) Reboot each machine

    3) Starting with the iPhone, re-enable 'Calendars' in the iCloud setting

     

    I hope these steps work for you too.

  • hc10 Level 1 Level 1 (0 points)

    Hi - thanks for your suggestions. 

     

    Did try them out in the order they worked for you but unfortunately, this has not resolved the problem.  I think I am going to have to take it to the Genius Bar.

  • bigbow Level 1 Level 1 (0 points)

    Finally something worked. I've tried other junk on other threads like rebooting synch through terminal to no avail.

     

    I knew it would work when I turned on ical cloud synch on my MBP and then iCal showed a loading bar for moving all of my calendars onto the servers. I couldn't find any way to do this manually and only my MBP afforded proper synching. Now my phone and MBP are synching one another all day.

     

    feelsgoodman

  • trefontaine Level 1 Level 1 (0 points)

    I did what bigbow suggested. It seemed to work - a few previously non-synched events posted, but now iCal has the blue striped bar animation and has been "Moving calendars to server account..." for the past five hours. So the application is frozen and won't let me see or change anything. Force quit and restarting the app didn't work either.

  • phd67 Level 1 Level 1 (0 points)

    That worked for me, at least so far. Thank you!

  • pallaksch.pallaksch Level 1 Level 1 (0 points)

    I followed the steps Ticklesneezer suggested (disable 'Calendars' in iCloud, reboot each machine, re-enable 'Calendars' in iCloud, starting with iPhone), and it did not work.

     

    I think it has to do with the fact that I just started syncing my iMac calendar about a month ago. Since then, the following has occurred:

     

    - For iCloud entries: new entries sync fine, but older entries (older than one month) only show up on my iMac, not on my iPhone -- and those are the entries I actually created on my iPhone, so they appear to have been added to the iMac and deleted from the iPhone. I checked to make sure that the older entries are in the iCloud calendar, and they are.

     

    - For Exchange entries (the calendar synced through my Outlook mail account from work): new entries sync fine, but older entries (older than one month) only show up on my iPhone, not on my iMac.

     

    I need to be able to access the older entries from both devices.


    Any other suggestions?

  • ac96822 Level 1 Level 1 (0 points)

    What worked for me with my iPhone & MacBook Air was this (changes made on my iPhone calendar not syncing with MacBook iCal):

     

    Go to: Settings-->iCould-->Calendars in iPhone

     

    Somehow my Calendars on my iPhone had switched/toggled to the "off" position.  I don't know why or how, but it wasn't like this the last I'd checked (a few months before noticing this issue).

     

    It's really a simple fix, and all I had to do was toggle to the "on" position on my iPhone, and then hit refresh on my MacBook (click on the iCal on computer, then cmd+R).

  • Unky_Si Level 1 Level 1 (0 points)

    Hi, I'm a relative newby but also had this problem with my iPhone, iPad and iMac not syncing, i found the settings on my iMac were set to push and once i'd changed it to every hour it synced without issue, dunno if this helps anyone but my my 2p....

  • Ragnvard Level 1 Level 1 (0 points)

    So I was on these posts trying everything to no avail when I accidentally figured out my problem. I simply renamed the calendar on my macbook pro ical under the icloud tab. Once I renamed it, then rt clicked on it and hit refresh it immediately updated on my iphone and sent the info I've been missing from my macbook. Not sure if that will work for everyone but it did for me after and hour of reading a bunch of different solutions that didnt work.

  • Paul Reddington1 Level 1 Level 1 (0 points)

    What worked for me was that I noticed the iCloud settings button was greyed out, so I went to 'Restrictions' which was ON and saw that 'Allow Changes' for 'Accounts' was set to 'Don't Allow Changes'.

     

    Don't know how this got set but I switched it to 'Allow Changes' and that solved the syncing from iPhone Calendar to iCloud for me.

  • Gene Chu1 Level 1 Level 1 (5 points)

    This worked for me.  Thanks.

Previous 1 2 Next