10 Replies Latest reply: Feb 2, 2013 11:19 AM by gordguide
BarduCharles Level 1 Level 1 (0 points)

Java 7 update 11 has trouble. It does jump over installing place, and are not stored even if it says its completed. Help..

MacBook Pro (15-inch Mid 2010), OS X Mountain Lion (10.8.2)
  • Eric Root Level 8 Level 8 (41,465 points)

    Try this link:



  • BarduCharles Level 1 Level 1 (0 points)

    Thank U for help! But it didnt solve my problem. I can not follow theese instructions because all signs of java is missing, I cant enable something that doesn`t exist. What i Wierd is that the program seems to install sucsessfully, but no signs of java on my computer...


    To test that Java was installed and working properly on my computer, I tried to run this test applet. But it failed


    Strange problem..

  • AsKhaM Level 1 Level 1 (0 points)

    Hi, I do my banking online and both bank websites use java to perform their transactions. Since this morning I haven't been able to do anything. Tried installing java over and over but nothing changes! I'm desperate because my bills keep comming and I reckon I'll have to go back 15 yrs in time and start doing my banking physically...


    I run a mac book Pro 2.4Ghz - Intel Core i5 - OS X 10.8.2 and Safari 6.0.2

    My java preferences are gone and it just doesn't seem to get any better by re-installing from JAva website or Oracle website.

  • atomicluck1 Level 1 Level 1 (30 points)

    Apple has once again blocked JAVA.  Problems is that the corporation is automatically making the decision for us.  Now I'm unable to access bank accounts or even my work site because they all require JAVA. 


    Don't know about anyone else, but I'm getting tired of Apple making the decsion for me.  Now I either go out an buy a Window laptop or I lose 90% of what I use my MBA.


    So far it doesn't make a difference which browswer .... JAVA is not working.

  • AsKhaM Level 1 Level 1 (0 points)

    Same problem here!!! That's really annoying!! Please Apple, help us like you again!

  • Eric Root Level 8 Level 8 (41,465 points)

    Try turning on Java Script, which is not the same as Java, in Safari Preferences. This allowed me to access my financial sites.


    Screen Shot 2013-02-01 at 12.52.56 PM.png

  • AsKhaM Level 1 Level 1 (0 points)

    Thanks for your reply Eric, but unfortunately that was already turned on and still the problem remains.
    Many people at work here also use Macs and are having the same problem, nobody has found any solution yet.

  • atomicluck1 Level 1 Level 1 (30 points)

    Unfortunately my work site requires Java, end of story.  Without Java my MBA and MBP are now simply $2,000 pieces of garbage.  I now have to make the decision to dump Apple for the first time in more than 25 years and return to Windows.  I understand the issue, but by Apple making the decision for me I am now locked out ... period.  I'm so ready to take all 3 of my Macs, box them up, send them and my iPhone to Tim Cook and never look back. 

  • Daniel Lyons Level 1 Level 1 (35 points)

    Java 7 update 13 was released this morning eliminating the actively exploited security hole that prompted Apple to disable update 11.  Update 12 was skipped.

  • gordguide Level 1 Level 1 (25 points)

    I've installed the latest version of Java [EDIT: latest as of a week ago] directly from Oracle's website. I just checked and Java applets residing on my computer work as expected.


    Easiest way to determine if Java is installed is to check System Preferences, because this is where J7v11+ preferences are found now (a change from Oracle).


    There is a process within the Safari browser where Apple can impose minimum versions of plugins. Recently such an imposition was made, that effectively disables Java in the browser. This is equivalent to unchecking the Java checkbox in Safari preferences. You can also disable Java in the browser for all browsers via the Java Preferences in System Preferences.


    What Apple did was to limit the allowable version of Java in Safari to a version that does not exist (ie a newer version number than the latest version from Oracle). As mentioned, this effectively disables Java in Safari.


    However, you should be able to use an alternate browser (eg Firefox) and enable Java in the browser via the Oracle Java preference pane found in System Preferences (and double check with Firefox's preferences).


    This assumes you've properly installed the latest version of Java from Oracle directly. In this case, Java should work in Firefox but not in Safari, and Java apps residing on your hard drive should work as normal (unless they're incompatible with the latest version of Java from Oracle).


    Now, on my system, Java from Oracle was installed prior to the latest effort by Apple to disable Java in Safari. So, although I don't see a reason why it should be any different, it's possible that someone trying to download Java from Oracle might not be able to fully install it.


    In order to determine if that's the case, I suggest users look for the Java Preference Pane in System Preferences to see if it was sucessfully installed.


    UPDATE: I am currently downloading j7v13 via the Control Panel. All seems fine. It may well be that v12 was skipped because that was the version imposed by Apple for a "legal" plugin for Safari. Either way the latest version of Java (and Flash) should always be installed since those two are prime vectors for attack on most computers via the browser.