Previous 1 2 Next 21 Replies Latest reply: Feb 1, 2013 3:36 PM by CountMarco Go to original post
  • Shane Ross Level 8 (42,795 points)




    Here are some on Rosette and Mountain Lion:



    In fact, YOU MichaelLAX, says that it works:


    So...if you say it must work.  Why must I say it works? I have no personal experience with Rosetta installing on Mountain Lion.  You do.  So, if it worked for you...just say so.  Sheesh...


    As for Kate... Here's how you do it on Lion...using Snow Leopard install disk:


  • MlchaelLAX Level 4 (2,027 points)

    Shane Ross wrote:


    In fact, YOU MichaelLAX, says that it works:


    So...if you say it must work.  Why must I say it works? I have no personal experience with Rosetta installing on Mountain Lion.  You do.  So, if it worked for you...just say so.  Sheesh...

    I do not need to be discredited nor maligned for my efforts to get this issue straight; by you linking to a post by me that you obviously did not even read!  I work too hard to help people out with the issue of the lack of Rosetta on Lion and Mt. Lion.


    Maybe after you go back and actually read that post, you will return and apologize to me.  Until you do, I have no need to read or consider the rest of your post.

  • Shane Ross Level 8 (42,795 points)

    GAH!  You are right. *head hung in shame*.  I didn't read the post.  That's what I get for doing this while trying to work...I skim and got in trouble.


    I shouldn't say "try it and see." That's dangerous. 


    I should say, "Clone your hard drive so you have an exact copy, in case anything goes wrong, and then try to install Rosetta and see if it works.  If you really need this new mac to run FCP 6. Because newer Mac computers are designed not to be able to run the older OS versions, simply installing an OS that is compatible with FCP 6 isn't possible in most cases."


    All I meant to say "this works with Lion, not sure about Mountain Lion.  Proceed at your own risk."

  • MlchaelLAX Level 4 (2,027 points)

    Your apology is accepted!


    Now back to our regular programming, which we join already in progress...


    It never made sense to me that (a) one could install Rosetta into Lion and get any results at all, let alone get an installer written in PPC code to run; or (b) if installing Rosetta into Lion worked for an installer written in PPC code, then why wouldn't an application written in PPC code work also?


    And the answer is...


    Anytime an operating system is updated, there is a chance that some of your software will no longer function 100% correctly, until the publisher releases an update of that software for the newly updated operating system.  And that is what is going on here...


    The Final Cut Pro installer is NOT written in PowerPC code!  There is some minor instruction in the installer that makes a call to the operating system in Lion, that Lion is incorrectly interpreting as being PPC code and hence giving the Dialog Box that says that it cannot run a PowerPC program.


    This minor instruction is attempting to execute the following instruction in Terminal:

    $ sudo installer -package /Volumes/Final\ Cut\ Studio/Installer/FinalCutStudio.mpkg -target /

    If you execute this instruction in Terminal sans Rosetta, the program will install perfectly!


    Somehow, the "installation of Rosetta" into Lion, and perhaps Mountain Lion interferes just enough between the program and the operating system, to allow the program to make this call to Terminal and install the program.  Since this instruction will work in Terminal without Rosetta installed, it obviously has nothing to do with PowerPC code or Rosetta.


    So the best advice would appear to be to use this instruction in Terminal and wait while the installation program completes all of its tasks with the concluding statement:


    installer: The install was successful.

    This method avoids any pitfalls that may occur by installing Rosetta, which has no place in Lion or Mountain Lion and may be the cause of future problems!


    Since I do not have Final Cut Pro, I cannot confirm this, but maybe I can borrow a copy somewhere soon...

  • KateBradbury Level 1 (0 points)

    Thanks Michael its my first time using the forum. It's been great.

  • MlchaelLAX Level 4 (2,027 points)

    Were you successful in installing Final Cut Studio 2, Kate?


    If so, which method did you use?


    Terminal or install Rosetta...

  • CountMarco Level 1 (0 points)

    Came across this thread in my attempt to install Final Cut Express on Mountain Lion.

    I received my newest gen iMac 27 just yesterday and after fresh app installs from discs and importing what data/apps I needed from time machine backup manually (didn't want to risk pulling in any corrupt files from old computer) had pretty much everything I wanted/needed- except Final Cut. This was of course because the disks were rejected by ML as unsupported as has been documented ad-nauseum.

    Found a related thread where a user said he was able to install FC on ML-


    I went to upgrade from Lion to ML, and halfway through installing it ran into a problem and said my hard drive was corrupted and I had to wipe it. I thought this would mean I couldn't update to FCE 4.0.1 since it would be a clean install and apparently that blocks the update.


    When I was using Target Disk Mode (which somehow still worked) to load all my documents off before I wiped it, I thought I would try something. I went to an archived Apple Support document ( for what to delete to uninstall FCE. Instead of deleting those files I copied them too. Once I clean installed ML I pasted the files back to where they came from, THEN reinstalled FCE from the disk, and everything worked in 4.0.1! All my old projects loaded, no featrues were broken, and everything on my mac is fine."


    I gave it a shot using this "reverse engineering" and voilà! It worked.

    Mind you I am running Final Cut Express HD 3.5.1 so that doesn't exactly match thread but this fellow seemed to do just fine with 4.0.1.

    Thus far my FC opens, edits, saves, exports to QT just fine.


    Maybe now I will try to find way to update it to 4 as I've been running this v3.5 since purchasing my old and recently retired iMac 24 back in 1.2007.


    Hope this is of both relavence and assistance to some of you.

    -The Count

Previous 1 2 Next