Previous 1 2 Next 16 Replies Latest reply: Jun 11, 2013 7:22 PM by Way
jasper.slokker Level 1 (0 points)

Since a few days Numbers keeps crashing when i start to work on a worksheet. And it doesn't matter if it's a template or a empty screen. I keep sending the reports to Cupertino.

Numbers, OS X Mountain Lion (10.8.2)
  • Wayne Contello Level 6 (17,509 points)

    Quit Numbers (if it's running)


    In the Finder select the menu item "Go > Go To Folder…" then enter the path:



    Screen Shot 2013-01-29 at 5.11.03 PM.png

    then locate the file:


    move this file to the desktop


    Now start Numbers.


    If Numbers runs correctly move the file you moved to the desktop to the trash.

  • jasper.slokker Level 1 (0 points)

    Wayne, thanks a lot for your quick response but unfortunately it doesn't help. Problem is still there. Do you have any other suggestions?

  • perpetualanticipation Level 1 (0 points)

    Jasper, did you ever fine a resolution?


    I am experiencing the exact same issue. I tried restarting the system, removing the .plist file, and reinstalling Numbers.


    I can enter a value into a cell, but then as soon as I select another cell it crashes.


    I'm running 10.8 on a 2010 iMac.

  • benfromrockaway Level 1 (0 points)

    I have the same problem, followed the steps, and it also did not work for me. I am running Mac OS 10.8.2.

  • simona586 Level 1 (0 points)

    I am having the same problem! its very frustrating! is someone finds a fix please let us know!!!

  • ronniefromcalifornia Level 2 (230 points)

    Probably not, but I wonder if some of these problems are from Numbers trying to open a bad file on launch? Try going to system preferences, general and add a check next to "close windows when quittng an application".


    If that doesn't work, other common crash issues are fonts. Maybe you've installed some 3rd party application that installed some fonts that Numbers is choking on?


    Another thing I've seen people try is create a new user account (system preferences, users and groups). See if Numbers launches from the new user account.

  • ronniefromcalifornia Level 2 (230 points)

    Perhaps iCloud? Maybe sign out of iCloud and see if that helps?

  • ancientmech Level 1 (0 points)

    Note: I solved this problem by unticking 'Documents and Data' from iCloud and restarting Numbers. Must be a bug in the current 4th December update for icloud synching.

  • benfromrockaway Level 1 (0 points)

    My update

    1.Numbers now crashes when starting itself, not when opening a spreadsheet. Does not matter if I start it by on the app icon or one of the number files.

    2.Removing all the* files did not make a difference.

    3.Restoring numbers out of Time Machine from a time it did not crash made no difference.

    4. I was happy to find the IWork 9.3 update ( However, after upgrading numbers still crashes at startup

    5.The key part in the crash report seems to be "*** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '-[SFUDateFormat decimalPlaces]: unrecognized selector sent to instance 0x1f3a4da0'

  • FM63 Level 1 (0 points)

    Finally my solution was an combo Update for 10.8.3.

    After the update numbers works as before.

  • Mela1987 Level 1 (25 points)

    I am also experiencing this problem since yesterday on two computers. I know exactly what caused the problem to start happening, because I replicated it on the second computer. Now I have to figure out how to fix it.


    For the record, in case the iWork engineering team is watching:


    1. I opened a Numbers document from iCloud.

    2. I attempted to Duplicate that document by pressing Shift-Command-S.

    3. The progress bar dialog appeared saying that it was duplicating the document, but the progress bar just got stuck. After an hour it was still there. Numbers had obviously hung.

    4. I force-quit Numbers by option-control-clicking on its icon in the Dock.

    5. Ever since, Numbers crashes on startup with the following message in the crash log:


    *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '-[SFUDateFormat decimalPlaces]: unrecognized selector sent to instance 0x10014020'


    6. I deleted all Numbers preference files from the Preferences folder. It didn't help.

    7. I turned off Document & Data syncing in iCloud. It didn't help.

    8. Opening the same document on another machine and repeating above caused the exact same thing to happen. It appears that there was some corruption about that document that caused Duplicate to fail. Immediately previously to this problem, I had Duplicated several other documents and saved them successfully.


    The problem with Numbers is isolated to the user account I was using when I force quit the application. Numbers continues to work fine on other user accounts on the same machine.


    Now I'm off to try a few solutions to get Numbers working again.

  • Mela1987 Level 1 (25 points)

    Update to post on steps tried so far to fix problem:


    1. Ran all the scripts in Yasu ( to clear caches:

    - Daily cron

    - Weekly cron

    - Monthly cron

    - Reset system permissions

    - Reset home permissions

    - Update prebinding

    - Clear system cache

    - Clear local cache

    - Clear user cache

    - Reset launch services

    - Clear system font cache

    - Clear local font cache

    - Clear user font cache

    - Clear swap files


    2. Reinstalled 10.8.3 from Combo Updater file.


    Neither fixed problem. Now going to reinstall iWork from install DVD, then update.

  • Mela1987 Level 1 (25 points)

    Further update:


    1. I reinstalled iWork from the original install DVD, then updated it to the latest version online. On launch in the affected user account, Numbers still crashed.


    2. I looked in the folder ~/Library/Autosave Information and found an unsaved, untitlted Numbers document and a file. The unsaved Numbers document was the one that I had been attempting to duplicate (see my original comment above). Once I deleted both of these files from Autosave Information, then Numbers started normally.


    Clearly there was something very corrupted about that particular Numbers document that I was trying to work with. The corruption seems to have gotten saved into the unsaved document and then prevented Numbers from starting at all.


    Problem solved for me.

  • Mela1987 Level 1 (25 points)

    This was definitely my problem. See my comments below. The problem was a corrupted unsaved Numbers document in the folder ~/Library/Autosave Information. Once that was deleted, Numbers started fine.

Previous 1 2 Next