0 Replies Latest reply: Jan 29, 2013 2:41 PM by GerSte69
GerSte69 Level 1 Level 1 (0 points)

Hi,

 

I am trying to print from a MacBookPro on an HP printer connected to a desktop computer running Windows Vista.

 

MacBookPro  - running Mac OS X 10.7.5; 2 GHz Intel Core 7; 4 GB 1333 MHz DDR3

Windows desktop computer - Acer Aspire M1100 running Windows Vista Home Premium SP2 32-bit; 2.1 GHz AMD Athlon X2 Dual Core

Printer - HP Deskjet F2210 All-in-one (printer, scanner), connected to Windows Desktop via USB (direct, not hub)

Wired/Wireless environment - Motorola SBG900 Cable Modem, to which the Windows Desktop is connected either wirelessly or via Ethernet cable

 

The printer will print documents when connected directly to MacBookPro via USB, but over the network, this is showing:

On MacBookPro: In the printer queue, the message shows, "Waiting for print job to complete..."

On the Windows Desktop: In the printer queue, the size of the document comes up as ...KB/...KB (in my case, 10.7 KB/13.8 KB) - won't change, number of pages "N/A"

On the printer front panel: blinking On/Off button light (blinking slowly, suggesting printer is still busy) - the printer will start to kick into action, but the only thing happening is that blinking light...

... and that's it! From there, there is no more progress (even after 10-20 minutes); you have to cancel the print job on both the MacBookPro and the Windows Desktop.

 

This is what I have tried already:

Making sure both machines are in the same network (check)

Making sure both are in the same subnet (check)

Deactivating Windows firewall and the firewall in the router/gateway (does not solve issue)

Logging in to Windows Desktop over Finder on the Mac using a user name that is the same on both machines (does not solve issue)

Deleting Keychain Access stored passwords in case they were incorrect (does not solve issue)

Making sure drivers for printer are up-to-date on both MacBookPro and Windows Desktop (check)

Deleting the printer from the MacBookPro and letting the system find it by itself when printer  connected directly via USB (does not solve issue)

I have also tried installing the printer as described in Apple Support article HT3049 (How to manually add a Windows shared printer.) It seems like there are two ways to add a printer, one is by using the "Windows" button in the "Add printer" window toolbar, the other is by using the "Advanced" button. Both did not help.

I exchanged the printer cartridges, since low ink levels apparently can also cause errors when printing in a network (read that somewhere here - but does not solve issue either.)

In order to see if the Windows version has something to do with it, I connected a Windows 7 laptop to the printer and tried to print from the MacBook wirelessly to it (no success there, either).

 

When printing first when we got the MacBookPro, I think it worked to print over the network, but for whatever reason, things won't budge at the moment. (I guess, it's a driver issue, but the drivers are up-to-date.) I must be doing something wrong, I just don't seem to be able to figure out what, so any help would be greatly appreciated.

 

Thank you in advance.


MacBook Pro, Mac OS X (10.7.5)