1 Reply Latest reply: Jan 29, 2013 9:48 PM by BDAqua
apopj Level 1 Level 1 (0 points)

When I try to load my older version of Final Cut Express, I get an error message saying it cannot run on this mac. Is there an update I can install to make it compatible? I am running a MacBook Pro 10.6.8 and the Final Cut Express is 2.0.... thanks in advance


Powerbook G4, Mac OS X (10.4.10)