7 Replies Latest reply: Apr 3, 2013 6:49 PM by Chris103204
CCawthon Level 1 Level 1

I am in the process of deploying 20 iPads in a primary school environment using Apple Configurator. I have prepared the devices and pushed configuration profiles to the devices. I have also purchased the necessary volume purchase activation codes (20 of them). In order to download the physical app packages (.ipa files) I used the first activation code from the downloaded VPP store spread sheet in the redeem field in the iTunes store to download the .ipa file from iTunes and added the file to the apps list in configurator. Now when I attempt to install the apps on the iPads configurator installs the first 19 no problem but since I used the first code in iTunes to get the .ipa file configurator tells me that that code is no longer valid. I worked around this by turning on app downloads on the iPad in configurator, signing into the itunes store on the ipad and installing the app from the coud then in configurator turning off the ability to install/delete apps on the ipad. This will be a pain if this is the work flow for every app I plan to install on the devices. Am I missing something? Do I actually need to purchase an extra activation code (21 codes for 20 iPads) one to download the .ipa from iTunes and the remaining 20 for the iPads or purhase the app at full price in the iTunes store and then use the 20 codes in configurator? Help!

  • TeachTechMom Level 1 Level 1

    According to Apple Enterprise, if you pull the vpp spreadsheet again it should give you credit for the iTunes download.  You then have to go back into configurator and load the (new) spreadsheet...supposedly it will have given you a new code.  They said this was a recent fix because you shouldn't have to buy an extra.

     

    I think it is an ANNOYING fix, but I'll give them credit for trying.  Let us know if it works.  I honestly haven't had a chance to give it a go.

  • TeachTechMom Level 1 Level 1

    Update: Was able to test this and pulling the spreadsheet from vpp account DID work... however, it did not actually give me a new code, just made it accept the old code...like it validates that it was used to redeem the app in itunes for the same apple id tied to configurator for that app.

     

    So... you do not have to buy an extra... but you do have to jump through a few hoops.

  • CCawthon Level 1 Level 1

    Fantastic! Just tried it myself and all is well. Thanks! It'd be really nice if Apple was a little more thorough in their documentation at times.

  • ERLtech Level 1 Level 1

    This is happening with every app that we purchase through the VPP program and the solution is BEYOND ANNOYING as I install the apps but don't manage the account and rigamarole that is requried to purchase apps. I have to send a note to the person that did the purchase asking them to redownload the spreadsheet. No matter how carefully I word my request, I always get back a copy of the original spreadsheet and have to send another email to AGAIN explain that it has to be a new download from the VPP portal. I know the purchasing dept just can't believe that they really have to go back and do the whole process over again just to reclaim the one license that won't apply. I see over 200 views of this thread so this a big problem and Apple needs to fix it!

  • rccharles Level 6 Level 6
    expertise.classicmacos
    Classic Mac OS

    It's agreed.  Snafu by Apple. This isn't the place to contact apple.  It's user to user.

     

    *Feedback*

    "Use the form below to send us your comments. We read all feedback carefully, but please note that we cannot respond to the comments you submit."

    http://www.apple.com/feedback/ipad.html

  • Chris103204 Level 1 Level 1

    By 'pull the spreadsheet again' do you mean re download it and add to Configuator? Ive tried this but im still getting problems.

     

    Im very much doing the same thing as CCawthon for  my school at the moment.

    As a test ive purchased two liscences for a VPP app and have tried to install them to 2 ipads. I managed to get it to install on 1 ipad and one failed as expected.

     

    I removed the app, redownloaded the spread sheet and reimported it to configuator. Now I cant install the app at all, just getting the eplanation mark with the error Can't install app. The code importer window is telling me that 1 code has been redeemed (from when I downloaded it from itunes im assuming) and I cant get it to change from that state.

     

    Any ideas or am I doing something wrong?

  • Chris103204 Level 1 Level 1

    So I downloaded the spreadsheet again today and reimported and it appears to have made the first liscence available.

     

    So thats great but I still get the error Cant Install App with no explanation...