Previous 1 2 Next 16 Replies Latest reply: Feb 5, 2013 10:08 PM by BDAqua Branched to a new discussion.
Jim Taylor Level 1 Level 1

I have an external 4TB G-DRIVE disk for time machine backups on my late 2010 21.5" iMac. 

OS/X Mountain Lion fully up to date with all Apple-supplied updates installed as of January 29, 2013.

Originally the external G-DRIVE disk was pre-formatted as a boot disk.  I erased it, and re-partitioned it as a GUID partition.

When I run the time machine backup, it generally fails with this message:  "Time Machine couldn't complete the backup to "time machine backup" (that's the name of my disk).  Unable to complete backup.  An error occirred whie creating the backup folder."

I open the disk utility and verify the disk.  If there are any verify errors, I unmount the disk and run the disk repair utility.

Once the disk repair is successful I mount the backup disk and  re-open time machine preferences.

The "Select Disk" routine finds two versions of the same physical disk.

When I select the first one in the list, it prompts me to remove the disk.

I generally cancel this option and select the second version of the same physical disk in the list.

It prompts me to "Use this disk".

I then open the little time machine backup icon and  select "Back up now".

Sometimes the backup completes successfully, sometimes not.


Clicking on the "?" symbol in the error message window opens a list of "Time Machine Problems" on the apple support web site.


The various remedies about robust cable connections to the external disk are checked and verified as OK.  I'm on a firewire 800 cable from my iMac to the external G-DRIVE.


As the external disk is not shared, I have not set a password on it.  I do not recall an option to set a password in the disk utility, but perhaps I missed it, as I was not concerned with putting a password on it.


My expectation is that the external disk can be selected once, then run its hourly time machine backups with no further intervention.

The reality is that sometimes it will run a few backup cycles, then will fail with the "time machine couldn't complete the backup...." error.  Then I start over again, sometimes I shutdown and reboot, open time machine preferences, re-select the disk (the same disk appears as duplicates in the list, as described above.) 

A side-effect of this bizarre behaviou is a mix of curiosity and annoyance on the part of the computer owner.


The external G-DRIVE disk appears to go to sleep after a few moments of inactivity, and sometimes wakes up OK, sometimes not.

I have not found any physical or software switches to this effect in the disk or the technical literature about the disk.


Does anyone have similar experiences with an external G-DRIVE disk used as a time machine backup disk?

AND, does anyone have an effective remedy that fixes it?


I have checked the permissions on the backup partition, and they appear to be OK and logical.

The format is Mac OS extended (case-sensitive, journaled)

Owners Enabled: Yes

Mount point: /volumes/time_machine_backup

Capacity: 4 TB, Available 3.6 TB, Used 403.8 GB



Many thanks

Jim Taylor

Winnipeg, Canada

iMac, OS X Mountain Lion (10.8.2), 8 GB RAM, 3.6 GHz Intel Core i5
  • BDAqua Level 10 Level 10

    Hi Jim, besides TM being the most cantankerous Backup App I've ever run accross...


    The "Select Disk" routine finds two versions of the same physical disk.


    In Finder's Menu, select Go menu>Go to Folder, and go to "/volumes". (no quotes)


    Volumes is where an alias to your hard drive ("/" at boot) is placed at startup, and where all the "mount points" for auxiliary drives are created for you to access them. This folder is normally hidden from view.


    Drives with an extra 1 on the end have a side-effect of mounting a drive with the same name as the system already think exists. Try trashing the duplicates with a 1 or 2 if there are no real files in them, and reboot.


    If it does contain data...


  • Jim Taylor Level 1 Level 1

    It sounded like the remedy was close, but when I examined the /volumes directory, there was only one version of each disk -- the iMac internal hard drive, and the G-DRIVE external disk.


    Following the other support article (TS2474) that you pointed to, I did a graceful shutdown to power off.

    Then I powered on the iMac and went in to single user mode (press power button, then immediately hold the command key and the letter S key).

    While I was there, and before any drives were mounted, I did a "fsck" on the internal hard drive.  The fsck reported that some errors were corrected.


    I then did the mount -uw /

    and checked the /volumes directory.  Again, there was only one version of each disk.


    I rebooted and after the boot process completed, I initiated another time machine backup.

    And it worked.


    But it has done that before -- after a reboot, the time machine backups work for a while -- a few hourly cycles -- and then it once again complains that it cannot find the backup disk.


    So now I am going to wait it out.


    I opened the time machine preferences menu, and went to the "Select Disk" routine.

    It shows what one could interpret as one backup disk, listed in two places:

    1) the current backup disk

    2) the same disk in the list of available disks


    Or, perhaps, the problem has not been remedied.

    When I click on the disk in the "current backup", it prompts me to REMOVE DISK.

    When I click on the disk in the ist of Available Disks, it prompts me to USE DISK.


    Of course, I cancelled instead of selecting, and I will wait it out to see if the problem is fixed or not.


    If I have to shutdown again, I'll go into single user mode again and run another fsck on both the iMac internal disk and on the external disk, then reboot and take it from there.


    It is an interesting problem, yes?


    Jim Taylor

    Winnipeg, Canada

  • BDAqua Level 10 Level 10

    I think the problem was the "some errors", if it fails again, you can check it in Disk Utility>Verify Disk, not Verify Permissions.

  • Jim Taylor Level 1 Level 1

    It seems that I have to reboot each time the time machine cannot find the fire-wire-attached backup disk.  After reboot, it finds the disk and does the time machine backups until -- and this may be a big clue -- until I leave my computer for a couple of hours, of for the night or for the day. 

    Then the energy-saving stuff kicks in, and the login window appears after a period of absence.

    Sometimes I activate the login window as a security measure to lock my screen when I am not at my desk.


    It seems that activating my login window suspends my login session until I return and enter the password to get back to my session.


    I am only speculating here, and these ideas may be completely untrue and irrelevant to the problem.


    Theory number one:

    My speculation is that, if activating the login window to lock my screen has the effect of suspending my login session, that the time machine timer keeps ticking.  But if my session is suspended, it cannot perform the hourly backup.

    Eventually it is unable to find the external backup disk.


    Theory number two:

    My backup disk goes to sleep after a period of inactivity -- I haven't yet figured out if I can change this attribute or not.  If the disk goes to sleep, perhaps the time machine is not able to wake it up, and so cannot find the disk.

    I am able to wake up the backup disk by going to the Finder window and clicking on the disk and querying the contents.  However, after the time machine is unable to find the disk, waking it up after the fact does not remedy the problem.


    Theory number three:

    The gods are displeased with me, and jerk me around with this backup disk problem.


    Fortunately, this is an interesting problem.  My bypass is to reboot when the time machine disk is not found, and to initiate the time machine backup manually. 

    Interesting or it, I am actively searching for a remedy.


    Jim Taylor

    Winnipeg, Canada

  • BDAqua Level 10 Level 10

    When TM can't find it, does the Drive show up in System Profiler>Hardware>Firewire?

  • Jim Taylor Level 1 Level 1

    So far the external backup disk continues to fail regularly.

    For the past couple of days I had to reboot in order to bring the external disk back online after it could not be found.

    This afternoon when I rebooted, I got a message that "The disk you inserted was not readable by this computer."  The action button choices were "Initialize", "Ignore", or "Eject".




    I am beginning to think that the disk itself might be a lemon.


    My wife has a similar external G-DRIVE disk attached as her time machine backup drive, and it has been working flawlessly since September 2012.  I just checked it to be sure, and the latest backup was about half an hour ago on the regular hourly backup cycles.


    I will likely take this disk back to the Apple Store where I purchased it, and exchange for another.


    Does anyone have any comments or suggestions that might offer a solution on the present external disk?


    To recap:

    - I have reset the disk partitions from a boot partition to a non-bootable GUID partition

    - I have erased and reformatted the disk at least three times

    - I have run the disk utility "disk repair" on the disk several times.  The first few times it repaire a couple of things, but the other disk repair runs were clean

    - I have tried rebooting, and that seemed to work for a couple of hourly backup cycles, then today I got the "disk not readable my this computer" message.

    - I have tried running fsck on my iMac internal hard drive; though fsck found a couple of things to fix, it did not affect the stability of the time machine external backup disk

    - My MacOS Mountain Lion is fully up-to-date

    - another problem I've been having is intermittent system hangs (frozen screen, keyboard frozen), but it is difficult to imagine that this problem is related to the time machine problem


    I will click on the "Initialize" option and see what happens.  At this point, there is not much to lose, as I do not have much confidence in the time machine backup data that is on this disk. I will re-comission my old Time Capsule backup disk for now, until I can fix or replace the external G-DRIVE disk.


    Jim Taylor

    Winnipeg, Canada

  • Jim Taylor Level 1 Level 1

    One last question:

    Selecting the "Initialize" button simply opened the disk utiltiy.

    My backup partition had been formatted as Mac OS Journaled (extended case sensitive)


    I checked about the difference between "extended" and "extended case sensitive".

    Some comments indicate that "extended" should be OK, and recommended that the partition NOT be "extended case sensitive".  Apparantly some apps, even Apple-supplied apps, can run into problems with the case-sensitive formatting.


    So erasing and re-initializing my partition, changing only the extended option to be not "case-sensitive", my time machine is backing up its 465GB of data once again.

    After that first backup completes, we'll see what happens next.


    I checked my wife's backup disk and hers is Mac OS Extended (Journaled), and is not case-sensitive.


    Does anyone have any comments on case-sensive versus not case-sensitive with respect to the Time Machine backup disk?


    jim Taylor

  • BDAqua Level 10 Level 10

    Very well could be the case-sensitive problem, keep us posted please.

  • Jim Taylor Level 1 Level 1

    The first backup (almost 470GB) to the re-initialized disk took a few hours, as expected.

    This morning the backup had completed, and the disk was still available. I initiated another backup which completed OK, at about 08:25. 

    I created a few small test files with text edit, just to have something new on my internal disk for the time machine to back up. 

    Then I left the machine for a few hours to have breakfast and coffee with my wife, and wait a few hours to see what would happen with the backup disk.

    About 15 minutes ago I came back to check it, and it appeared to be OK, but the last backup registered was 08:25, with no hourly backups indicated.  I initiated a backup and it came back with the usual problem:  "Time machine couldn't complete the backup... an error occurred while creating the backup folder".


    Re-initializing the disk from "case sensitive" to not case-sensitive appears not to have been a solution to the probem.  At least I can state that I have tested this attribute also.


    I am coming to the conclusion that it is the backup disk itself, and not the Time Machine application nor the Mac OS X 10.8.2 nor the iMac hardware.


    I am going to head back to the Apple Store and purchase a new backup disk.  If it works properly, I will do a secure 3-times wipe of the old backup disk and return it to the Apple Store for a refund.


    If anyone wants to talk me out of this, let me know of another solution to try.

    However, I think I've run through all the list of remedies that should work, none of which have been "The Solution" to this problem.


    The G-DRIVE web site support page does not appear to have firmware updates for their G-Drives.


    Jim Taylor


  • Jim Taylor Level 1 Level 1

    Last thing:

    I swapped firewire 800 cables on the G-DRIVE box.

    Years ago (1970's) there was an old server that worked when the doors were open, and failed when the doors were closed.  After a week of technicians crawling all over the box to diagnose the problem, the office secretary pointed out that it worked when the doors were  open and failed when the doors were closed. She asked if there was something about the doors.  It turned out that there was a multi-wire flat cable on one of the doors, and it turned out to be a broken wire in the cable.  When the door was open, the wire made contact and it worked.  When the door was closed, the wire broke contact and it failed.  At that time, the part cost about $3.00 to replace. 


    After reading through firewire discussions, there are many complaints about firewire in relation to external disks, so I thought that changing the f/w 800 cable couldn't hurt, and it might help.


    After running the usual tests, I'll report back on the cable.

    If that doesn't work, I'll make a trip to the Apple Store to get a replacement drive.




    JIm Taylor


  • Jim Taylor Level 1 Level 1

    I bought the replacement external hard drive -- an identical G-DRIVE 4TB.

    Did a graceful shutdown, removed the failing disk and plugged in the new disk.

    Booted the iMac, it found the new disk as expected.

    I opened time machine preferences, went to SELECT DISK, and selected the old disk that was still in the configuration for time machine.  I REMOVED the old disk, closed time machine preferences, and did a graceful shutdown-reboot.

    On reboot, the system prompted me whether I wanted to use the new disk as a time machine backukp.

    YES, I said.  It opened the time machine preferences, and this time the old disk was gone from the selection list.  (Fortunately I gave distinct names to the external disks so it was easy to tell them apart)


    After the reboot, the old disk was gone and the new disk was in the list and already selected.

    I launched the backup -- a full backup of some 465GB. 


    I'll leave it alone to finish the backup, and leave it overnight to track the hourly backups.


    The manager at the Apple Store was quite decent and agreed that I could return the old disk, and expressed hope that the new disk would fix the problem.  I showed him the lengthy history of all the posts on this topic and he was satisfied that "due diligence" was complete.  I purchased the original disk on January 19th, and today is the two-week limit on the store's returns policy.  He agreed of the need to do a secure wipe of the old disk before returning it.

    They did offer to make an appointment with the Genuis Bar to have a tech look at it and run diagnostics, but appeared satisfied that (1) diagnostics and remedies have been tried already, and (2) in principle I did not want to leave my populated backup disk with the store unless it had been wiped.


    If the new disk works as hoped then I will do a secure wipe of the old disk before returning it to the Apple Store.


    I'll keep you posted, hopefully tomorrow morning before heading off to work.


    Jim Taylor


  • Jim Taylor Level 1 Level 1

    The new disk, so far, appears to be backing up OK. 

    I wrote a little script to update a file every 45 minutes to ensure that there would be something new to be backed up every hour.  Right now it is 7:30 am, and the last backup was taken at 7:10 am. 


    This looks encouraging.  I'll check again tonight after work, and if the time machine backups appear to be OK, then I'll initiate the secure wipe of the old disk and get it ready to return to the Apple Store.


    Jim Taylor


  • Jim Taylor Level 1 Level 1

    The new disk is, so far, performing flawlessly, as it should.

    Based on all the diagnostics mentioned in earlier posts, it is reasonable to conclude that the old disk was defective.  Therefore I will initiate a secure data wipe of the old disk, and prepare it for return to the Apple Store.


    Thanks to everyone who took interest in this curious problem and who provided valuable suggestions and advice. 

    Jim Taylor

    Winnipeg, Canada

  • BDAqua Level 10 Level 10

    It sure seems so Jim.

Previous 1 2 Next