6 Replies Latest reply: Feb 8, 2013 3:26 PM by nickloiacono
nickloiacono Level 1 (0 points)

I'm literally running a guitar straight into my computer (no plugins, no interface, just the "built-in input" on my macbook) and there's a LOT of latency. I'm very experienced with Logic and pro-audio (I have logic on my other computer and it works fine) but for some reason there's a ton of delay on my signal. NO idea where to start with this one. I've examined every option within Logic and nothing seems to be helping. I've changed every parameter, including buffer size, disabling and reenabling core audio, and low-latency mode, but nothing has worked.

 

Any advice would be appreciated, thanks.

 

Also, I'm using a late 2011 15" Macbook (Quad core, 4 GB ram)


Logic Pro, Mac OS X (10.7.5)
  • Pancenter Level 6 (9,470 points)

    If you're a very experienced Logic User you know that "Low Latency Mode" will have zero effect if you have no latency inducing plugins running...... right ?

     

    Use a 128 buffer setting.

     

    Audio Prefs set to Built-In Line IN  and  Built-IN Line OUT (or speakers)

     

    After this is all set, quit Logic.

    Reboot the Mac

    Still the same?

  • nickloiacono Level 1 (0 points)

    Yes I am fully aware, I just threw that out there so anyone reading wouldn't ask if I'd examined that option. I've restarted Logic, restarted my computer, tried several different buffer sizes, tried different in/out options, tried all parameter options within those tabs, set them back to standard defaults, etc. Nothing changes. I also just tried garageband... same issue. I have a bad feeling it has nothing to do with my software at this point. Maybe my computer's audio driver or something along the lines of. Not really sure what I should do about it.

  • Pancenter Level 6 (9,470 points)

    Never heard of this before... what are you using for output in Logic's Audio Prefs?

     

    Are you on 10.7.5 as you signature says?  There is a supplemental update for early builds of 10.7.5 that were released.

     

    Take a look at the Audio portion the "Audio-MIDI Setup" in Utilities.

    Bit-depth, sample frequency?  Try it at 16-bit 44.1kHz.  Is Logic set to the same?

     

    What kind of cable are you using to get the guitar into Logic, the Mac audio input jack is multifunction, could you be partially enabling the digital I/O.

     

    just tossing some ideas..

  • nickloiacono Level 1 (0 points)

    "Built-in output"

     

    Yes, I'm on 10.7.5. Tomorrow I'm going to take a look at the bit depth/sample rate tomorrow, perhaps something is out of synch.

     

    I'm going in via 1/4" cable with a 1/8" adapter. However, I ran in with a USB interface and there was still latency. I'm thinking that the hardware/input is okay.

  • Pancenter Level 6 (9,470 points)

    Here's a link to the supplemental 10.7.5 update.

     

    You may or may not need it depending on the version of 10.7.5 you have installed.

    If you can use it, by all means install it.

     

    If you go to Utilities/Audio MIDI Setup   You can adjust all of the built in audio parameters.

  • nickloiacono Level 1 (0 points)

    Sorry, where's the link? Also, adjusted every parameter in audio-midi, still nothing.