10 Replies Latest reply: Jan 29, 2013 10:54 PM by mende1
Shad D Level 1 (0 points)

I'm trying to do a hardware test on my Macbook Air 11" 1.6GHz i5 Mid-2011. I restart, press and hold D and then it shows a spinning globe "Internet Recovery". I wait and then it asks my to select a WiFi network. I select my network and enter the password but it doesn't accept the password. So I removed password restrictions on my router, I then rebooted, selected the network and it then connected. But nothing happens. There's no continue button, or 'next', it just shows the airport icon as connected with the network name and that's all.


So I thought it might have something to do with some partitioning I had done earlier to set-up ubuntu on the MBA, so I booted with the Mountain Lion Disk, entered Disk Utility, erased the SSD and re-installed OS X. I tried again and the same thing happens. Not sure if it's important, but when I restart the laptop and press/hold option key to show the disks, there is no 'Recovery HD', even after re-installing OS X.


I've also tried plugging in the Mountain Lion USB and holding D but the same thing happens.


Any ideas?