3 Replies Latest reply: Jan 30, 2013 12:22 PM by Alley_Cat
MetallicAsh Level 1 Level 1 (0 points)

After Apple had released the latest update for the Apple TV I turned mine on and went through the update process. It kept saying that there was an error and before long the "Status Light" started flashing quickly. So I plugged it into my MacBook Pro and went through the process of restoring it (downloading the software then installing it onto the Apple TV) but I kept getting Error 21. After looking it up and making sure I had the latest version of all the software and that there was no security software activated and many resets I tried resetting it via a Windows computer and got the same errors.


Anyone get any ideas?

Apple TV (3rd generation), iOS 6.0.2
  • Alley_Cat Level 6 Level 6 (17,960 points)

    Make sure there's no external USB hub and if you can try a different USB cable.


    I had to restore one of mine a few montsh ago - it gave errors  with one microUSB cable but worked with another.



  • MetallicAsh Level 1 Level 1 (0 points)

    I plug it staight in without using my hub, as for the USB cable, I only have the one. I'm tempted to just take it into the Apple Store and see if they'll sort it out there.

  • Alley_Cat Level 6 Level 6 (17,960 points)

    Yes, that might be worth doing.  Did you buy it there?  Should still be under warranty anyway.


    Personally I think it's daft they don't provide a micro USB lead in the box as it is needed to fix things when they mess up - hardly an expensive item to include.


    You could call the Cardiff store and see if they'll restore it for you:


    029 2055 6800