Previous 1 2 3 Next 31 Replies Latest reply: Feb 10, 2013 7:44 PM by Neil2 Go to original post
  • Neil2 Level 1 (0 points)

    Larry, I'm _restoring_  from Time Machine now.  It will take about an hour because it's 40gig.  I will try reinstalling next. 


    Old Toad:  Meanwhile I'll download iLife support, in case these steps don't work.

  • Neil2 Level 1 (0 points)

    Old Toad, iLife Support can't be opened because it's from an unidentified developer.  That's strange. 


    I reinstalled iPhoto again and it disappeared again.  It isn't in my application folder.  I did a spotlight search and it didn't turn up any apps.  That's very strange.  I'll try reinstalling a third time.

  • Neil2 Level 1 (0 points)

    Old Toad, I overrode security to launch the iLife Support installer, but it told me that it wouldn't run because I already had a newer version of the software installed.

  • Old Toad Level 10 (135,423 points)

    I see you've overrided the lock.  Here's how to do it permanently if you did something different:


    Go into the System/Security & Privacy/General preference pane, unlock the lock at the bottom and select the Anywhere radio button at the bottom.

    System Preferences001.jpg

    Then you should be able to run that updater


    Check in your System/Library/PrivateFrameworks/iLifeSlideshow.framework/Versions/A  folder to see if you have the missing "iLifeshow" file.


    If it's there repair disk permissions with Disk Utility, reboot and try again.

  • Neil2 Level 1 (0 points)

    OK, I got to the PrivateFrameworks folder and didn't see the iLifeSlideshow.framework folder.  So, I did a Spotlight search, just to be sure.  I don't have it even though I ran the iPhoto installer three times today and the iLife Support installer told me I already had a newer version (of iLife Support) already installed.


    Just to be sure, I entered Time Machine and did the search there too.  Nothing.

  • Old Toad Level 10 (135,423 points)

    Spotlight can't find it because it can't search system folders. Download and use  Find Any File to do the search.  It can search system and invisible folder and even packages like applications, etc.

  • Neil2 Level 1 (0 points)

    OK, I used Find Any File and did a root search and the item came up greyed out in the results window and the bottom of the window said '<item has disappeared>' without the quotes. 

  • Neil2 Level 1 (0 points)

    I also searched the package contents of the iPhoto installer and the iLife Support installer.  Not there either.

  • Old Toad Level 10 (135,423 points)

    If it's not there I wonder why the installer said there was a newer version of it already installed. I'll bet because there was a receipt


    Ah ha!  Run FAF again but this time looking for iPhotoLibraryUpgrader.


    Find Any File001.jpg


    Dag the .bom file and the .plist file to the trash from the search results window.  Then apply the  iPhoto Library Upgrader again. it should install.

  • Neil2 Level 1 (0 points)

    That was very clever, but the search result was still null.  I included invisible items and did root.  Nothing.

  • massiG82 Level 1 (0 points)



    I've the same problem. After re-install clean OS Lion, iphoto doesn't work. So, I started TM to recover a previous version (from a backup system with Snow Leopard) 8.1.2. Nothing successfully.

    I remember when I switched from Snow Leopard to Lion did not have this problem because it was not a clean install, After installation of LION I restored the settings I had in Snow.


    Another strange thing (for me, a "rookie") is that iMovie and iDVD using the same procedure work perfectly.


    Thanks to all in advance



    This is my report of the problem:


    Process:         iPhoto [308]

    Path:            /Applications/


    Version:         8.1.2 (8.1.2)

    Build Info:      iPhotoProject-4240000~8

    Code Type:       X86 (Native)

    Parent Process:  launchd [128]



    Date/Time:       2013-01-31 09:38:05.349 +0100

    OS Version:      Mac OS X 10.7.5 (11G63)

    Report Version:  9



    Interval Since Last Report:          30756 sec

    Crashes Since Last Report:           2

    Per-App Crashes Since Last Report:   2

    Anonymous UUID:                      3CF043A8-7820-4F75-A1EF-78765166443C



    Crashed Thread:  0



    Exception Type:  EXC_BREAKPOINT (SIGTRAP)

    Exception Codes: 0x0000000000000002, 0x0000000000000000



    Application Specific Information:

    dyld: launch, loading dependent libraries



    Dyld Error Message:

      Library not loaded: /System/Library/PrivateFrameworks/iLifeSlideshow.framework/Versions/A/iLifeSlid eshow

      Referenced from: /Applications/

      Reason: image not found



    Binary Images:

        0x1000 -   0x9fbfee (8.1.2 - 8.1.2) <436E886C-E26D-2C7D-9745-252829318EFE> /Applications/

      0xb31000 -   0xb5dffb (6.0.4 - 6040.4.1) <20BF6CE7-0923-3302-BE45-4880FA8A958D> /System/Library/Frameworks/DiscRecordingUI.framework/Versions/A/DiscRecordingUI

      0xb76000 -   0xb78fff (1.5 - 10) <7C514CC4-7951-31CA-AEB3-D4AF49F44AE7> /System/Library/Frameworks/ExceptionHandling.framework/Versions/A/ExceptionHand ling

      0xb7e000 -   0xc2bff7  libcrypto.0.9.7.dylib (0.9.7 - compatibility 0.9.7) <7B6DB792-C9E5-3772-8734-8D0052757B8C> /usr/lib/libcrypto.0.9.7.dylib

      0xc70000 -   0xc7afff (1.0 - 1.1) /Applications/ A/UpgradeChecker

      0xc84000 -   0xd20ffc (8 - 1.0) <47DF6C20-78C5-1AA2-1D64-274EAE522D93> /Applications/ leMe

      0xd82000 -   0xd82fff +eOkaoCom.dylib (??? - ???) <17ADB0F4-BF83-0B0B-5293-F843F1724644> /Applications/

      0xd86000 -   0xdb9fe7 +eOkaoDt.dylib (??? - ???) <673BD0C5-FAC4-ABB7-B55E-FD8A75E4759D> /Applications/

      0xdbf000 -   0xf25fff +eOkaoFr.dylib (??? - ???) <684982FE-55E4-174D-9CF3-DA4319BD57F9> /Applications/

      0xf29000 -   0xf4dff2 +eOkaoPt.dylib (??? - ???) <E2ED8DE8-7A2D-8309-3CB5-2E87F135A8A8> /Applications/

      0xf54000 -   0xf9bff7 (1.0.0 - 1.0.0) /Applications/ XTCore

    0x8fe40000 - 0x8fe72aa7  dyld (195.6 - ???) <60FD3471-A1D7-342E-99A7-3EDECDAEC6EC> /usr/lib/dyld

    0x90143000 - 0x90253fe7  libsqlite3.dylib (9.6.0 - compatibility 9.0.0) <34E1E3CC-7B6A-3B37-8D07-1258D11E16CB> /usr/lib/libsqlite3.dylib

    0x9062c000 - 0x90690fff (2.0 - ???) <94827954-5906-36C4-819B-24CDAFD85C72> /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit

    0x90691000 - 0x907a8fe9 (7534.57 - 7534.57.7) <85DAC34E-86A1-380F-B166-56630C9B0BD5> /System/Library/Frameworks/WebKit.framework/Versions/A/WebKit

    0x912e1000 - 0x915b0ffb (7.0 - 55148.6) <8DF67BDD-C98F-3B7E-AC63-D468407FA82D> /System/Library/Frameworks/Security.framework/Versions/A/Security

    0x916da000 - 0x9188eff3  libicucore.A.dylib (46.1.0 - compatibility 1.0.0) <4AFF6FC3-6283-3934-8EFC-CA227CA11164> /usr/lib/libicucore.A.dylib

    0x91ff0000 - 0x91ff0ff0 (41 - 41) <C48EF6B2-ABF9-35BD-A07A-A38EC0008294> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Application Services

    0x925b0000 - 0x92691ff7 (6.0.4 - 6040.4.1) <5841CEC8-6746-357E-9F0A-C0614320D153> /System/Library/Frameworks/DiscRecording.framework/Versions/A/DiscRecording

    0x92c8f000 - 0x92df2fff (7.7.1 - 2339) <163FBDDD-0458-378F-84DD-CB0F603A259E> /System/Library/Frameworks/QTKit.framework/Versions/A/QTKit

    0x94ed7000 - 0x9515cfe3 (7.7.1 - 2339) <FC82F13B-1788-3766-8681-7A3B1EFAE02D> /System/Library/Frameworks/QuickTime.framework/Versions/A/QuickTime

    0x964ea000 - 0x964eafff (6.6 - ???) <5FAFE73E-6AF5-3D09-9191-0BDC8C6875CB> /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa

    0x979a9000 - 0x979bffff (6.0.2 - 837) <BA53CE88-D89B-3C2C-BE59-5B747EF3EE7E> /System/Library/Frameworks/InstantMessage.framework/Versions/A/InstantMessage

    0x97a34000 - 0x97a34ff2 (53 - 53) <7CB7AA95-D5A7-366A-BB8A-035AA9E582F8> /System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices

    0x98197000 - 0x98449ff7 (6.1.3 - 1091) <B8CC707C-6368-3CDD-BE38-D2335B7CC2DE> /System/Library/Frameworks/AddressBook.framework/Versions/A/AddressBook

    0x9844a000 - 0x98758fff (5.3 - 1283) <FAEC957B-FC52-3561-94FE-23AD1A776DBD> /System/Library/Frameworks/Message.framework/Versions/B/Message

    0x9882e000 - 0x9883cfff  libz.1.dylib (1.2.5 - compatibility 1.0.0) <E73A4025-835C-3F73-9853-B08606E892DB> /usr/lib/libz.1.dylib

    0x99e9b000 - 0x99ea9fff (1.8.1 - 1.8.1) <766AFB12-A2CB-3A55-B662-FC9FFCAE0008> /System/Library/Frameworks/OpenGL.framework/Versions/A/OpenGL

    0x9a2aa000 - 0x9a2f2ff7 (1.11.3 - 1.11) <C8DE66D7-0880-3F5F-A4BA-215B52DEFC74> /System/Library/Frameworks/SystemConfiguration.framework/Versions/A/SystemConfi guration

    0x9a9e5000 - 0x9aa64ff7 (2.6.4 - 502.4.5) <5C10CC72-586E-3497-9873-A0ACFB6156C3> /System/Library/PrivateFrameworks/iLifeMediaBrowser.framework/Versions/A/iLifeM ediaBrowser

    0x9aa6e000 - 0x9ac45fe7 (6.7.2 - 635.21) <4D1D2BAF-1332-32DF-A81B-7E79D4F0A6CB> /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation

    0x9b545000 - 0x9b545fff (153 - 153) <63603A0C-723B-3968-B302-EBEEE6A14E97> /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon

    0x9c729000 - 0x9c729fff (1.7 - Accelerate 1.7) <4192CE7A-BCE0-3D3C-AAF7-6F1B3C607386> /System/Library/Frameworks/Accelerate.framework/Versions/A/Accelerate

    0x9ca91000 - 0x9caceff7  libcups.2.dylib (2.9.0 - compatibility 2.0.0) <007A1877-E981-3007-A8FA-9B179F4ED6D1> /usr/lib/libcups.2.dylib



    Model: MacBookPro6,2, BootROM MBP61.0057.B0F, 2 processors, Intel Core i7, 2.66 GHz, 4 GB, SMC 1.58f16

    Graphics: NVIDIA GeForce GT 330M, NVIDIA GeForce GT 330M, PCIe, 512 MB

    Graphics: Intel HD Graphics, Intel HD Graphics, Built-In, 288 MB

    Memory Module: BANK 0/DIMM0, 2 GB, DDR3, 1067 MHz, 0x802C, 0x31364A53463235363634485A2D3147314631

    Memory Module: BANK 1/DIMM0, 2 GB, DDR3, 1067 MHz, 0x802C, 0x31364A53463235363634485A2D3147314631

    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x93), Broadcom BCM43xx 1.0 (

    Bluetooth: Version 4.0.8f17, 2 service, 11 devices, 1 incoming serial ports

    Network Service: Wi-Fi, AirPort, en1

    Serial ATA Device: Hitachi HTS545050B9SA02, 500,11 GB

    Serial ATA Device: MATSHITADVD-R   UJ-898

    USB Device: hub_device, 0x0424  (SMSC), 0x2514, 0xfd100000 / 2

    USB Device: Ext HDD 1021, 0x1058  (Western Digital Technologies, Inc.), 0x1021, 0xfd130000 / 5

    USB Device: IR Receiver, apple_vendor_id, 0x8242, 0xfd120000 / 4

    USB Device: Built-in iSight, apple_vendor_id, 0x8507, 0xfd110000 / 3

    USB Device: hub_device, 0x0424  (SMSC), 0x2514, 0xfa100000 / 2

    USB Device: Internal Memory Card Reader, apple_vendor_id, 0x8403, 0xfa130000 / 5

    USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x0237, 0xfa120000 / 4

    USB Device: BRCM2070 Hub, 0x0a5c  (Broadcom Corp.), 0x4500, 0xfa110000 / 3

    USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8218, 0xfa113000 / 8

  • massiG82 Level 1 (0 points)



    I solved it, I restored the folder indicated by Old Toad using TM.



    Work perfectly.

  • Neil2 Level 1 (0 points)

    OK, I decided I would fix this by just buying the new version of iPhoto from the app store.  The thing is I still have the problem.  That is very strange.

  • Neil2 Level 1 (0 points)

    I'm afraid that I have now stumped everybody.  The app store should have installed everything I needed.

  • Neil2 Level 1 (0 points)

    I finally solved this problem.  I had to 'Reset Home Directory Permissionssions and ACL's'.  The instructios are here:



    Note that this isn't the same thing as repairing disk permissios in Disk Utility.