6 Replies Latest reply: Feb 2, 2013 12:32 AM by Terence Devlin
tzargregory Level 1 (0 points)

I've combined Events zillions of times in iPhoto and drag-'n-drop in Aperture 3 also. Today, when I tried to drag one Event into another, it didn't work. It didn't 'release' into the new event when I let go of the mouse button. I restarted iPhoto - same problem. Rebooted my MBP, same problem.


Tried to drag and drop a new photo into my Photostream (from Aperture this time) and the same problem. I click to drag, move the event, and then it appears 'ghosted' and will not release.


I even went into my Sys Prefs to see if it was my mouse, but that looked OK, and I could not replicate this problems in other applications.


I'd love to know why it does this (did I inadvertently check something somewhere) but more importantly, how do I fix this?


Oh yes - I got an error message the first few time about repairing iPhoto, which I let it do - took about 10 minutes, and I've never seen that before in iPhoto. (Aperture, yes, a LOT...)


Oh yes - I can 'Merge Events' from the Menu - that works, but seems cumbersome and the drag-and-drop has worked fine until today...


I am stumpped...





  • Terence Devlin Level 10 (137,920 points)

    As a Test:



    Hold down the option (or alt) key and launch iPhoto. From the resulting menu select 'Create Library'



    Import a few pics into this new, blank library. Is the Problem repeated there?

  • tzargregory Level 1 (0 points)

    Thanks Terence - I created a new library, imported some test pics, dragged and dropped without problem - thankyou!


    Now, what do I do to fix that in my current library?


    Thank you ever-so-much!



  • Terence Devlin Level 10 (137,920 points)

    Option 1

    Back Up and try rebuild the library: hold down the command and option (or alt) keys while launching iPhoto. Use the resulting dialogue to rebuild. Choose to Repair Database. If that doesn't help, then try again, this time using Rebuild Database.


    If that fails:


    Option 2

    Download iPhoto Library Manager and use its rebuild function. (In Library Manager it's the FIle -> Rebuild command)



    This will create an entirely new library. It will then copy (or try to) your photos and all the associated metadata and versions to this new Library, and arrange it as close as it can to what you had in the damaged Library. It does this based on information it finds in the iPhoto sharing mechanism - but that means that things not shared won't be there, so no slideshows, books or calendars, for instance - but it should get all your events, albums and keywords, faces and places back.



    Because this process creates an entirely new library and leaves your old one untouched, it is non-destructive, and if you're not happy with the results you can simply return to your old one. 




  • tzargregory Level 1 (0 points)

    Thanks Terence - this worked beautifully. I had gotten iPhoto Library Manager some time ago for another issue, and didn't think to try it. Had to restart the process as it crashed once, but the drag-and-drop issue is now gone.


    Did I do something to create this problem? I'm just wondering what I need to do to avoid this in the future - if it was me, or some mysterious software glitchy thing...


    Appreciate your help!



  • tzargregory Level 1 (0 points)

    Update: Well, I spoke too soon apparently. I've rebuilt the library several times since my previous update, but my problem now appears to go beyond iPhoto. The inability to 'drop' when I try to drag-and-drop is back as before. But now, I see that this problem happens even when I try to drag things on my desktop. The click-and-drag works, but there is no release - no ability to 'drop' in a new location. I realize this is likely no longer an iPhoto problem, but might you have any suggestions for me to proceed?





  • Terence Devlin Level 10 (137,920 points)

    Try the 'Using Mac OS X forum' for whatever version of the OS you have.


    Or try a new mouse...