Previous 1 2 Next 24 Replies Latest reply: Feb 1, 2013 8:32 PM by shirtandtieler
shirtandtieler Level 1 Level 1 (0 points)

Hello all,

So I recently got an Airport Extreme and hooked it up to my Westell modem (model: C90-610030-06). Innitially I had the router bridging to the modem, but I wanted it the other way around. So I turned the modem on bridge mode and disabled the LAN dhcp (had to do both to get rid of the "double NAT error"). In Airport Utility, I then connected using PPPoE (previously via DHCP but there was an "internet connection" error and switching to PPPoE solved that). And the router is in DHCP and NAT mode. I also added the iMac, that the router is hooked up to via ethernet, to the DHCP reservations.

 

On the Airport Extreme, the light is green. The Airport Utility shows no errors. However, the light next to where it says "Internet" is orange. At this point, Im confused how to resolve this problem. I've spent so many countless hours resolving the double NAT issue (despite putting the modem on bridge mode) that I am done fiddling around with this.

 

I realize I might be missing something obvious so ANY help would be appretiated. Ill be glad to give any more relevant info if needed.

Also, I really don't want to go through the hassle of solving my problem any other way than the route I've taken. I realize it might not be the most "efficient" but it's what I need to do.


Airport Extreme, OS X Mountain Lion (10.8.2)
  • Bob Timmons Level 10 Level 10 (91,810 points)

    Bridge Mode on the modem and Connect Using = PPPoE on the AirPort Extreme would be the correct way to configure things if you are using ATT.

     

    You don't mention what service you are using, but most DSL providers would be compatible with the same type of setup.

     

    You may have already done this but it typically takes several modem and router power downs and restarts whenever you are making configuration changes on both the modem and router.

     

    Try powering off the modem, waiting a minute and then restarting. Then do the same with the AirPort Extreme while the modem stays "on".

     

    If that does not work, it might be good idea to set up a temporary or test PPPoE connection on the Mac and see if the modem will work correctly when it is connected directly to the Mac. Post back if you are not sure how to do this.

     

    If things work this way, at least you know the modem is working correctly in Bridge Mode.

     

    If you still cannot get an Internet connection during this "test".....when the modem is connected directly to the Mac.... then you know that the modem is either not configured correctly, or it is simply not functioning in Bridge Mode. More modem work will be required.

     

    If you can get an Internet connection when the modem is connected directly to your Mac, then we'll try to get the AirPort Extreme working.

     

    Important......Remember to delete or inactivate the PPPoE connection on the Mac now.....before  you connect the modem to the AirPort Extreme......since you cannot have two devices on a network both trying to initiate PPPoE service.

  • shirtandtieler Level 1 Level 1 (0 points)

    Bob Timmons wrote:

     

    If that does not work, it might be good idea to set up a temporary or test PPPoE connection on the Mac and see if the modem will work correctly when it is connected directly to the Mac. Post back if you are not sure how to do this.

     

    I'm more not sure as to what you mean by this. I know for sure that the connection works if the modem's using a  PPPoE connection and directly connected to the Mac....not sure if the test that you are saying I should try is something else, though?

     

    As for your last note - That won't be a problem since I can't have a PPPoE connection on the modem and be in bridge mode.

     

    Either way, I shall return tomorrow morning with results. It's 1:30am when I am viewing this and WAY too tired to do it now, but thank you for your quick reply!

  • Bob Timmons Level 10 Level 10 (91,810 points)

    I'm more not sure as to what you mean by this

     

    What I mean is that IF the modem really is in Bridge Mode......you cannot then connect the modem directly to your computer and get an Internet connection that way.......UNLESS.....you set up a special connection on the computer.

     

    You won't have to worry about this if you can get the AirPort working with the modem.

  • shirtandtieler Level 1 Level 1 (0 points)

    OK! Back with some more details. I'm going to lay this out really simple so that you get the full picture. I have people relying on me to get this problem fixed so I'm very determined to get it fixed! haha

     

    So when the modem is directly connected to the mac....if it's in PPPoE, there's connection; if it's in bridge mode, there's no connection. So that leads me to believe there is not a special connection.

     

    I power cycled the modem and router twice (shut computer off, unplugged modem and router, waited, plugged in modem, waited for it to initialize, plugged in router, waited for it to initialize and turn green, then turned comptuer back on).

     

    I also did your method two times as well. I  first unplugged the modem, waited a minute, and then plugged it back in (while it was unplugged, airport utility gave me the "ethernet unplugged" error which went away once the modem was back up and plugged in).

    Then I unplugged the router, waited a minute, and then plugged it back in (after I pluged it back in, it gave me the "PPPoE server" and "Internet Connection" errors. This went away by itself after about a minute).

     

    As for other details - It is in fact AT&T service. I also double checked to make sure all the cords are in the right place and also tried full resets of both devices.

    In the end, the problem remains the same. The link below is a picture of my (problematic) setup when the modem's in bridge mode and the router's set up for PPPoE: http://i50.tinypic.com/mv1dsi.jpg

    (On the modem, the "Power" "ethernet" and "dsl" lights are on)

  • Bob Timmons Level 10 Level 10 (91,810 points)

    I don' have a Westell modem, so cannot test that aspect of your setup. I do have an older Motorola ATT 2210 modem, which I configured in Bridge Mode and then set up a spare AirPort Express here to connnect using PPPoE.

     

    As luck would have it, things worked fine the first time that I powered things up. I've since tried to "break" the connection to try to figure out why your setup is not working. So far, I cannot duplicate the errors that you are reporting.

     

    So, here are the possibilities:

     

    1) The modem is not really in Bridge Mode....or if it is...it is not functioning correctly. Please verify that you have gone into the modem settings using a default IP address....something like 192.168.1.254 for example only....... to bring up the configuration pages for the modem and then chosen the Bridge Mode setting, saved the configuration, etc.

     

    2) The AirPort's PPPoE settngs are not working correctly. Here, I assume that you have entered your ATT user name and password in the setup of the AirPort.

     

    So, to summarize.....we do not know whether you have a modem problem....or an AirPort problem....or both devices are problematic, which is possible, but not likely.

     

    There is a way to find out whether the modem is working correctly in Bridge Mode.....and that is to set up a PPPoE connection on your Mac.....as a temporary test. In this test, your computer would simulate the PPPoE connection from the router.  You would keep the AirPort Extreme powered off and disconnected during this test process.

     

    If you connect the modem directly to the Mac....and if the computer can connect using a PPPoE setup on the Mac (I will tell you how to do this).....then you know that the modem is working correctly in Bridge Mode. So that eliminates one of the possibilities above and points to the AirPort Extreme as the device that needs more troubleshooting.

     

    Does that make sense? Do you want to do this?

  • shirtandtieler Level 1 Level 1 (0 points)

    Absolutely, I want to know! Haha. Thanks in advance!

  • Bob Timmons Level 10 Level 10 (91,810 points)

    Power off the AirPort Extreme

    Disconnect the Ethernet cable from the modem

     

    On your Mac.......

     

    Open Sysem Preferences

    Open Network

    Click the small + (plus) button at the bottom of the connection list on the left

    Click on Interface and select PPPoE

    Click Create

     

    Now Click on the new PPPoE connection on the left column

     

    On the right, leave the Service Name area blank

    Under Account.....enter the ATT user name

    Under Password....enter the ATT account password

     

    Connect the modem directly to the Ethernet port on your Mac

    Turn off wireless on your Mac if it is on

     

    Click Connect

     

    Wait a minute to see if the Mac's PPPoE connection service will work with the modem

     

    See if you can get an Internet connection on the Mac

     

    If you can.....then you know the modem is working correctly in Bridge Mode

     

    If you can't....then you know that the modem is not working correctly.

     

     

     

    Screen Shot 2013-01-31 at 5.55.50 PM.png

  • shirtandtieler Level 1 Level 1 (0 points)

    Well thank you again for that tutorial! There's a lot that I wrote as I was writing as I went. However, there's a summary at the very bottom if you don't feel like reading through all of this haha.

     

    Small bit of back story before I mention the results - I can have a successfull connection with the modem using a PPPoE connection and the router in bridge mode. Of course, my intended goal is to have that flip floped. So when I started your tutorial, I actually had the modem/router settings set up in the connected-but-unwanted way (modem using PPPoE/router in bridge). I took everything step by step and transitioned step by step so as to be able to provide you with all the details, so sorry in advance about the length of this post.

     

    Now as for the results - I followed your tutorial in the order that you had mentioned it. When I did it that way (with the modem being directly connected to the Mac) the PPPoE connection that was setup in the Network settings worked. I then put the modem into bridge mode. After I did that, it still worked.

     

    So then I decided to add the router into the mix. That's when things went off the cliff. When I plugged the router in, a pop up said, "You were disconnected because the PPP server is not responding. Try reconnecting." I clicked OK then continued into Airport Utility to change the router to "NAT and DHCP mode." After I did that, I applied it, restarted the router and then got the "Double NAT" error. Despite the error, and just to cover all my tracks, I still tried connecting to the PPPoE connection that was made through your tutorial and it failed (not to my surprise).

     

    I then went back into the router settings and changed the "Connect using" from DHCP to PPPoE. After this, the router had no more errors and gave me the green light. However, the same problem was still there where despite this, I still couldn't connect to the internet.

     

    Finally, I went back into the Network settings and tried reconnecting to the PPPoE network that I created through your tutorial. This resulted in it giving me the message "Could not find the PPPoE server."

     

    Something did perplex me, though, and it lead to me solving this problem (I think!). If I had the modem was in bridge mode, but the router connected using DHCP and in bridge mode, I could connect to the internet this way if and only if I used the PPPoE connection made by your tutorial. So then I was thinking - if I put the router as connected using PPPoE, it will automatically put it in DHCP and NAT mode. However, what if I kept it connecting as DHCP but had it in DHCP and NAT mode? So I tried this and the PPPoE connection made through your tutorial went down, I had no internet and got the "Double NAT" error. Then I just dialed it back to just DHCP only. I clicked update but it gave me "invalid value - Sharing a range of IP addresses using DHCP only requires manually configuring your WAN IP address." So I raised the starting DHCP range from 192.168.1.2 to 192.168.1.100. This let me successfully updated and it connected! I am just not certain what I should do for the DHCP reservations as I do need to open up a few ports....

     

    Summary: Here's how the end result looked - The router was configured to connect using PPPoE, was in DHCP and NAT mode, and the device itself had the green light. The modem was configured in bridge mode and on the device itself, the power, ethernet and dsl lights were all green. In the network settings, the ethernet was stated as connected, the PPPoE status was statd as not connected and I have no internet.

    However, I CAN connect to the internet using the PPPoE connection I made through your tutorial if I can have modem in bridge mode and the router in DHCP only.

  • Bob Timmons Level 10 Level 10 (91,810 points)

    I assume that you remembered to disable the PPPoE connection on the Mac when you connected the modem back to the router.

     

    The bottom line to all of this is that the modem is working correctly in Bridge Mode, (you verified this by having the Mac connect directly to the modem in the test), but the router is having problems providing the PPPoE service to allow a valid Internet connection.

     

    There are no more settings on the AirPort that can be adjusted or changed in this regard, so if your goal remains to have the modem in Bridge Mode and the AirPort provide the DHCP and NAT service, you will need to try another AirPort.

     

    This connection method has worked correctly for me for years with an AirPort Extreme and a modem configured in Bridge Mode.

  • shirtandtieler Level 1 Level 1 (0 points)

    Bob Timmons wrote:

     

    if your goal remains to have the modem in Bridge Mode and the AirPort provide the DHCP and NAT service, you will need to try another AirPort.

     

    This connection method has worked correctly for me for years with an AirPort Extreme and a modem configured in Bridge Mode.

    Yes, that is my goal but before I go on, I just want to make sure all the ground has been covered:

    With the modem in bridge mode, the PPPoE connection that I set up through your tutorial works when the router's in DHCP only mode and NOT in DHCP and NAT mode. When I set it in DHCP and NAT mode, the router gives me the Double NAT error and the PPPoE connection drops.

     

    Are you saying that there's nothing I can do to get around these problems? If so, how would trying another AirPort help?

  • shirtandtieler Level 1 Level 1 (0 points)

    And if not, then this thread is finished and I'll have to go back to trying to forward ports off of my modem. If you're asking why I just didn't do that in the first place - I tried to. But my modem is discontinued and support for it is through AT&T, not Westell (the brand of it). So help for doing that has been very unsuccessful haha :/

  • Bob Timmons Level 10 Level 10 (91,810 points)

    Please provide a screen shot to verify that the modem is set up to operate in Bridge Mode.

     

    Some of what you are telling me now indicates that it is not...and you told us it was. All of our instructions assumed that you were providing correct information.

     

    For example, you could not have a Double NAT error if the modem is in Bridge Mode since NAT is turned off on the modem when it is configured in Bridge Mode.

  • shirtandtieler Level 1 Level 1 (0 points)

    Posting more info than you probably need, but thought it might help. Went through step-by-step how I changed to bridge mode.

    This first picture is the Home Summary when I first go into the modem settings:

    Screen Shot 2013-02-01 at 5.00.52 PM.png

    The picture below is the screen I get when I click on "Broadband DSL line" :

    Screen Shot 2013-02-01 at 5.01.47 PM.png

    On the right side of the picture above, there is the button "Configure Connection". I click on that and then the picture below is what the next screen looks like:

    Screen Shot 2013-02-01 at 4.59.52 PM.png

    In the picture above, I click on the drop down box and change the protocol to Bridge Ethernet. There are two types of bridging I can do, the first option is "Bridge" and the second is "Routed Bridge." I was told to choose "Bridge" so that it what I did. The picture below is what the screen looks like when I change it to Bridge Ethernet:

    Screen Shot 2013-02-01 at 5.02.57 PM.png

    After I clicked "Save and restart connection" in the picture above, it then restarted and took me to the Home Summary page that you see below (The router at this time is in DHCP only mode and reconnected to the PPPoE connection I made through your tutorial so that I would get internet again) :

    Screen Shot 2013-02-01 at 5.05.17 PM.png

    The picture below is what the Broadband DSL Line page looks like after I configure it to bridge mode:

    Screen Shot 2013-02-01 at 5.06.21 PM.png

  • shirtandtieler Level 1 Level 1 (0 points)

    And if you're curious what is under the "Home Network" tab :

    Screen Shot 2013-02-01 at 5.22.05 PM.png

Previous 1 2 Next