3 Replies Latest reply: May 25, 2013 11:56 AM by netesh
michelsalters Level 1 Level 1 (0 points)

When I open up my MacBookPro in the room where the WiFi transmitter is located it will not connect with it. When inspecting the networks list I notice that my own network is not listed. When the name of the home network does appear trying to connect with it will lead to a timeout error.

When I take the computer upstairs (3rd level, 20 meters away from the WiFi box and have two solid concrete floors between it) the network will be recognized and connected to right away.

 

Windows 7 computers, the iPad, an IPodtouch, and 4 smartphones of diverse brands do not have this problem. My other Macbook with osx 10.6 has the same problem.

 

Anybody solved this?

 



MacBook Pro, OS X Mountain Lion (10.8.2), same problem with osx 10.6
  • Tesserax Level 8 Level 8 (49,470 points)

    Try the following on your MBP, in order, until (hopefully) resolved:

     

    1a. Delete Preferred Network(s)

     

    • System Preferences > Network > Wi-Fi > Advanced > Wi-Fi tab
    • Under "Preferred Networks," delete the network(s) you regularly use from the list.

     

     

    1b. Delete AirPort Keychain Entries

     

    • Launch the "Keychain Access" application located in Applications/Utilties.
    • In the windows on the left side: Select login for Keychains and "All Items" for Category.
    • Click on the "Kind" filter at the top, and look for any "AirPort network password" entries...and delete them.

     

     

    1c. Add Preferred Network(s)

     

    • System Preferences > Network > Wi-Fi > Advanced > Wi-Fi tab
    • Add the preferred network(s) using the "+" button.
    • Restart or log out then back in.

     

     

    2. Move System Configuration Files

    (Note: You will have to reestablish your network connections settings.)

     

    • Go to /Library/Preferences
    • Move the SystemConfiguration folder to the desktop.
    • Restart your Mac. (Note: OS X will rebuild the files that are now sitting on your desktop. If this doesn't resolve the issue, you can move the folder back to it's original location.)
  • michelsalters Level 1 Level 1 (0 points)

    Hi, thanks for thinking with me on this.

    All steps you describe are being done, the result stays the same.

     

    What happens is that the strongest WiFi network (mine) is just unvisible to the computer when I'm close to the box. When I go further away from the box (so the signal gets lower) my computer will see the network and connect.

     

    There are 7+ WiFi networks available in that room, so I think the Mac gets confused or something.

  • netesh Level 1 Level 1 (0 points)

    This worked for me.

    I did the exact steps and now i can access my wi-fi signal.

     

    Thanks a ton!