Previous 1 2 3 4 Next 75 Replies Latest reply: Mar 8, 2013 9:33 AM by Shareef Yousef Go to original post
  • mikewede Level 1 (0 points)

    Sorry, it requires a developer login, so I cannot provice a link

  • htilly Level 1 (10 points)

    This solved our problem:

     

    /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/XProtect.meta.p list

     

    <?xml version="1.0" encoding="UTF-8"?>

    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

    <plist version="1.0">

    <dict>

    <!--

            <key>JavaWebComponentVersionMinimum</key>

            <string>1.6.0_37-b06-435</string>

    -->

            <key>LastModification</key>

            <string>Thu, 31 Jan 2013 04:41:14 GMT</string>

            <key>PlugInBlacklist</key>

            <dict>

                    <key>10</key>

                    <dict>

                            <key>com.macromedia.Flash Player.plugin</key>

                            <dict>

                                    <key>MinimumPlugInBundleVersion</key>

                                    <string>11.3.300.271</string>

                            </dict>

    <!--

                            <key>com.oracle.java.JavaAppletPlugin</key>

                            <dict>

                                    <key>MinimumPlugInBundleVersion</key>

                                    <string>1.7.11.22</string>

                            </dict>

    -->

                    </dict>

            </dict>

            <key>Version</key>

            <integer>2028</integer>

    </dict>

    </plist>

  • Thorsten007 Level 1 (5 points)

    This command solves the problem here for us:

     

    sudo /usr/libexec/PlistBuddy -c "Delete :JavaWebComponentVersionMinimum" /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/XProtect.meta. plist

     

    (it removes a key from the mentioned file, requires administrator privileges)

  • Janemann Level 1 (5 points)

    The thing is that all will not keep apple away from disabling it again... our little app bypasses the webstart and launches fcsvr right from the server.

     

    NoWebStart - No Problems!

     

    http://moovit.de/index.php/TechBlog/Techblog/finalcut-server-won-t-launch-after- restart

     

    Greets Jan

     

    www.moovit.de

  • newrulez Level 1 (0 points)

    at me persists the problem. also when i delete the minium webstart requeriements shizzle in the xprotect.meta.plist

  • bastian_kroll Level 1 (0 points)

    THIS HELPS ME! Commenting out the lines in the XProtect.meta.plist!

     

    Also an update to the Apple Developer 1.6.0_38 solves the problem tested on another machine

  • yabbanoname Level 1 (0 points)

    Nope, XProtect.meta.plist didn't fix it overhere

  • newrulez Level 1 (0 points)

    here you can download the java developer update 1.6.38 WITHOUT develper account

     

     

    https://developer.apple.com/downloads/index.action?name=Java%20for%20OS%20X%20De veloper%20Preview

  • Thorsten007 Level 1 (5 points)

    It seems like Apple tried to define Java 1.6.0.37-435 as the least allowed Java version to be used for WebStart by defining

    JavaWebComponentVersionMinimum = 1.6.0_37-b06-435

    but currently the most recent 'official' version deployed by Apple is 1.6.0_37-b06-434.

     

    Please note: Commenting out the lines or using the command line i posted above will allow any 1.6 to be used for Java WebStart and so MAY be a SECURITY ISSUE!

  • yabbanoname Level 1 (0 points)

    Well, it removed my Java Preferences.app  again and didn't solve my issue ...

  • emstewart Level 1 (0 points)

    The command to comment the key in the plist file worked for our webstart application.

    Thanks to all of you for the help.

     

     

    sudo /usr/libexec/PlistBuddy -c "Delete :JavaWebComponentVersionMinimum" /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/XProtect.meta. plist

     

     

    it worked on the 6 systems we have here.

     

    E.

  • PhilipVL Level 1 (0 points)

    The solution of htilly solved our problem.

    Thnx a lot

  • WroDo Level 1 (0 points)

    This did solve it for me, and keeps working after reboot:

     

     

    sudo defaults write /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/XProtect.meta JavaWebComponentVersionMinimum "1.6.0_37-b06-434"

    sudo chmod +r  /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/XProtect.meta. plist



    What does it do:

     

    Since 1.6.0_37-b06-434 is actually installed (you can check with "java -version"), I set this as the required version. If the key exists, it won't be set again.



    Yours, Heiko
  • Matthew Knight Level 1 (15 points)

    It sounds like Apple need to fix this, then.

     

    Hope they get around to it soon, as I am going to have to use my Windows 7 VM to access our Java Applet.

     

    I'm not keen on deleted stuff from CoreServices using sudo in Terminal.

Previous 1 2 3 4 Next