Previous 1 2 3 Next 75 Replies Latest reply: Mar 8, 2013 9:33 AM by Shareef Yousef
yabbanoname Level 1 Level 1

Today after restart the javaws refused to work again (after been fixed 2 months ago with http://support.apple.com/kb/HT5559).

Removed the plugin JavaAppletPlugin.plugin again, and still didn't work.

the symbolic link for /usr/bin/javaws was stil active:

$ ls -l /usr/bin/javaws

lrwxr-xr-x  1 root  wheel  64 Oct 23 11:20 /usr/bin/javaws -> /System/Library/Java/Support/Deploy.bundle/Contents/MacOS/javaws

 

Starting javaws from command line with url shows:

 

Java Web Start splash screen process exiting .....

Bad installation. No JRE found in configuration file: No such file or directory

 

Anybody knows the fix for this one ? (advise don't restart before you know the fix).

Solved by htilly on Jan 31, 2013 3:30 AM Solved

This solved our problem:

 

/System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/XProtect.meta.p list

 

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

<plist version="1.0">

<dict>

<!--

        <key>JavaWebComponentVersionMinimum</key>

        <string>1.6.0_37-b06-435</string>

-->

        <key>LastModification</key>

        <string>Thu, 31 Jan 2013 04:41:14 GMT</string>

        <key>PlugInBlacklist</key>

        <dict>

                <key>10</key>

                <dict>

                        <key>com.macromedia.Flash Player.plugin</key>

                        <dict>

                                <key>MinimumPlugInBundleVersion</key>

                                <string>11.3.300.271</string>

                        </dict>

<!--

                        <key>com.oracle.java.JavaAppletPlugin</key>

                        <dict>

                                <key>MinimumPlugInBundleVersion</key>

                                <string>1.7.11.22</string>

                        </dict>

-->

                </dict>

        </dict>

        <key>Version</key>

        <integer>2028</integer>

</dict>

</plist>

Reply by Thorsten007 on Jan 31, 2013 4:05 AM Helpful

It seems like Apple tried to define Java 1.6.0.37-435 as the least allowed Java version to be used for WebStart by defining

JavaWebComponentVersionMinimum = 1.6.0_37-b06-435

but currently the most recent 'official' version deployed by Apple is 1.6.0_37-b06-434.

 

Please note: Commenting out the lines or using the command line i posted above will allow any 1.6 to be used for Java WebStart and so MAY be a SECURITY ISSUE!

Reply by jlnovak on Jan 31, 2013 12:26 PM Helpful

I found an easier solution that involves editing the XProtect.meta.plist file that can be found at

/System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/XProtect.meta.p list

 

On line 6:

<string>1.6.0_37-b06-435</string>

 

 

Should be:

<string>1.6.0_37-b06-434</string>

 

This allows us to launch java apps from the browser.

All replies

  • mikewede Level 1 Level 1

    In my company we have several customers with exactly the same problem.

     

    All got OSX 10.6.8 and Java version 1.6.0_37.

     

    The problem appears after restart/start today.

  • yabbanoname Level 1 Level 1

    I expect the problem could be fixed with proper entries in ~/.java/.deployment/deployment.properties (still looking for the proper settings)

  • bastian_kroll Level 1 Level 1

    Same problem here: Start of javaws in the morning was working (Mac was only in sleep-mode overnight), after restart javaws isn´t working any more.

    We have also a lot of customers with Java 1.6.0_37 and Mac OS 10.6.8 reporting the same error in the morning.

     

    Still looking for a solution

  • wim_hocu Level 1 Level 1

    Same problem here javaws configfile error

  • newrulez Level 1 Level 1

    since today i have also following error when i want to start javaws

     

    sh-3.2# javaws

    Java Web Start splash screen process exiting ...

    Can not find message file: No such file or directory

  • Janemann Level 1 Level 1

    Hi we see that issue at a couple of customers using FinalCutServer. Thanks apple for the nightly "fix"! We figured out the problem already and we are workin on a fix for that maybe in form of a little app. I will post it here as soon it is ready.... stay tuned!

     

    Jan

    www.moovit.de

  • emstewart Level 1 Level 1

    Does anyone know what the update actually did?  I mean to reverse engineer on individual systems by hand?  This morning my systme had the Java Web Start disabled in the preference panel.  I reactivated it, logged out and back in.  Still my .jnlp file won't launch.  From command line, just opening the view showed this:

     

    $ /System/Library/Frameworks/JavaVM.framework/Commands/javaws -viewer

    Java Web Start splash screen process exiting .....

              Bad installation. No JRE found in configuration file

     

    And a normal execution initiates the System Software Update, which has nothing naturally.

     

    Could it be a configuration file we can edit to reinstate the correct indication to the JRE?

     

    E.

  • frogX Level 1 Level 1

    Apple has updated: /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/XProtect.meta. plist

     

    Only solution for me up to now: use an old version from Timemachine-Backup.

     

    greetings, volker

  • htilly Level 1 Level 1

    Hi Janemann,

     

    Care to share the root cause of the problem? We´re having the same problem and would really like to know how to fix this. App is nice, but we would be more interesting in the exact solution in order to distribute the fix with our own tool.

     

    Thanks in advance!

     

    /Tilly

  • woodmeister50 Level 5 Level 5
    expertise.serversenterprise
    Servers Enterprise

    FWIW, this covert update also kills JAVA plugin use

    in Safari.  Even with latest (downloaded and installed today)

    Java, Safari is saying plug in blocked because out of date.

     

    Will try replacing the Xprotect stuff from old clone per suggestion.

  • wim_hocu Level 1 Level 1

    On OSX 10.6.8 no update same problem it seems

    in terminal command line No Java runtime present

    java -version

    1.6.0_37

  • mikewede Level 1 Level 1

    If you have a developer account, you can login to the developer center and download:

     

    Java for OS X Developer Preview 11M4001+10M4001

     

    That is Java 1.6.0_38 and fixed the problem on my machine.

     

    But my problem is that I cannot distribute this to all our customers.

  • newrulez Level 1 Level 1

    can you please provide here a download link to download it

  • Janemann Level 1 Level 1

    Here as promised you have the fix...

     

    http://moovit.de/index.php/TechBlog/Techblog/finalcut-server-won-t-launch-after- restart

     

    Downloadthe Finalcutserver app and replace it with your app on you client system.... no worrys we are a serious company... let me know if that works for you!

Previous 1 2 3 Next