11 Replies Latest reply: Feb 6, 2013 8:52 AM by Old Toad
Hiflyer47 Level 1 Level 1 (0 points)

My new iPhoto '11 crops my photos before sending to the printer. This results in photos with partially missing heads and feet. My iPhoto 9 never did this. It always printed the photos as shown in the program. It happens on standard 4X6 photos. How can I resolve this, or do I need to reinstall iPhoto 9 ?


iPhoto '11, OS X Mountain Lion (10.8.2), Macbook pro
  • LarryHN Level 9 Level 9 (62,145 points)

    Crop the photo to 4x6 before printing or click on the customize button and right click on the preview ad select fit to frame

     

     

    and BTW if you printed a photo that was too big for the print size it always have been cropped - no change between iPhoto '09 and '11 (or iPhoto 6 and '11 for that matter) you have never been able to print a 4x7 photos on a piece of 4x6 paper

     

    LN

  • Hiflyer47 Level 1 Level 1 (0 points)

    Okay, thanks. I'll try it. I'm just saying, I NEVER had this problem with any previous iPhoto programs. Why it suddenly "cropped up" in iPhoto 11, I don't know. Appreciate the help.

  • Old Toad Level 10 Level 10 (123,615 points)

    I'm sure your mistaken because in every version of iPhoto that I have running, Version 6 thru 9.4.2, the images get chopped off if they are not cropped to the stock size being printed on.

     

    V6 would scale the photo to fit the 4 x 6 stock but would leave white space at one end if the imge size didn't fit the stock size.

     

    OT

  • Hiflyer47 Level 1 Level 1 (0 points)

    Actually, I wouldn't mind if it left a little white space at the end of the photo, if it wouldn't crop the top and bottom of the photo.  I have tried right clicking on the "customize" button and selected "fit to frame." It's better, but  it still crops a lesser amount off the top and bottom of the photo than before. Just enough to take a perfect photo of my granddaughters, and cut off the top two inches of their head, and the toes of their shoes. I still think I should be able to print what I see in iPhoto, not a slightly cropped version. G-r-r-r.

  • Old Toad Level 10 Level 10 (123,615 points)

    still think I should be able to print what I see in iPhoto,

    You can by picking a print size that is smaller than the page size you're printing to. 

  • Hiflyer47 Level 1 Level 1 (0 points)

    Sorry, OT, but your solutions don't work, they only reduce the problem slightly. Picking a print size that is smaller gives me a border around the 4X6 photo, but it is still slightly cropped - just enough to ruin the photo. And, it IS in the iPhoto program, because in the preview BEFORE printing, it shows the slightly cropped photo exactly as it will print. It's pretty frustrating, and I hope Apple gets this fixed. I simply am unable to print the photo as shown in iPhoto.....

  • Old Toad Level 10 Level 10 (123,615 points)

    Not if you pick a custom size with the same size ratio as the image file.  If it's from a digital camera it'll be 4:3.  So if you're printing to a 4x6 stock try a custom size of 4 x 5.33.

  • Hiflyer47 Level 1 Level 1 (0 points)

    Sorry, OT, have tried that and several other sizes. The same exact thing happens every time. The photo is still slightly cropped BEFORE sending it to the printer. It's not like I'm using some strange camera. It's a Canon Elph that I have taken many photos with. Never happened before. I revert to my original statement, in that I have NEVER had this problem before, and I seem to be unable to resolve it. I know the solution seems simple to you, but it simply does not work. Perhaps there is a flaw of some type in my iPhoto program - I don't know. All I know is that I cannot seem to resolve it, no matter what I do. This has only occurred in the past two weeks since I have been using iPhoto 11 on my new MacBook Pro 15" with the retina display.

  • Old Toad Level 10 Level 10 (123,615 points)

    You must not be doing it correctly.

     

    This image has a  4:3 in size ratio:

    iPhoto002.jpg

    iPhoto001.jpg

     

    I set the paper size to 4 x 6 and the print size to 5.33 x 4 and get this when I print to a 4x6:

    P1020507.JPG

     

    If you check the white triangles at the edges you'll see the height hasn't been cropped.

  • Hiflyer47 Level 1 Level 1 (0 points)

    Thanks for the advice, O.T. In fact the way you show is exactly how I did it, and I still end up with a cropped photo, top and bottom.  By looking at your images, I can indeed see that the triangles along the top and bottom edge of your printed photo are  slightly cropped from what you show in iPhoto. In fact, your finished photo shows the printed words on the bottom of the iPhoto shot missing in the printed photo. My cropping is slightly more exaggerated than that, but cropped neverthless.I have the same slight border along the outside edge.

        Final analysis means I will try to frame my photos better when I take them, leaving a bit more space on the top and bottom. But, it has sure wrecked a number of otherwise nice photos. Hopefully, Apple will get this fixed in a future update.

      Thanks again.

  • Old Toad Level 10 Level 10 (123,615 points)

    Try the following:

     

    1 - delete the iPhoto preference file, com.apple.iPhoto.plist, that resides in your

         User/Home/Library/ Preferences folder.

     

    2 - delete iPhoto's cache file, Cache.db, that is located in your

    User/Home/Library/Caches/com.apple.iPhoto folder (Snow Leopard and Earlier).

    home.PNG

    or with Mt. Lion from the User/Library/Containers/com.apple.iPhoto/
    Data/Library/Caches/com.apple.iPhoto
    folder

     

    iP11mtlioncache.png

    3 - launch iPhoto and try again.

     

    NOTE: If you're moved your library from its default location in your Home/Pictures folder you will have to point iPhoto to its new location when you next open iPhoto by holding down the Option key when launching iPhoto.  You'll also have to reset the iPhoto's various preferences.

     

    NOTE 2:  In Lion and Mountain Lion the Library folder is now invisible. To make it permanently visible enter the following in the Terminal application window: chflags nohidden ~/Library and hit the Enter button - 10.7: Un-hide the User Library folder.