Skip navigation

iChat no longer works on local network

666 Views 3 Replies Latest reply: Feb 1, 2013 12:13 PM by Ralph Johns (UK) RSS
kanyfilm Level 1 Level 1 (0 points)
Currently Being Moderated
Jan 31, 2013 8:54 AM

i used to use ichat at work to message between co-workers on the same network.  now i have about 10 other people all with macs (prob with different OSs, but all with either iChat or messages) and with bonjour enabled, no one comes up in the buddy list.  i have added buddies, people i have chatted with in the past.

 

i did have the Messages beta and it expired and now iChat is back.  but i can;t find a simple way to communicate with my coworkers on the network.

 

what gives? 

 

thanks

keith

MacBook Pro, Mac OS X (10.7.1)
  • Ralph Johns (UK) Level 9 Level 9 (66,840 points)
    Currently Being Moderated
    Jan 31, 2013 2:02 PM (in response to kanyfilm)

    HI,

     

    Check your DNS settings.

    mDNS is Bonjour and it needs the DNS part of Networking to be working.

     

     

    3Sigcopy2.png
    10:02 PM      Thursday; January 31, 2013


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Ralph Johns (UK) Level 9 Level 9 (66,840 points)
    Currently Being Moderated
    Feb 1, 2013 12:13 PM (in response to kanyfilm)

    Hi,

     

    There is this Apple Doc. http://support.apple.com/kb/HT3789

    Basically some people used to turn Bonjour Off.

    At OS  X 10.6 Apple linked mDNS to the DNS service.

    Then turning mDNS Off also turned Off DNS, which in turn means you can't access the Internet properly.

     

    It obviously turns Off Bonjour as part of the process.

     

    I would also check if your router is in fact allowing Local Traffic.

    Although ports above 1024 are not open in  router by default they can be open to local traffic.

    Bonjour uses port 5353 to discover other Macs and Bonjour able devices.

    (iChat/Messages also uses ports 5297 and 5298)

     

    In the System Preferences > Security & Privacy > Firewall > Unlock the Pane and check Firewall Options

    In here make sure it is not set to Block All Incoming connections.

    Some outgoing connections may allow return data to arrive.

    NOTE:  I have not got a OS X 10.7 boot in front of me and the above are the Mountain Lion instructions.

    Other then Snow Leopard using an Advanced button instead of the Options button I see little changes between those two versions.

     

     

     

    Sigcopy2.png
    8:12 PM      Friday; February 1, 2013


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.