1 Reply Latest reply: Jan 31, 2013 1:28 PM by mende1
prabodh1 Level 1 Level 1

have old mac and need to down load facetime


MacBook, OS X Mountain Lion (10.8.2)
Reply by mende1 on Jan 31, 2013 1:28 PM Helpful

Welcome to the Apple Support Communities

 

First, open  > About this Mac, and check Version. If it is:

 

- 10.7 or 10.8: You have FaceTime on the Dock, so open FaceTime.

 

- 10.6: First, open  > Software Update and install the most recent version. Then, open App Store and purchase FaceTime.

 

- Older Mac OS X versions: Check if your Mac is compatible with Snow Leopard > http://support.apple.com/kb/SP575 Then, purchase Snow Leopard > http://store.apple.com/us/product/MC573/mac-os-x-106-snow-leopard

All replies