10 Replies Latest reply: Feb 2, 2013 5:15 AM by Frank Caggiano
Inscapes Level 1 (0 points)

hi Folks,


just purhased Aperture from the App Store for my MacBook Pro (4 year old, dual core, 4 gig ram, OSX 10.7.5)


I followed a support FAQ's instructions and trashed the installation, re-installed from the app store.


Same thing again, it crashes, with a long techno-gobbledegook message.


any hints on what I can do?


I could possibly install Aperture on my iMac, but again because I'm running

a slightly older OS (10.6.8 - and no, I don't want to 'upgrade'...), the recent version

of Aperture doesn't work in this system.  Unfortunate that Apple doesn't make

older versions available.


thanks for any suggestions ...

Aperture 3, Mac OS X (10.7.5)
  • léonie Level 10 (85,640 points)

    Please post the first 60 lines of the "long techno-gobbledegook message" you get, perhaps that will give us a clue what's going on




  • Frank Caggiano Level 7 (25,715 points)

    Is this a totally brand new install of Aperture? You never had an older version or tried the demo out?


    Also create a new user account on your machine and log into that account and try running Aperture. Post back the results. If it crashes there too post the crash log as Léonie suggested.

  • Inscapes Level 1 (0 points)

    Hi guys, thanks for input so far.  I trashed Aperture again (new version, not update), but have to go thru the difficult process of trying to find my purchase again and re-download it.  It's very challenging on the Apple site to get to this place.  When I do, I will try Frank's suggestion of the new user account.


    Here's the error message up to the point of where it identifies my computer:

    Process:     Aperture [3350]
    Path:        /Applications/Aperture.app/Contents/MacOS/Aperture
    Identifier:  com.apple.Aperture
    Version:     3.4.3 (3.4.3)
    Build Info:  Aperture-310022000000000~2
    App Item ID: 408981426

    App External ID: 12009533

    Code Type:   X86-64 (Native)

    Parent Process:  launchd [124]


    Date/Time:   2013-01-30 17:19:57.070 -0800
    OS Version:  Mac OS X 10.7.5 (11G63)

    Report Version:  9


    Interval Since Last Report:      2349902 sec
    Crashes Since Last Report:       9

    Per-App Interval Since Last Report:  58 sec

    Per-App Crashes Since Last Report:   3

    Anonymous UUID:                  18979737-F99B-4EE7-902A-E9699BF2CB16


    Crashed Thread:  0


    Exception Type:  EXC_BREAKPOINT (SIGTRAP)

    Exception Codes: 0x0000000000000002, 0x0000000000000000


    Application Specific Information:

    dyld: launch, loading dependent libraries


    Dyld Error Message:

    Library not loaded:


    Referenced from: /Applications/Aperture.app/Contents/MacOS/Aperture

    Reason: no suitable image found.  Did find:


    no matching architecture in universal wrapper


    no matching architecture in universal wrapper


    Binary Images:

    0x10899b000 -    0x1090f0fff  com.apple.Aperture (3.4.3 - 3.4.3)



    0x109314000 -    0x10931dff7  com.apple.PhotoFoundation (1.0 -

    10.17) <C40F985F-9C0A-389A-9E21-684EB0A5B160>

    /Applications/Aperture.app/Contents/Frameworks/PhotoFoundation.framework/Version s/A/PhotoFoundation

    0x109394000 -    0x1098b4fff  com.apple.RedRock (1.9.4 - 310.33)


    /Applications/Aperture.app/Contents/Frameworks/RedRock.framework/Versions/A/RedR ock

    0x109bbf000 -    0x109c42fff  com.apple.iLifePageLayoutCore (1.0

    - 200.9) <8AAC1EB9-5823-3624-A525-635C2A77C34E>

    /Applications/Aperture.app/Contents/Frameworks/iLifePageLayoutCore.framework/Ver sions/A/iLifePageLayoutCore

    0x109ca1000 -    0x109ca6fff

    com.apple.iLifePhotoStreamConfiguration (3.4 - 2.5)


    /Applications/Aperture.app/Contents/Frameworks/iLifePhotoStreamConfiguration.fra mework/Versions/A/iLifePhotoStreamConfiguration

    0x109cb3000 -    0x109ce4ff7  com.apple.iLifeAssetManagement

    (2.7 - 40.34) <E4E1A39C-E8AE-31D5-9C50-B392EBAD7447>

    /Applications/Aperture.app/Contents/Frameworks/iLifeAssetManagement.framework/Ve rsions/A/iLifeAssetManagement

    0x109d15000 -    0x109d22ff7

    com.apple.iphoto.AccountConfigurationPlugin (1.2 - 1.2)


    /Applications/Aperture.app/Contents/Frameworks/AccountConfigurationPlugin.framew ork/Versions/A/AccountConfigurationPlugin

    0x109d32000 -    0x109dd5ff7  com.apple.MobileMe (13 - 1.0.4)


    /Applications/Aperture.app/Contents/Frameworks/MobileMe.framework/Versions/A/Mob ileMe

      0x7fff6859b000 - 0x7fff685cfbaf  dyld (195.6 - ???)

    <0CD1B35B-A28F-32DA-B72E-452EAD609613> /usr/lib/dyld

      0x7fff8a58e000 - 0x7fff8a5daff7  com.apple.SystemConfiguration

    (1.11.3 - 1.11) <0A7F1982-B4EA-3424-A0C7-FE46C6224F03>

    /System/Library/Frameworks/SystemConfiguration.framework/Versions/A/SystemConfig uration

      0x7fff8a7ce000 - 0x7fff8a96eff7  com.apple.QuartzCore (1.7 - 270.5)



      0x7fff8af81000 - 0x7fff8b10bff7  com.apple.WebKit (7534.57 -

    7534.57.7) <15AA1A2E-DCAC-35CE-89DF-0FF7149198CD>


      0x7fff8cf65000 - 0x7fff8cf65fff  com.apple.Cocoa (6.6 - ???)



      0x7fff8f184000 - 0x7fff8f358ff7  com.apple.CoreFoundation (6.7.2 -

    635.21) <62A3402E-A4E7-391F-AD20-1EF20236CE1B>


      0x7fff8f674000 - 0x7fff8f6dfff7  com.apple.framework.IOKit (2.0 -

    ???) <FE838BB6-D42E-3291-A1A0-6F53FC970261>


      0x7fff907b0000 - 0x7fff907b6fff  com.apple.DiskArbitration (2.4.1 -

    2.4.1) <CEA34337-63DE-302E-81AA-10D717E1F699>


      0x7fff92748000 - 0x7fff92748fff  com.apple.ApplicationServices (41

    - 41) <03F3FA8F-8D2A-3AB6-A8E3-40B001116339>

    /System/Library/Frameworks/ApplicationServices.framework/Versions/A/ApplicationS ervices

      0x7fff92efe000 - 0x7fff9316aff7  com.apple.AOSKit (1.021 - 94)



      0x7fff9345c000 - 0x7fff9345cfff  com.apple.CoreServices (53 - 53)



      0x7fff93653000 - 0x7fff93662fff  com.apple.opengl (1.8.1 - 1.8.1)



      0x7fff93fe5000 - 0x7fff942daff7  com.apple.security (7.0 - 55148.6)



      0x7fff9552d000 - 0x7fff955c0fff  com.apple.PDFKit (2.6.4 - 2.6.4)


    /System/Library/Frameworks/Quartz.framework/Versions/A/Frameworks/PDFKit.framewo rk/Versions/A/PDFKit

      0x7fff956a5000 - 0x7fff956a5fff  com.apple.Carbon (153 - 153)



      0x7fff96be3000 - 0x7fff96be3fff  com.apple.Accelerate (1.7 -

    Accelerate 1.7) <82DDF6F5-FBC3-323D-B71D-CF7ABC5CF568>


  • Inscapes Level 1 (0 points)

    ps - tried creating new user and logging in; aperture crashed on that account as well.

  • Frank Caggiano Level 7 (25,715 points)

    Do you have Final Cut installed? The crash shows the classic symptoms of Aperture and Final Cut.


    If so the easiest thing to do is to reinstall the OS. It won't overwrite any of your user data it will just  put a fresh copy of the OS on your disk.


    Of course having a good working backup is always a good idea even more in cases like this.

  • Inscapes Level 1 (0 points)

    Hi Frank,


    I did install Final Cut Express on this machine; I believe Aperture was crashing before that as well.  I just bought this computer from a friend, and there's a copy of MS Office & Toast on it, which he's lost hte serials for; this software would likely not survive an OS re-installl.  Does Apple have access to any earlier versions of Aperture?




    (ps I believe Lion was purchased online as an upgrade to 10.5.6, which I have the system CD for)

  • Frank Caggiano Level 7 (25,715 points)

    re-install Lion and all will work .


    Earlier version of Aperture won;t fix it it is the interaction between the install of Aperture and Final Cut, once you have the problem the dynamic library that got messed (which is what the crash report shows) has to be put back on the system. The only way to fix that is to either try and dig it out of a backup or install the OS . Installing the OS is by far the easiest way to go.

  • léonie Level 10 (85,640 points)

    I just bought this computer from a friend, and there's a copy of MS Office & Toast on it, which he's lost hte serials for;

    Reinstall the system on top of your current system - don't wipe your disk. That will restore the corrupted PluginManager framework.

  • Inscapes Level 1 (0 points)

    thanks Frank, re-installing Lion was the ticket.

    much appreciated!

  • Frank Caggiano Level 7 (25,715 points)

    Glad it helped,