3 Replies Latest reply: Feb 1, 2013 9:04 AM by mmollo22
sapper Level 1 Level 1 (70 points)

I'm not sure if it's an OSX Mountain Lion or a Safari issue, but just today I'm now unable to play games on Facebook.

 

I'm being prompted to download the latest version of Adobe Flashplayer 11 which I have done about 5 times and still no joy.

 

What's more, is that the Installer is sitting there on the screen and the logo is on the dock, but I cant see it in any of the apps in Finder.

 

I also find that I can't view my purchases in Software Updates without signing in. Just what the **** is going on?

 

Result: Misery!!


iMac (20-inch Early 2008), OS X Mountain Lion (10.8.2), HP 3310 A-I-O, Epson Stylus CX5400
  • thomas_r. Level 7 Level 7 (30,540 points)

    Did you download Flash Player from here:

     

    http://get.adobe.com/flashplayer/

     

    Did you, after downloading it, run the installer? Did the installer complete? What games are you trying to play, and what is telling you to download Flash?

     

    One possibility is that some of the games you're trying to play are Java-based games, rather than Flash-based games. Java is extremely insecure, with four currently known vulnerabilities in the latest version at this point, so Apple has disabled it until Oracle gets their act together and puts out an update. However, this wouldn't explain why you're being told to download Flash.

     

    As for:

     

    I also find that I can't view my purchases in Software Updates without signing in.

     

    That's what I would expect. You have to be signed in in the App Store before you can view your purchases.

  • sapper Level 1 Level 1 (70 points)

    Hi Thomas, thanks for your quick reply.

     

    Firstly, each of the games I tried to play put up a tiny window at the top of the page advising me to download

    Flashplayer. I have done this 5 times, and have installed also 5 times. The games I have tried to play are Absolute Solitaire, Bejeweled Blitz. There are other games, but not too concerned with those. I see from iOS forums for iPad that Apple won't or can't approve Flashplayer.

    Here's what I get from 2 games:

     

    Screen Shot 2013-02-01 at 16.36.05.png

     

     

     

    and this comes up for each time I want to install.

     

    Screen Shot 2013-02-01 at 16.50.45.png

    Oddly enough, Absolute Solitaire is now playing, where earlier it threw up the same 'Update Flashplayer' warning window. Also, I'm now able to view my purchases without having to sign in. Something very weird is going on here!

     

    Here's what I have on my Safari preference pane relating to Security:-

     

    Screen Shot 2013-02-01 at 16.35.32.png

  • mmollo22 Level 1 Level 1 (110 points)

    Basic, but maybe a good question... did you QUIT safari and open it again?