7 Replies Latest reply: Feb 1, 2013 4:54 PM by Eric Root
Radnet Level 1 Level 1 (0 points)

I have a white unibody macbook 6.1 running 10.6.8 and I would like to upgrade so I can use icloud. what is my best option? as it looks like its too old to run mountain lion? thanks!


MacBook, Mac OS X (10.6.8)