7 Replies Latest reply: Feb 2, 2013 3:00 AM by Mac_o_phile
Artyom Ost Level 1 (0 points)

Hello,

 

I have MacBook Late 2008 (Unibody). And I can't install this firmware MacBook SMC Firmware Update 1.5

 

Need your help.

 

Thanks


MacBook (13-inch Aluminum Late 2008), OS X Mountain Lion (10.8.2)
  • Mac_o_phile Level 1 (0 points)

    What is the error message you are getting?

     

    I have downloaded the MacBook SMC Firmware Update 1.5. now a half-dozen times with different browsers and each time I get this message when I try to open the .dmg:

     

    http://i.imgur.com/r1p5pZ8.png

     

    I've seen the error before and ignored it with other .dmg files but with a firmware update that could brick my computer if anything goes wrong it's not very confidence inspiring at all.

  • Artyom Ost Level 1 (0 points)

    error message is "This software is not supported on your system"

  • Mac_o_phile Level 1 (0 points)

    If you want to Dropbox or put the 1.5 firmware update .dmg you downloaded on a file hosting service I will download it and if it doesn't have the error I showed in my post I will try to run the update on my computer and report back to you.

     

    MacBook 5,1 (late 2008) 2.4 GHz 8GB RAM 128GB SSD in the optical bay and 640MB hdd in the standard hdd bay, running ML 10.8.2.

  • Artyom Ost Level 1 (0 points)

    I have downloaded this one http://support.apple.com/kb/DL1625?viewlocale=en_US&locale=en_US. and also have tried other ones too, for air and pro.

  • Mac_o_phile Level 1 (0 points)

    That is the same one I downloaded but I get the error message that I linked to a screenshot in my reply to your original post when I try to open it. I need a known good working .dmg, that mounts without an error, to do the testing so I need you to upload your copy of the MacBookSMCUpdate1.5.dmg file somewhere that I can download it. As it mounts on your system with no warning I can at least isolate if my problem is with my computer or the .dmgs I'm getting from Apple. I can then try to install it and report back.

     

    I have a feeling we don't need the update. As per other discussions on this issue that I've read here today, people running 10.6 and later are not able to install it and the consensus seems to be it's been addressed in 10.6 and later. Still would like to try so if you upload your file somewhere I will give it a go.

  • Mac_o_phile Level 1 (0 points)

    OK, looking at this page: http://support.apple.com/kb/HT1237

     

    It says our computers should have SMC version 1.32f8 (SMC 1.2)

     

    I have: SMC Version (system): 1.40f2 which comes from the SMC 1.3 update. Weird!


    It appears that only the new MacBook needs the 1.5 update. Also, that page was updated just recently.

     

    I don't think we need this update.

  • Mac_o_phile Level 1 (0 points)

    Also, according the the 1.4 update page here: http://support.apple.com/kb/DL974

     

    It will update the Boot ROM version (on MB 5,1) to MB51.007D.003.

     

    Yet I have (MB 5,1) Boot ROM version MB51.007D.B03. Weird again!

     

    What a mess Apple. Considering how important firmware updates are you'd think they could make this a little clearer.

     

    Anyways, again, I don't think we need it.