Previous 1 2 3 Next 36 Replies Latest reply: Mar 26, 2013 6:00 PM by Shintz123 Go to original post Branched to a new discussion.
  • KillerShadow666 Level 1 Level 1 (0 points)

    Thank You wuzi36,


    I was getting the 9006 error (after i updated to 6.1 on a jb 4s) and could not rescue my 4s so i had a hunch that your way would save it.


    I can CONFIRM this method worked for me too


    Previously i tried to disable the anti-virus/firewall on windows 7 64bit BUT failed... So i did the following....


    • I just partitioned the hd and installed Windows 8 64bit (which i kinda like now after seeing it in action where and was reluctant to install it before^^).
    • Then i downloaded and installed iTunes 11.
    • All this time my 4s was in dfu mode.
    • Then i went through the restore process via iTunes (This will put your iphone back to factory settigs so make sure you have made a back up in iTunes BUT if you reading this then your iphone is not accessible then you cannot do backup oops).
    • And i saw my 4s come alive.............
    • Once it was restored i checked the OS and it was 6.1.

    I do not know if i can post links from other websites to help here, but i can if i get permission to from mods etc etc.


    <Edited by host>

  • ammoun Level 1 Level 1 (0 points)

    I had the problem with error -1 on my iPhone 4S trying to upgrade from 5.1.1 jailbroken to 6.1

    I disabled my antivirus and restarted my computer and the update worked (I had my iPhone connected to the my MacBookPro during the restart and it was in recovery mode).

    So, disable antivirus and restart and I hope you get your issue resolved.

  • grayfoxx122 Level 1 Level 1 (0 points)

    Ok, so I recently updated my 4S to 6.1 from 5.x (Jbroken) and i hook it up to both my PC and my fiance's PC and the 4S is stuck in "recovery". I get no errors and eveytime it tries to hook up to Itunes(on either PC) the message comes up that says it cannot connect to Iphone update server...?

  • Lawrence Finch Level 7 Level 7 (30,665 points)

    That's because the method that you used to JB corrupted the network database on your computer. You need to fix your hosts file, delete any records that contain If that doesn't fix it it's likely that you altered the baseband on your phone. There's no easy solution for that, and any solution must come from a source other than an Apple-hosted forum.

  • grayfoxx122 Level 1 Level 1 (0 points)

    Where do I find the Hosts file?

  • Lawrence Finch Level 7 Level 7 (30,665 points)

    My first thought is that if you don't know where the hosts file is you shouldn't have hacked a phone, but, assuming you have Windows:







  • crosshelder Level 1 Level 1 (0 points)

    Hi there, I'm stuck with the same problem!


    I have Iphone 4s 5.0.1 JB tried to update to 6.1 and it's always with error 21. Have tried in 4 pc one with windows 8 fresh install and nothing solves the problem. Is there any other program besides itunes that updates iphone? is this a problem of the update and so my iPhone is still under warranty and they have to fix it?



  • Lawrence Finch Level 7 Level 7 (30,665 points)

    You are getting that error because your phone is jailbroken. There is nothing wrong with the update, you have turned your phone to trash. Apple's warranty is void for jailbroken phones; they do not have to fix it for you.

  • Soss32 Level 1 Level 1 (0 points)

    My Iphone has never been jailbroken and I'm getting the same errors. I don't  believe in coincidence of having hardware problem exactly at the time 6.1 update was installed. I'm against JB and so would like to find
    Apple recommended way to fix my phone. So far all suggestions I found are not working at all! It's frustrating because for over a week now I'm forced to use my old phone as a backup. I'm not willing to pay for another smartphone because software updating process has flaws.

  • Kwintenc Level 1 Level 1 (0 points)

    Since some people are bringing jailbreaking into this discussion, I feel like I should note that this iPhone 4S has NOT EVER been jailbroken. At the time of my original post, there wasn't even a jailbreak available for iOS 6.


    Also, update: I still haven't been able to fix the problem. Probably going to have to send it back sometime next week.

  • Lawrence Finch Level 7 Level 7 (30,665 points)

    The message i responded to stated that the phone was jailbroken. If yours is not you have a different problem. What specific error code are you seeing?

  • Lawrence Finch Level 7 Level 7 (30,665 points)

    Both of the errors that you report (1611 and 21) are related to security software blocking the update. If turning off firewall and antivirus doesn't resolve the problem you may have to actually uninstall the antivirus. This is especially true if you are using Kaspersky, which can never be completely turned off and which is known to block iPhone updates.


    Another thing to try is to update using a different computer, or create a new user ID on your computer and try updating logged in to that computer.


    Also, occasionally the TCPWindowSize parameter in the Windows Registry can interfere with an update if it is different from the default. Fixing that is beyond the scope of a post in this forum, but you can find information on it on the Internet.

  • Kwintenc Level 1 Level 1 (0 points)

    Thanks for the help so far, Lawrence.


    As stated in my original post, I have tried restoring on many different computers, in both Windows (7 & 8) and OS X (10.8). As such, I firmly believe that security software is not the issue here, as I have both deleted my antivirus software (Microsoft Security Essentials) and turned off my firewalls while trying to troubleshoot this issue. I also made sure that my hosts files in both Windows and OS X are configured correctly.


    I have also tried the TCPWindowSize thing you mentioned but sadly that didn't work either.

  • janiceappel Level 1 Level 1 (0 points)

    Problem is pretty simple. Iphone sent message to update in settings. Clicked ok. Stuck with image of Itunes and beneath image is the word Itunes with arrow beneath that and image of USB cable below that.


    If you try to call the phone you can hear voice mail picking up the call. Cannot do anything but look at the above described screen.


    Tried 2 things - 1) power off and restart 2) Tried hooking up to MacBook Air laptop thinking maybe itunes could fix problem and Itunes said that the phone needed to be restored - which then says it would erase the contents of the phone.


    Phone does not have antivirus. The phone has never been tampered with.


    Any help would be greatly appreciated.

  • snoebreeze Level 1 Level 1 (0 points)

    Try a Ipsw 6.1